python3 and urwid versions issue

Questions about applications and software
Forum rules
Before you post please read this

python3 and urwid versions issue

Postby antib on Tue Jan 08, 2013 11:22 am

Hi there. Current OS - lately installed LMDE. I learn python programming, using python 3.2.3 and python3-urwid 1.0.1-2 installed from repos. Sadly current latest stable version of urwid is 1.1.1, and tutorials written for this version are not compatible with python3 and urwid versions, available from LMDE repos. Even if I will replace python3-urwid by latest, still python3.2.3 won't support widely used strings like u"text", widely used in python3-urwid source and examples.

I tried to install latest version of python - I made deb file from latest python by checkinstall, but this python3.3.3.deb didn't replaced python3.2.3, and standard python modules were not importable for python3.3.3. Also it was impossible to uninstall python3.3.3 by synaptic or aptitude, and uninstalling of python 3.2.3 crushed half of system.

How can I SAFELY upgrade python3?
Last edited by xenopeek on Tue Jan 08, 2013 12:08 pm, edited 1 time in total.
Reason: LMDE, so moved here.
antib
Level 1
Level 1
 
Posts: 2
Joined: Sun Nov 11, 2012 4:15 am
Location: Russia, Saint-Petersburg

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 7 guests