Really can't get flashplayer to work, tried too many ways.

Questions about applications and software
Forum rules
Before you post please read this

Really can't get flashplayer to work, tried too many ways.

Postby squiesuie on Thu Jan 10, 2013 1:55 pm

Hello.
Here comes a newbie who needs help. I hope I post in the right section, I didn't put this in the newbie section because I suspect there is no easy answer to my problem.

Anyway... I have just installed Linux Mint 14 MATE on an older pc, running dualboot with win Xp. When installing Mint I had a problem with the installer. It crashed when starting to show the slideshow during the installation process. I fixed this using
Code: Select all
sudo apt-get remove ubiquity-slideshow-mint
to remove the slideshow. After this, the installation went smooth, I thought...

BUT, I haven't been able to open any flash clip from youtube or any other source. I have read these forums about many different flash problems, (I have had too many problems with flash in windows also) and tried many different suggestions that where supposed to solve the problems. I have tried installing/re-installing different versions of flashplayer, tried firefox, opera and chrome, and haven't got any flash clip to play. I only get a black screen or a symbol saying flash have crashed/ no flash installed or something, I soon don't rember everything I have got or I have tried, but nothing I have done seems to be working, that's for sure. According to the forums sources, flash should be working with firefox directly after installation, otherwise nobody seems to have much clue what could be wrong. Somewhere I saw someone suggesting the installation slideshow crash could have something to do with flash not working, but no suggestion to how or why. I hope someone here could try to help me. Please tell me what more information could be needed to help solve my problem, and I will try to give any information I can. Now I don't really know what to do.
Last edited by squiesuie on Thu Jan 10, 2013 2:35 pm, edited 1 time in total.
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Linux Mint is funded by ads and donations.
 

Re: Really can't get flasplayer to work, tried too many ways

Postby viking777 on Thu Jan 10, 2013 2:08 pm

Please open a terminal and run this command:

Code: Select all
apt-cache policy mint-flashplugin*


Post the result.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Really can't get flasplayer to work, tried too many ways

Postby squiesuie on Thu Jan 10, 2013 2:16 pm

Ok. Hope this helps, what am I looking at?
$ apt-cache policy mint-flashplugin*
mint-flashplugin:
Installed: (none)
Candidate: 2011.10.19
Version table:
2011.10.19 0
700 http://debian.lth.se/linuxmint/ nadia/main i386 Packages
mint-flashplugin-x64:
Installed: (none)
Candidate: (none)
Version table:
mint-flashplugin-11:
Installed: 11.2.202.243
Candidate: 11.2.202.243
Version table:
*** 11.2.202.243 0
700 http://debian.lth.se/linuxmint/ nadia/import i386 Packages
100 /var/lib/dpkg/status
mint-flashplugin-10.2:
Installed: 10.2.153.1
Candidate: 10.2.153.1
Version table:
*** 10.2.153.1 0
700 http://debian.lth.se/linuxmint/ nadia/import i386 Packages
100 /var/lib/dpkg/status
mint-flashplugin-10.3:
Installed: (none)
Candidate: 10.3.180.65
Version table:
10.3.180.65 0
700 http://debian.lth.se/linuxmint/ nadia/import i386 Packages
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby viking777 on Fri Jan 11, 2013 5:25 am

I just wanted to see that you had mint-flashplugin installed - which you do although strangely you have two versions of it so maybe they are conflicting (I can't be sure though). So try this in your terminal:

Code: Select all
sudo apt-get purge mint-flashplugin-10.2


Then reboot and have a look. It might not work, but it certainly won't do any harm.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 6:21 am

viking777 wrote:I just wanted to see that you had mint-flashplugin installed - which you do although strangely you have two versions of it so maybe they are conflicting (I can't be sure though). So try this in your terminal:

Code: Select all
sudo apt-get purge mint-flashplugin-10.2


Then reboot and have a look. It might not work, but it certainly won't do any harm.


Ok. I did this but no change. Still no working flashplayer. Any ideas what could be the problem?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby viking777 on Fri Jan 11, 2013 6:31 am

Given the amount of research you have done into this I am sure you will have tried something like this before, if you have already done so and got nowhere, then there is probably no point in repeating it, but if you haven't open Firefox and type about:plugins into the address bar and press enter. I get something like this:

Code: Select all
Shockwave Flash

    File: libflashplayer.so
    Version:
    Shockwave Flash 11.2 r202

MIME Type    Description    Suffixes
application/x-shockwave-flash    Shockwave Flash    swf
application/futuresplash    FutureSplash Player    spl


Do you get something similar?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 6:50 am

About:plugin show me this about flash
Code: Select all
Shockwave Flash

    File: libflashplayer.so
    Version:
    Shockwave Flash 11.2 r202

MIME Type    Description    Suffixes
application/x-shockwave-flash    Shockwave Flash    swf
application/futuresplash    FutureSplash Player    spl

No different to yours what I can see, but the shockwave flash part do show up twice in the enabeled plugins list, both at the top and the bottom of the list, both identical. Could this mean anything?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby meteorrock on Fri Jan 11, 2013 7:54 am

I want you to try opera linux at this link here. I got flashplayer working using that browser. Choose the correct browser version at this link, there are different download for 32 and 64 bit linux builds. Make sure you have adobe flashplayer installed. If you do not then skip down to the last paragraph. If you already have it installed see below. http://www.opera.com/browser/download/?custom=yes

Check your PATH variable for your plugins in the options here after you have downloaded Opera. It should include your flashplayer for youtube. Sometimes you will need to correct the path variable for your plugins if your flashplayer got downloaded elsewhere by default. Go to the opera tab up in the top left hand corner. Go down to settings >> preferences >> advanced >> content. Make sure that plug in is checked marked on that page.

Then go into "plug in options." Make sure your path variable is set to /usr/lib/opera/plugins/ this is the default PATH variable for you plugins. You can also select which plug in you want in there.

Lastly check this setting here in the settings of your Opera 12.12 for linux, Page >> developers tools >> plugins. Make sure that page is checked marked to "enable plug ins."

Check also if you have the correct flashplayer in the correct directory, it should be located in the above directory, the /usr/lib/opera/plugins/ , it is called a libflashplayer.so. If not you will have to download the adobe flashplayer at thier website here. http://get.adobe.com/flashplayer/
meteorrock
Level 3
Level 3
 
Posts: 122
Joined: Tue Jan 08, 2013 2:24 am

Re: Really can't get flashplayer to work, tried too many way

Postby kc1di on Fri Jan 11, 2013 8:13 am

Hello squiesuie,

Don't know how your making out with your flash problem but I suspect since it seems to be across all you browers that it's a hardware problem.

That being said ,
please do the following and try it again.

in a terminal type:
Code: Select all
sudo apt-get purge mint-flash

then
Code: Select all
sudo apt-get install adobe-flashplugin


when that is finished open up Firefox and try a flash file , if it still crashes, right click on the black screen and go to setting and uncheck hardware excelleration.
and try again.

let me know how that works for you.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1441
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 8:23 am

Hello meteorrock. Yes I have been trying with Opera also, but no sucess so far. I tried checking your points, as far as I can understand plugins are enabeled and in the plug in path I have:
Code: Select all
usr/lib/opera/plugins:/usr/lib/adobe-flashplugin:/usr/lib/mozilla/plugins:/usr/lib/xulrunner-addons/plugins
can this be correct?

If I open "about opera" there is a list of paths, where I have:
Code: Select all
Plug-in path
/usr/lib/opera/plugins
/usr/lib/adobe-flashplugin
/usr/lib/mozilla/plugins
/usr/lib/xulrunner-addons/plugins
Can this be correct?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 8:33 am

Hello kc1di,
yes it could be a hardware problem, but I still think I have something strange with my flashplayer installation. I would like to rule out a software problem first.

When i type
Code: Select all
sudo apt-get purge mint-flash
I got
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package mint-flash
This cant be right? I have installed mint flashplayer, or have I ? Or is this another version? Shall I try
Code: Select all
udo apt-get install adobe-flashplugin
anyway?

As it is now in firefox I can't right click on the black screen in for example youtube, nothing happens it is just a black screen.
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby kc1di on Fri Jan 11, 2013 9:39 am

Ok

go to the file manager and navigate to the following file see if you have
Code: Select all
 libflashplayer.so
file located there.
/usr/lib/mozzila/plugins
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1441
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 12:58 pm

Ok kc1di,
my /usr/lib/mozzila/plugins folder is empty, could this be the problem? How shall I fix this? I thought I had istalled and reinstalled flashplayer many times already but apparently it is still missing.
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby kc1di on Fri Jan 11, 2013 1:02 pm

squiesuie wrote:Ok,
my /usr/lib/mozzila/plugins folder is empty, could this be the problem? How shall I fix this? I thought I had istalled and reinstalled flashplayer many times already but apparently it is still missing.

yes that is the problem. All the browser except maybe Opera look in /usr/lib/mozilla/plugins for the flashplayer.

Let's try this again =
go to a terminal and type:
Code: Select all
sudo apt-get install adobe-flashplugin


then check to see if libflashplayer.so is in /usr/lib/mozilla/plugins
if not we will do it the hard way.
Last edited by kc1di on Fri Jan 11, 2013 5:44 pm, edited 1 time in total.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1441
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 1:10 pm

Ok kc1di,
This is what happens then
Code: Select all
$ sudo apt-get install adobe-flashplayer
[sudo] password for :
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package adobe-flashplayer

How should I do now then?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 1:26 pm

Ok viking777, I saw a post from you that dissapered suddenly?
can my symlink be broken then? How can I check this? And is there any good single way to check if my flashplayer really is installed as it should be?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby viking777 on Fri Jan 11, 2013 1:32 pm

Yes it disappeared because after I had written it I remembered that I had made some changes to locations of flash files when experimenting with a new browser so I wasn't sure it was correct until I investigated further.

I am now sure I was correct and I would like you to try running this command:

Code: Select all
sudo update-alternatives --auto mozilla-flashplugin
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Really can't get flashplayer to work, tried too many way

Postby squiesuie on Fri Jan 11, 2013 1:38 pm

Ok. I tried
Code: Select all
$ sudo update-alternatives --auto mozilla-flashplugin
[sudo] password for :
-desktop ~ $

Nothing seems to happen? Something wrong here?
squiesuie
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2013 1:19 pm

Re: Really can't get flashplayer to work, tried too many way

Postby zerozero on Fri Jan 11, 2013 1:44 pm

the correct command to install adobe flashplayer is
Code: Select all
sudo apt-get install flashplugin-installer
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Really can't get flashplayer to work, tried too many way

Postby viking777 on Fri Jan 11, 2013 1:53 pm

Nothing seems to happen? Something wrong here?


Sorry, wrong target it should be:

Code: Select all
sudo update-alternatives --auto libflashplayer.so


But it may be it doesn't have any alternative so it won't work, but the other purpose of the command is to rebuild the symlink chain in case it is broken so it is still worth trying.

Or here is another one to try along the same lines:

Code: Select all
sudo update-alternatives --config libflashplayer.so


It gives a bit more output so might give a clue.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: cybercloud, mosi13 and 27 guests