LM13 Xfce loses window manager periodically

Forum rules
Before you post please read this

LM13 Xfce loses window manager periodically

Postby phil on Sun Jan 06, 2013 6:40 pm

I am not sure if this is a bug or something I did wrong, but at randm times xfwm4 quits running. I fix it by running "xfwm4 --replace" on a terminal and everything is o.k. again for a while. Any ideas??
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Linux Mint is funded by ads and donations.
 

Re: LM13 Xfce loses window manager periodically

Postby jungle_boy on Mon Jan 07, 2013 8:16 pm

LM13 uses xfce 4.8 with many bugs, all fixed in xfce 4.10 (LM14).
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1213
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: LM13 Xfce loses window manager periodically

Postby Matt267 on Mon Jan 07, 2013 10:05 pm

I've also started having the same issue within the last month and according to "inxi -S" I'm running xfce 4.10

Code: Select all
matt@matt-mint13 ~ $ inxi -S
System:    Host: matt-mint13 Kernel: 3.2.0-23-generic i686 (32 bit) Desktop: Xfce 4.10.0 Distro: Linux Mint 13 Maya


Maybe it's fixed in Mint14.

Matt
Matt267
Level 3
Level 3
 
Posts: 150
Joined: Sat May 07, 2011 7:53 am
Location: Rhode Island, USA

Re: LM13 Xfce loses window manager periodically

Postby phil on Tue Jan 08, 2013 9:34 am

I am also running Xfce 4.10, definitely not fixed for me.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: LM13 Xfce loses window manager periodically

Postby jjaythomas on Tue Jan 08, 2013 11:20 pm

LM13 uses xfce 4.8 with many bugs, all fixed in xfce 4.10 (LM14)


The Ubuntu 12.04 base is actually using the 4.8 Mint13 went with a PPA to default to xfce4.10. :o

anyways (I use LMDEs) see if 'nautilus or nautilus-data' installed (use synaptic) was causing alot of trouble in LMDE-Xfce where install as default (from ISO).

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: LM13 Xfce loses window manager periodically

Postby Barnabooth on Wed Jan 09, 2013 10:41 pm

This is long-winded, but I wrote it as an aide-memoire.
I am running an HP-Compaq dc5100 Pentium (R)4 3.20 with 796 M of RAM.
I have been running Ubuntu 10.04 without difficulty since it came out. It has served me very well, but I was not feeling enthusiastic about the more recent changes in Ubuntu, and decided to try Linux Mint.
I installed Linux Mint 13 Cinnamon (32 bit), but found it painfully slow, and the Software Manager froze constantly. I thought this was probably caused at least in part by my limited RAM, and I did a fresh installation with Linux Mint 13 Xfce. This I found very speedy, but I found that the Software Manager was as buggy as ever. Thus when Linux Mint 14 Xfce arrived, I decided to install it at once.
I had installed 13 from a USB key without difficulty, after two or three sessions where I ran the computer from the key; I tried to repeat the process (installing the ISO on the same key). Although I was again able to run the computer from the key, when I attempted installation it hung...although it did remove 13! My good luck: for once I had been careful about my backups. Using another computer, I downloaded the ISO again and installed it to another USB key, and this time the computer refused to boot from the key at all (I had verified the Checksum). It continued to boot from the first key happily.
I burnt the ISO to a DVD, and finally was able to install Linux Mint 14 Xkfe. It is just as fast as 13 and the Software Manager works.
Now my troubles started.
Two days ago (I had been running 14 for perhaps 3 days without trouble) I opened Firefox, and found that when I clicked on Bookmarks, the menu closed as soon as I attempted to choose a particular bookmark. I assumed the problem was particular to Firefox and—once I realized I xfwm4could browse through the bookmarks with the keyboard—I tried looking for Firefox help. In the meantime I had realized that the Max/Min/Close buttons had vanished from the window, and eventually realized that the problems were the same with any file or document I opened.
Looking online I didn't see any suggestions that jumped out at me, and I had found that I could not open Window Manager in the Control Centre, and that although I could open a terminal it would not allow me to type in commands, so I simply reinstalled (from the same DVD.
The problems returned within a few hours, although for the moment the terminal accepts commands. After each application I installed Adblocker, Ghostery, and Multicolumn bookmarks on Firefox.
I found this thread:
viewtopic.php?f=110&t=113058
and entered “xfwm4”, and suddenly everything worked. But I am going to be very careful with my backups from here on in—I found this extremely wearing!
Barnabooth
Level 1
Level 1
 
Posts: 26
Joined: Wed Jan 09, 2013 10:32 pm

Re: LM13 Xfce loses window manager periodically

Postby jungle_boy on Wed Jan 09, 2013 11:15 pm

OK Barnabooth;

Great tip reinstall xfwm4; keep us informed if everything is working well.
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1213
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: LM13 Xfce loses window manager periodically

Postby jjaythomas on Thu Jan 10, 2013 6:37 pm

Great tip reinstall xfwm4; keep us informed if everything is working well.

yep thats the way to do it. (not really reinstall its their just not the running WM anymore). :(
BUT
unless uninstall Nautilus and data (might) keeps happening . If uninstall (watch what also goes (and install alternative if need be) and if install anything watch if 'nautilus/nemo a dependency. :wink:

J.Jay

P.S. runinning settings>window manager and/or tweaks is a good way to see (the both only run if xfwm4 running) :wink:
Edit** Forgot to state 'Compiz' also a WM remember.
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: LM13 Xfce loses window manager periodically

Postby knitter on Thu Jan 10, 2013 10:16 pm

This sounds very much like what I'm experiencing.

I came here to report this problem, but didn't know how to describe it. It happened a few weeks ago for the first time under xubuntu. I then moved to linux mint xfce 13. It ran well for a short while - then it started happening in mint too. I had difficulty getting anything to reinstall (different distros even) after that. Finally, I got WattOS installed. It runs nicely, but I miss Mint. I then got Mint (xfce 13) to install as a dual boot next to WattOS. All seemed fine for a couple weeks - until tonight. It's like the edges of all the windows vanish - and I can't make things behave properly. Thank heavens you explained the problem - because I'm too much of a newbie to explain such things. (I'm booted in WattOS right now or I'd be sunk.)

So - having said that - I don't actually understand what the others have posted for solutions. How do I fix this exactly? Could you walk me through sort of step by step, so I don't mess it up?

Thanks in advance. Eager to have my Mint back!

PS: I can't move up to Mint 14 because my computer doesn't support PAE apparently. (Thinkpad R51)
knitter
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 13, 2012 3:19 am

Re: LM13 Xfce loses window manager periodically

Postby knitter on Thu Jan 10, 2013 11:12 pm

I understand how to fix it now! Hurray. :D

Here is what I learned on an old post on the xfce forum:

Just a note, you don't need to delete your Sessions. That makes for a huge pain in the butt for some, just restart xfwm4 (press ALT+F2, enter xfwm4 and click Ok) and save your Session o


I found that info here:
http://forum.xfce.org/viewtopic.php?pid=22504#p22504

For me, as a newbie who understands very little, I could understand these directions. (I'm not very clever, I have to admit.) I hope maybe by posting it here it might help other newbies who have this problem.
knitter
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 13, 2012 3:19 am

Re: LM13 Xfce loses window manager periodically

Postby Matt267 on Fri Jan 11, 2013 7:14 am

knitter,

Hopefully that will solve it for you. I have done that but will still randomly loose the windows manager.

Matt
Matt267
Level 3
Level 3
 
Posts: 150
Joined: Sat May 07, 2011 7:53 am
Location: Rhode Island, USA

Re: LM13 Xfce loses window manager periodically

Postby jjaythomas on Fri Jan 11, 2013 1:39 pm

Hopefully that will solve it for you. I have done that but will still randomly loose the windows manager.


I really think seeing if nautilus/nemo and/or data their. Don't happen to me BUT a uninstall nautilus 1st thing on install. :wink:

Hate to see Xfce get a Bum wrap because nautilus was installed.

J.Jay
P.S. I believe theirs also a setting in nautilus to tell it not to manage desktop (never tried myself).
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests