Sound only comes through headphones not speakers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Sound only comes through headphones not speakers

Postby voodoodoc2 on Sat Dec 22, 2012 10:05 pm

I have a Thinkpad W530 and a strange sound problem. Sound works fine through headphone jack, but will not come out of the speakers. I think it used to when I first setup Linux Mint (14) but not sure what could have caused this. Anyone heard of such a thing before?
voodoodoc2
Level 1
Level 1
 
Posts: 17
Joined: Sat Dec 01, 2012 1:04 am

Linux Mint is funded by ads and donations.
 

Re: Sound only comes through headphones not speakers

Postby mank_in on Sun Dec 23, 2012 9:00 am

run in terminal :
Code: Select all
alsamixer

If you see PCM or front with MM (mute ) , unmute with m keys.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Sound only comes through headphones not speakers

Postby voodoodoc2 on Mon Dec 24, 2012 5:28 pm

mank_in wrote:run in terminal :
Code: Select all
alsamixer

If you see PCM or front with MM (mute ) , unmute with m keys.


Yeah, that's the first thing I tried. Interestingly enough, when I plug or unpug the headphone alsamixer changes and recognizes what is going on, but nothing is muted and volume levels are up.
voodoodoc2
Level 1
Level 1
 
Posts: 17
Joined: Sat Dec 01, 2012 1:04 am

Re: Sound only comes through headphones not speakers

Postby arfonzo on Fri Jan 11, 2013 6:46 am

Hi, I have exactly the same problem. The thing is I had sound during the OS installation process, and I have a small sound when Mint is starting up. After that, as you said, sound only via the headphones.

Any solution?
arfonzo
Level 1
Level 1
 
Posts: 2
Joined: Thu Jan 10, 2013 9:22 am

Re: Sound only comes through headphones not speakers

Postby cgrosso on Fri Feb 22, 2013 7:11 pm

arfonzo wrote:Hi, I have exactly the same problem. The thing is I had sound during the OS installation process, and I have a small sound when Mint is starting up. After that, as you said, sound only via the headphones.

Any solution?


Hi,

I've exactly the same problem here... w530 without speaker sound (with headphones works perfectly).
Just a warning to all comunity, I've tried to install realtek HD audio driver and its simply blown up all the sound drivers, driving me to fresh reinstall all the system again...

Does anyone find a solution\workaround for this?

Thanks
cgrosso
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 6:40 pm

Re: Sound only comes through headphones not speakers

Postby bigj231 on Fri Feb 22, 2013 7:20 pm

Did you check and make sure that the "connector" in your sound settings output tab is set to speakers and the hardware tab is set to analog duplex?
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Sound only comes through headphones not speakers

Postby cgrosso on Fri Feb 22, 2013 8:13 pm

yap, everything checked...
Strange thing is when mint boots, it plays the startup sounds by the speakers, but after i login they be muted (and the volume isn't muted, checked in volume control and alsamixer...) and the only playback sound is by the headphones channel...

It looks like a conflict... i've checked the logs but i can't figure out the problem...
cgrosso
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 6:40 pm

Re: Sound only comes through headphones not speakers

Postby h5oj on Mon Mar 25, 2013 1:31 am

I have a similar problem with Mint 14 on a T430S but it seems like disabling the auto-mute "feature" in alsamixer may solve the problem.
h5oj
Level 1
Level 1
 
Posts: 1
Joined: Mon Mar 25, 2013 1:27 am

Re: Sound only comes through headphones not speakers

Postby kurtschoen on Wed Mar 27, 2013 12:41 am

Try this:

1. Go to Software Manager and install the GNOME ALSA Mixer, or install from the Terminal
2. Go to this link:
https://code.launchpad.net/~ubuntu-audi ... /+packages

- Click on the Quantal package
- Click on the .deb package
- Click on "Save File"
- When the "Downloads" box pops up, click on the new download and then click on "Install"
- Restart computer and then test it out. You should be able to close computer lid, suspend, and then hear sound from the speakers when resuming.
kurtschoen
Level 1
Level 1
 
Posts: 27
Joined: Mon Jul 04, 2011 2:31 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 17 guests