problem launching Firefox at start-up—Solved

Forum rules
Before you post please read how to get help

problem launching Firefox at start-up—Solved

Postby Barnabooth on Wed Jan 09, 2013 11:05 pm

January 9th, 2013
When I installed Linux Mint 14 Xfce 32 bit, I wanted Firefox to launch at start-up. It does, but opens to the message:
Server Not Found
Firefox can't find the server at www.%u.com.
It doesn't seem to matter what I have actually chosen as a homepage—I have tried the Linux Mint website and Google, and it always looks for www.%u.com.
Any advice?
Last edited by Barnabooth on Mon Jan 21, 2013 7:57 pm, edited 1 time in total.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Linux Mint is funded by ads and donations.
 

Re: problem launching Firefox at start-up

Postby igor83 on Thu Jan 10, 2013 4:11 am

Barnabooth wrote:January 9th, 2013
When I installed Linux Mint 14 Xfce 32 bit, I wanted Firefox to launch at start-up. It does, but opens to the message:
Server Not Found
Firefox can't find the server at www.%u.com.
It doesn't seem to matter what I have actually chosen as a homepage—I have tried the Linux Mint website and Google, and it always looks for www.%u.com.
Any advice?


The trouble is you are specifying an invalid command-line option. Eliminate the %u on your command line. If you enter "firefox %u", then firefox will attempt to open the page at www.%u.com. Open a terminal right now and try it and see. It does not matter what your home page is, if you specify %u on the command line, that is the "web site" you are going to.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: problem launching Firefox at start-up

Postby zerozero on Thu Jan 10, 2013 10:46 am

Barnabooth,
i removed your other (duplicated) topic regarding the same subject.
see the forum rules viewtopic.php?f=17&t=83444 point [7]
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: problem launching Firefox at start-up

Postby Barnabooth on Thu Jan 10, 2013 5:01 pm

My apologies for the duplicated post—I'm not sure how I was that sloppy.
This problem arose when, launching Firefox from the menu, I saw that on right-clicking "Firefox Web Browser" I was offered a check-box for "Launch when I log-in".
I did not understand the response mentioning the command line...is this to say that when startup tries to launch Firefox, there is a line mistakenly telling it to go to www.%u.com? And that, using the terminal, I could rewrite that instruction?
Would I then have to rewrite that instruction, if I wanted to change my homepage on Firefox? I was originally thinking that launching Firefox at start-up would be efficient—I would be shutting it down one time out of five, rather than starting it four times out of five, which appealed to my lazy nature!
But if there is a way of fine-tuning "Launch when I log-in" (command line or not) I would appreciate the input.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby jungle_boy on Thu Jan 10, 2013 6:28 pm

I tried now following:

Settings>Xfce settings>start-up session>application auto-start (3rd tab)

Add button

Name: Firefox

Command: firefox

Ok

Reboot and firefox start automatically...

Here works fine...
Last edited by jungle_boy on Fri Jan 11, 2013 8:08 am, edited 1 time in total.
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: problem launching Firefox at start-up

Postby igor83 on Fri Jan 11, 2013 1:21 am

Barnabooth wrote:My apologies for the duplicated post—I'm not sure how I was that sloppy.
This problem arose when, launching Firefox from the menu, I saw that on right-clicking "Firefox Web Browser" I was offered a check-box for "Launch when I log-in".
I did not understand the response mentioning the command line...is this to say that when startup tries to launch Firefox, there is a line mistakenly telling it to go to www.%u.com? And that, using the terminal, I could rewrite that instruction?
Would I then have to rewrite that instruction, if I wanted to change my homepage on Firefox? I was originally thinking that launching Firefox at start-up would be efficient—I would be shutting it down one time out of five, rather than starting it four times out of five, which appealed to my lazy nature!
But if there is a way of fine-tuning "Launch when I log-in" (command line or not) I would appreciate the input.


Precisely.
You have specifed "firefox %u" as your command, so firefox is taking you to %u.
You may not get a whole lot of surfing done at %u.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: problem launching Firefox at start-up

Postby Barnabooth on Fri Jan 11, 2013 2:26 pm

I repeat, I did not "specify" this address—I used the option available in the munu. This option apparently works, sometimes, as evidenced by the post earlier by jungle_boy.
I have removed the checkbox in the menu, restarted, replaced the checkbox, and restarted again, without result.
The problem is only a minor annoyance, but if anyone has experienced it, and corrected it, I would be pleased to hear—if not, I'll try it on a Firefox forum.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby zerozero on Fri Jan 11, 2013 2:33 pm

probably with a picture it's better
snapshot109.png
snapshot109.png (35.58 KiB) Viewed 2705 times

you see that % in the end of the command? FF is launching that as internet address. remove that part and try again.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: problem launching Firefox at start-up

Postby Barnabooth on Fri Jan 11, 2013 4:21 pm

Beauty! Thank you very much.
Unfortunately, this has lead to the realization that when I click on "Edit Properties", nothing happens...
Nor does it function with any other program I click on.
I have started reading about Xfce menus, but haven't found anything germane yet.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby jungle_boy on Fri Jan 11, 2013 4:57 pm

In Command input field write firefox, close and done!
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: problem launching Firefox at start-up

Postby Barnabooth on Fri Jan 11, 2013 8:45 pm

When jungle_boy refers to the "command input field" are we talking about the search-bar in the bottom right of the menu?
If so, I entered Firefox there, wondering if this would be a slantwise way of accessing properties, but there seemed to be no difference. However, since then, I have rebooted three times, and Firefox has opened each time to my homepage—this feels a bit like voodoo...or the problem may be an intermittent.
And Properties continues to refuse to open. If Firefox continues to behave, I will start another thread.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby Barnabooth on Sat Jan 12, 2013 10:29 am

I was too optimistic: it has returned to opening to "Firefox%u", so the bug is intermittent. I have also had difficulties with window manager, which are also intermittent, and are corrected as soon as I enter "xfwm4" in the terminal...I see no connection, but I have to wonder.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby jungle_boy on Sun Jan 13, 2013 10:32 am

Right click on desktop>Choose "Create launcher", will appear the picture below; in name field put firefox; and in command field put firefox and done!

I tried here no my laptop running LM14 xfce and it works fine...

Image

Image
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: problem launching Firefox at start-up

Postby Barnabooth on Sun Jan 13, 2013 4:42 pm

I decided to follow jungle_boy's advice, and simply install a desk-top launcer for the moment (thank you).
I still would like to launch Firefox automatically (well, I can, but I want it to go to the right address) but that seems to be part of the larger problem of my being unable to access "Edit Properties"...
I was interested to see that when I began entering "Firefox" into the first field of "Create Launcher" the other fields were immediately filled in—including jumping from "No Icon" to a Firefox Icon—and the command field had "firefox%u", which I edited to "firefox" and it worked fine.
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby jungle_boy on Sun Jan 13, 2013 8:42 pm

I tried firefox adding to startup, rebooted and it is running fine...

Image
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: problem launching Firefox at start-up

Postby Barnabooth on Mon Jan 21, 2013 2:45 pm

This works for me.
Thanks again.
Essentially Mint 14 Xfce seems good to go—but when I get ahead on my paperwork, I'll return to the question of why I cannot open "Edit Properties"!
Barnabooth
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 09, 2013 10:32 pm

Re: problem launching Firefox at start-up

Postby jungle_boy on Mon Jan 21, 2013 4:14 pm

OK!

I am glad to help you to fix the problem!

Please, edit the subject of your first post and add [SOLVED], so who has the same problem will know how to solve it.

Bravo for Linux!
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests