dist-upgrade problem

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

dist-upgrade problem

Postby gdv87 on Thu Jan 10, 2013 7:57 pm

"apt-get dist-upgrade" wants to remove a lots of packages. Is this correct? Should I just wait a little bit more to dist-upgrade?
os: linux mint LMDE 64 bit, xfce.
Thanks.

GdV87

Code: Select all
apt-get dist-upgrade 
password for giuseppe:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  cmap-adobe-japan1 dropbox gnome-netstatus-applet gnome-utils-common gs-cjk-resource libcogl5 libebook-1.2-12 libedata-book-1.2-11 libept1 libevince3-3
  libgnome-bluetooth8 libgnomepanel2.24-cil libgstfarsight0.10-0 libjack0 libpanel-applet2-0 linux-sound-base mint-artwork-debian python-gnomeapplet vlc
  vlc-plugin-notify vlc-plugin-pulse xfce4-xfapplet-plugin xz-lzma
The following NEW packages will be installed:
  aptitude-common at-spi2-core cheese-common cpp-4.7 cryptsetup-bin dconf-tools fonts-freefont-ttf fonts-liberation fonts-stix freeglut3:i386 g++-4.7 gcc-4.7
  gcc-4.7-base:i386 gcj-4.7-base gcj-4.7-jre-lib gcr gfortran-4.7 gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gnuplot gnuplot-nox groff gtk2-engines:i386
  gtk2-engines-pixbuf:i386 ia32-libs-gtk-i386:i386 ia32-libs-i386:i386 lesstif2:i386 libaacplus2 libacl1:i386 libaio1:i386 libapt-inst1.5 libapt-pkg4.12
  libart-2.0-2:i386 libasound2:i386 libasprintf0c2 libasyncns0:i386 libatk1.0-0:i386 libatspi2.0-0 libattr1:i386 libaudio2:i386 libaudiofile1:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libavcodec54 libblas3 libboost-iostreams1.49.0 libbsd0:i386 libc6:i386 libc6-i686:i386
  libcaca0:i386 libcairo2:i386 libcamel-1.2-33 libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libcanberra0:i386 libcap2:i386 libcapi20-3 libcheese-gtk21 libcheese3
  libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libcmis-0.2-0 libcogl9 libcomerr2:i386 libcups2:i386 libcurl3:i386 libdatrie1:i386
  libdb5.1:i386 libdbus-1-3:i386 libdbus-glib-1-2:i386 libdevmapper-event1.02.1 libdirectfb-1.2-9:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386
  libdrm2:i386 libebackend-1.2-2 libebook-1.2-13 libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15 libedataserver-1.2-16 libedit2:i386 libegl1-mesa
  libegl1-mesa-drivers libept1.4.12 libesd0:i386 libevdocument3-4 libevview3-3 libexif12:i386 libexiv2-12 libexpat1:i386 libexttextcat-data libexttextcat0
  libfarstream-0.1-0 libffi5:i386 libflac8:i386 libfltk1.1:i386 libfontbox-java libfontconfig1:i386 libfreetype6:i386 libgail-common:i386 libgail18:i386 libgbm1
  libgcc1:i386 libgcj13 libgconf-2-4:i386 libgconf2-4:i386 libgcrypt11:i386 libgd2-xpm:i386 libgdbm3:i386 libgdict-common libgdk-pixbuf2.0-0:i386 libgegl-0.2-0
  libgettextpo0 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386 libgmp10:i386 libgnome-bluetooth10 libgnutls26:i386
  libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-l10n libgphoto2-port0:i386 libgpm2:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386 libgxps2 libice6:i386 libidn11:i386
  libieee1284-3:i386 libiso9660-8 libitm1 libjack-jackd2-0 libjack-jackd2-0:i386 libjasper1:i386 libjbig0:i386 libjpeg62:i386 libjpeg8:i386 libjson0:i386
  libk5crypto3:i386 libkdeclarative5 libkeyutils1:i386 libkonq-common libkonq5-templates libkonq5abi1 libkrb5-3:i386 libkrb5support0:i386 liblapack3 liblcms1:i386
  libldap-2.4-2:i386 liblensfun-data liblensfun0 liblinear-tools liblinear1 libltdl7:i386 liblua5.1-0:i386 liblzma5:i386 liblzo2-2:i386 libmng1:i386 libmpc2:i386
  libmpfr4:i386 libmpg123-0:i386 libmtdev1 libmusicbrainz5-0 libmx-1.0-2 libmx-bin libmx-common libmysqlclient18 libncursesw5:i386 libnetpbm10 libnspr4 libnspr4:i386
  libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386 libodbc1:i386 libogg0:i386 libopal3.10.4 libopenal1:i386 libopenvg1-mesa libopus0 libp11-kit0:i386 libpam-cap
  libpam0g:i386 libpango1.0-0:i386 libpciaccess0:i386 libpcre3:i386 libpixman-1-0:i386 libpng12-0:i386 libpoppler-glib8 libpopt0:i386 libpt2.10.4 libpulse0:i386
  libqt4-dbus:i386 libqt4-network:i386 libqt4-script:i386 libqt4-test:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 librtmp0:i386 libruby1.9.1
  libsamplerate0:i386 libsane:i386 libsane-extras:i386 libsasl2-2:i386 libsasl2-modules:i386 libsdl1.2debian:i386 libselinux1:i386 libsigc++-2.0-0c2a:i386
  libslang2:i386 libsm6:i386 libsndfile1:i386 libsocialweb-common libsocialweb-service libsqlite3-0:i386 libssh2-1:i386 libssl1.0.0:i386 libstdc++5:i386
  libstdc++6:i386 libstdc++6-4.7-dev libsvga1:i386 libsvm-tools libsysfs2:i386 libsystemd-daemon0 libtasn1-3:i386 libtdb1:i386 libthai0:i386 libtiff4:i386
  libtinfo5:i386 libts-0.0-0:i386 libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libvisio-0.0-0 libvorbis0a:i386 libvorbisenc2:i386
  libvorbisfile3:i386 libvorbisidec1 libwacom-common libwacom2 libwayland0 libwebrtc-audio-processing-0 libwireshark2 libwiretap2 libwrap0:i386 libwsutil2
  libx11-6:i386 libx11-xcb1:i386 libx264-129 libx86-1:i386 libxau6:i386 libxaw7:i386 libxcb-glx0 libxcb-glx0:i386 libxcb-render-util0:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386 libxt6:i386
  libxtst6:i386 libxv1:i386 libxxf86vm1:i386 libyaml-0-2 linux-headers-3.2.0-4-amd64 linux-headers-3.2.0-4-common linux-image-3.2.0-4-amd64 mint-debian-mirrors
  ncurses-term netpbm odbcinst1debian2:i386 packagekit-tools python-dbus-dev ruby-gettext ruby-locale ruby1.9.1 syslinux-themes-debian-wheezy xaw3dg:i386 zlib1g:i386
The following packages have been kept back:
  vlc-nox
The following packages will be upgraded:
  alsa-base apt apt-utils aptitude cpp cryptsetup ekiga evince evince-common evolution-data-server evolution-data-server-common exiv2 filelight g++ gcc gdm3 gettext
  gettext-base gfortran gimp gimp-data gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-mutter-3.0
  gnome-bluetooth gnome-contacts gnome-control-center gnome-control-center-data gnome-dictionary gnome-keyring gnome-panel gnome-panel-data gnome-settings-daemon
  gnome-shell gnome-shell-common gnome-sushi gnome-user-share gstreamer0.10-plugins-bad gthumb gthumb-data gtk2-engines ia32-libs ia32-libs-gtk inkscape kate katepart
  kde-runtime kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools konsole libapt-pkg-perl libblas-dev libblas3gf libcap2-bin libclutter-1.0-0 libclutter-gst-1.0-0
  libclutter-gtk-1.0-0 libcogl-pango0 libedataserverui-3.0-1 libfolks-eds25 libgcj-bc libgck-1-0 libgcr-3-1 libgdict-1.0-6 libgettext-ruby1.8 libgimp2.0
  libgl1-mesa-dev libgl1-mesa-glx libglapi-mesa libgstreamer-plugins-bad0.10-0 libkateinterfaces4 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdecore5
  libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libktexteditor4 liblapack-dev liblapack3gf liblocale-ruby1.8
  liblvm2app2.2 libmutter0 libnepomuk4 libnepomukquery4a libnepomukutils4 libnspr4-0d libokularcore1 libpackagekit-glib2-14 libpdfbox-java libphonon4 libplasma3
  libpoppler-qt4-3 libpulse-mainloop-glib0 libpulse0 libpurple0 libqt4-dbus libqt4-declarative libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support
  libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libqtwebkit4 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk
  libreoffice-help-it libreoffice-impress libreoffice-l10n-it libreoffice-math libreoffice-style-tango libreoffice-writer libruby libsocialweb-client2 libsocialweb0
  libsolid4 libsoprano4 libstreamanalyzer0 libstreams0 libthreadweaver4 libumfpack5.4.0 libvcdinfo0 libxerces2-java-gcj linux-headers-amd64 linux-image-amd64 lyx
  lyx-common mesa-common-dev mintupdate-debian mplayer mutter-common nautilus-dropbox nautilus-sendto network-manager-gnome nmap okular openssh-client openssh-server
  packagekit packagekit-backend-aptcc phonon pidgin pidgin-data plasma-scriptengine-javascript poppler-data pulseaudio pulseaudio-esound-compat
  pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils python-apt python-dbus python-evolution python-scipy python-uno
  python3-apt qdbus r-base r-base-core r-base-dev r-cran-boot r-cran-class r-cran-foreign r-cran-kernsmooth r-cran-mass r-cran-nlme r-cran-nnet r-cran-rpart
  r-cran-spatial r-recommended ruby scribus seahorse soprano-daemon synaptic syslinux-themes-debian ttf-freefont udisks ufraw-batch wireshark wireshark-common
  xfonts-mathml xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-tseng
  xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xz-utils
256 upgraded, 305 newly installed, 23 to remove and 1 not upgraded.
Need to get 583 MB/583 MB of archives.
After this operation, 667 MB of additional disk space will be used.
Do you want to continue [Y/n]?
gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Linux Mint is funded by ads and donations.
 

Re: dist-upgrade problem

Postby zerozero on Thu Jan 10, 2013 8:09 pm

can you please give us the output of
Code: Select all
inxi -Sr
and
Code: Select all
cat /etc/apt/preferences
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: dist-upgrade problem

Postby gdv87 on Thu Jan 10, 2013 8:13 pm

Code: Select all
inxi -Sr
System:    Host milcom Kernel 3.2.0-2-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import
           deb [arch=amd64,i386] http://debian.linuxmint.com/latest testing main contrib non-free
           deb [arch=amd64,i386] http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb [arch=amd64,i386] http://debian.linuxmint.com/latest/multimedia testing main non-free
           deb [arch=amd64,i386] http://download.virtualbox.org/virtualbox/debian squeeze contrib non-free
           deb [arch=amd64,i386] http://fiji.sc/downloads/apt/ ./

Code: Select all
cat /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 400

gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Re: dist-upgrade problem

Postby zerozero on Thu Jan 10, 2013 8:17 pm

these weren't always the active source.list, or at least once in awhile you activate others just for a look&see?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: dist-upgrade problem

Postby gdv87 on Fri Jan 11, 2013 9:23 am

Some months ago I activated temporarily some different repos (now I don't remember exactly which ones).
So maybe I can just let apt-get remove those packages and then manually reinstall (most of) them?
GdV87
gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Re: dist-upgrade problem

Postby zerozero on Fri Jan 11, 2013 9:24 am

show us the output of
Code: Select all
cat /etc/apt/sources.list
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: dist-upgrade problem

Postby gdv87 on Fri Jan 11, 2013 9:38 am

I'll post it as soon as I come back home (now I'm on a different box), but the output of "cat /etc/apt/sources.list" will probably be the same as the one of "inxi -Sr" (there aren't any commented out lines in the file).
GdV87
gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Re: dist-upgrade problem

Postby zerozero on Fri Jan 11, 2013 10:32 am

my understanding is that you at some point had testing repos enabled and this pulled in higher versions of some lib (visible in the problem with vlc: vlc has no problems neither in latest/incoming nor in testing or sid), (visible also in the added rule in preferences)

the above is not a bad thing per-se but conflicts may arise and we should be aware of them.

also another thing that bothers me is the kernel version you are using: is that the latest you have available or are you using it because the latest has some kind of problems? i say this because (if your system was fully updated before this) you should have -3 and get an update now to -4.

one way around the vlc problem is uninstall all lib and then install again the ones matching your present repos. but this might occur with others app/lib (it's hard to tell) so you have to risk.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: dist-upgrade problem

Postby gdv87 on Fri Jan 11, 2013 10:48 am

Thanks. You are right: at some point I've enabled testing repos (that was a mistake).
The kernel is the latest I have available, is this a problem?
So I'll try to uninstall:
"libcogl5 libebook-1.2-12 libedata-book-1.2-11 libept1 libevince3-3 libgnome-bluetooth8 libgnomepanel2.24-cil libgstfarsight0.10-0 libjack0 libpanel-applet2-0"
then install them again and then dist-upgrade, right?
Thanks again.
GdV87
gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Re: dist-upgrade problem

Postby zerozero on Fri Jan 11, 2013 11:00 am

no, don't interfere with apt at this point: some of those pkgs/lib are really to go, others are to be removed because of this situation; so i would let apt purge the most possible and then try to rebuild the damages :D

regarding the kernel, yes you should have a higher version than that, check with
Code: Select all
dpkg -l | egrep '(linux-image*)|(linux-headers*)'


at the same time you can also check vlc (and see if there's mismatches)
Code: Select all
dpkg -l | grep vlc*
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: dist-upgrade problem

Postby gdv87 on Fri Jan 11, 2013 5:21 pm

Thanks a lot zerozero :-)

Code: Select all
apt-get dist-upgrade
apt-get install -f
apt-get dist-upgrade
apt-get install vlc


did the trick!

now I've this kernel:
3.2.0-4-amd64

Greets

GdV87
gdv87
Level 1
Level 1
 
Posts: 8
Joined: Thu Jan 10, 2013 7:23 pm

Re: dist-upgrade problem

Postby zerozero on Fri Jan 11, 2013 9:43 pm

8)
i just wanted to say something here: there's nothing wrong changing repos to testing or sid (my installs track either one or the other) but if we do it, we should do it completely (or learn the art of apt-pinning)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests