Can't transmit pics from camera with LM 14

Questions about applications and software
Forum rules
Before you post please read this

Can't transmit pics from camera with LM 14

Postby rodvitner on Tue Dec 11, 2012 5:59 pm

Shotwell, as well as gThumb and F-spot, freezes when I try to transmit pictures from my Canon 1000D. This was no problem in LM13, but in LM14 not possible any longer. Any ideas?
rodvitner
Level 1
Level 1
 
Posts: 10
Joined: Mon Mar 09, 2009 5:33 am

Linux Mint is funded by ads and donations.
 

Re: Can't transmit pics from camera with LM 14

Postby rosco on Wed Dec 19, 2012 7:21 pm

i'm having same issue. please PM, email, write me some how to let me know if this error is fixed.

the issue started when i installed mint 14. i've used Mint for four years and only having an issue now.
rosco
Level 1
Level 1
 
Posts: 19
Joined: Thu Aug 12, 2010 8:41 pm

Re: Can't transmit pics from camera with LM 14

Postby rodvitner on Thu Dec 20, 2012 5:48 am

The same problem in Ubuntu. In 12.04 no problem, in 12.10 the same problem as in Linux Mint 14. So this is not a distro specific issue.
rodvitner
Level 1
Level 1
 
Posts: 10
Joined: Mon Mar 09, 2009 5:33 am

Re: Can't transmit pics from camera with LM 14

Postby rosco on Fri Dec 21, 2012 9:13 am

how do we get help on this? I've tried on #linuxmint-help but no luck.
rosco
Level 1
Level 1
 
Posts: 19
Joined: Thu Aug 12, 2010 8:41 pm

Re: Can't transmit pics from camera with LM 14

Postby Flemur on Fri Dec 21, 2012 10:43 am

If all else fails - this is what I had to do in Arch:

# show all files on the camera (in all directories).

$ gphoto2 --list-files


# copy all the files to current directory:

$ gphoto2 --get-all-files
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 766
Joined: Mon Aug 20, 2012 9:41 pm

Re: Can't transmit pics from camera with LM 14

Postby SaphirePhoenix on Fri Dec 28, 2012 12:31 pm

Hello, I am having the same problem with my canon G10 in Linux Mint 14 (Cinnamon) it is recognized but can not export/copy the images out of it.

Open -> gThumb import tool -> Importing files -gThumb : but just freezes on the first image. -> cancel operations after 5m -> nothing happens ->close

then I tried to Drag and Drop to another folder -> did not get any visual that anything was being copied but 4 images of 33 were copied of which only 2 can be viewed the other two gave this error: Could not load image 'IMG_3139.JPG'. Error interpreting JPEG image file (Improper call to JPEG library in state 200)

tried copy and pasting individual images: some worked some didn't the ones that didn't, worked after a few tries...

then I tried: ctrl+A ->ctrl+c ->ctrl+v : did not work only one image was copied but not viewable. after this when I when back into the camera's folder it was hanging on loading and didn't load the folder. Then I had loading problems entering any folder on my system. ( not sure if it is related in anyway to this but wanted to mention it)

have trouble opening file browser now so I will stop here :)
SaphirePhoenix
Level 1
Level 1
 
Posts: 5
Joined: Fri May 15, 2009 8:43 pm

Re: Can't transmit pics from camera with LM 14

Postby lv426 on Sat Dec 29, 2012 4:28 pm

Exactly same problem here.
Trying to block copy a number of files from a USB connected Cannon camera to filesystem on disk.
The copy locks up after copying some files. There are no suspicious error messages in the system log.

I just installed Mint. If it's this problematic on something so fundamental I might have to switch back to Ubuntu.
lv426
Level 1
Level 1
 
Posts: 1
Joined: Sat Dec 29, 2012 4:22 pm

Re: Can't transmit pics from camera with LM 14

Postby mbeenham on Tue Jan 08, 2013 8:56 pm

Just tried my Canon on LM14 and gThumb freezes on first image. worked fine before LM14.

[EDIT] Just installed shotwell which downloaded from my camera just fine so I guess the issue is with gThumb 3.0.2.
I'll just delete gThumb for now as getting gThumb 2.14.3 to compile on LM14 looks to be an option fraught with difficulty.
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

Re: Can't transmit pics from camera with LM 14

Postby rosco on Sat Jan 12, 2013 2:07 am

rosco wrote:i'm having same issue. please PM, email, write me some how to let me know if this error is fixed.

the issue started when i installed mint 14. i've used Mint for four years and only having an issue now.


HOW DO I GET HELP ON THIS? the help channel has provided no help and it doesn't appear the resources are there for this particular problem. something was changed or left out between Mint 10, when this wasn't a problem, and Mint 14.

right now, i'm running a live Mint 9 version to get the photos off camera, downloading them to an external HDD then loading them into Mint 14 but doing that takes longer than it would to switch over to ubuntu or whatever would be similar w/o having to deal with codecs. i don't even know what a codec is

i wish i had the ability to use Arch.
rosco
Level 1
Level 1
 
Posts: 19
Joined: Thu Aug 12, 2010 8:41 pm

Re: Can't transmit pics from camera with LM 14

Postby bjornmu on Sat Jan 12, 2013 5:36 am

I've been using gphoto2 on various linuxes for my Canon cameras, though I haven't yest tried on my new Mint. One nice feature is that it extracts the timestamp from the EXIF and timestamps the file accordingly. Quite practical. :)

If all else fails, take the card out and put it in a USB card reader, then hopefully it will show up as a regular file system and you can just copy the files. I don't know why the Canon cameras don't export this interface when they clearly store the files in a standard format.
User avatar
bjornmu
Level 3
Level 3
 
Posts: 154
Joined: Wed Dec 19, 2012 2:50 am
Location: Trondheim, Norway

Re: Can't transmit pics from camera with LM 14

Postby DataMan on Sat Jan 12, 2013 8:05 am

<opininon>

I stopped trying to use the s/w app file transfer direct from camera to Lx many generations ago (I think M9 but not sure). Apps were just not reliable from version to version for me. I purchased a small usb card reader (not the permanent type of junk that's out there). Now for me, it's merely a matter of taking the SD card out of the camera and inserting into the card reader. Plug the reader in and you're good-to-go with transferring the files from the camera to the h/d.

These readers are cheap by relative terms. The cost (for me) is well worth the avoidance of dinking around all of the time trying to transfer files with apps that seem to break from one version of ops to another.

Canon EOS60d & G10

</opinion>

:lol:

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015
User avatar
DataMan
Level 6
Level 6
 
Posts: 1199
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Indiana USA at /var/www

Re: Can't transmit pics from camera with LM 14

Postby k357k9 on Sat Jan 12, 2013 8:52 am

@DataMan
I totally agree with your opinion. :D
k357k9
Level 3
Level 3
 
Posts: 128
Joined: Wed Mar 24, 2010 7:48 am
Location: Dallas, Texas

Re: Can't transmit pics from camera with LM 14

Postby SaphirePhoenix on Thu Feb 07, 2013 9:22 pm

mbeenham wrote:Just tried my Canon on LM14 and gThumb freezes on first image. worked fine before LM14.

[EDIT] Just installed shotwell which downloaded from my camera just fine so I guess the issue is with gThumb 3.0.2.
I'll just delete gThumb for now as getting gThumb 2.14.3 to compile on LM14 looks to be an option fraught with difficulty.


Thanks mbeenham! After I read your post I uninstalled gThumb as well and installed Shotwell and everything was downloaded successfully for me as well.
Thanks again.
SaphirePhoenix
Level 1
Level 1
 
Posts: 5
Joined: Fri May 15, 2009 8:43 pm

Re: Can't transmit pics from camera with LM 14

Postby Orbmiser on Thu Feb 07, 2013 10:23 pm

Yep downloading can be an issue with direct camera hookup.
Not only does the operation drain the battery on camera.
Also many horror stories of snagging the cable or kid grabbing cable and dragging off desk.

I always remove the card and insert in SD card reader slot. Camera is put in case where it's safe.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Can't transmit pics from camera with LM 14

Postby nadia14 on Thu Apr 11, 2013 7:54 am

Same problem!

Mint 14 and a Canon Sx 150 (haven't tried with the other camera i have), copying files from camera hangs after a while. That is a big problem for me.
I don't want to extract sd card every time i have to download pictures! (this way i will also for sure damage the cheap battery door of that camera).

Worked fine in ubuntu 10.04.

Is there a solution?
nadia14
Level 1
Level 1
 
Posts: 18
Joined: Mon Dec 31, 2012 11:39 am

Re: Can't transmit pics from camera with LM 14

Postby Capt Turk on Fri Apr 12, 2013 5:57 pm

I've had better luck with RawStudio than anything else. It has always worked for me no matter what version of Mint I've used.
Capt Turk
Level 2
Level 2
 
Posts: 92
Joined: Mon Aug 31, 2009 8:40 pm

Re: Can't transmit pics from camera with LM 14

Postby businessmik on Tue Apr 16, 2013 7:46 am

Wow... I can't believe it, I can't believe it.

Cannot transfer my pics from Nikon D5100 to LM14 (Asus laptop).

I've done exactly the same in the past months with LM13 and it worked. It was too good to be true. What's the point of making an alternative to Windows if we get the same "improvements" after every update?

I've spent so much time with LM13 to make it usable with my daily job (basic office tasks). I've even had to buy another laptop to reinstall Windows7 to be able to do 50% fo my job wich could not be done with Linux( mainly scanning, drivers compatibility, cell phone transfers, ...).

Now, I hoped that I could at least do the rest with LM14. You dreamer! Even the most basic thing such as transfering pics from a SD card directly from my camera doesn't work.

First it is not recognized, then after several plugs, it is, but it freezes when transfering. Great...

Pluging my sd card directly? Maybe, haven't tested yet, but hey, what's next??? Will Pluma still work in LM15?? Should I get my old Commodore 64 back from the attic?

Come on, I know developers are working for free, and it's a beautiful project, but what about wasting less time with LM look and feel and spending more time with what REALLY MATTERS. I mean: what makes an operating system usable on a daily basis by a business profesionnal so that he can focus on his business, instead of fixing manually every bug?
businessmik
Level 1
Level 1
 
Posts: 6
Joined: Tue Aug 07, 2012 10:39 am

Re: Can't transmit pics from camera with LM 14

Postby Orbmiser on Tue Apr 16, 2013 12:30 pm

Sorry for your pain especially when it did work.

I've spent so much time with LM13 to make it usable with my daily job (basic office tasks). I've even had to buy another laptop to reinstall Windows7 to be able to do 50% fo my job wich could not be done with Linux( mainly scanning, drivers compatibility, cell phone transfers, ...).


No need for a complete different system and dual boot was the option for me.

Yep that is specifically the reason I setup a dual boot with Win7. Since my clients & cash comes first. They have a right to continue to get results from my photography. And aren't concern if my linux fails to deliver.

Anyone serious about replacing OS is fine but only after extensive testing alongside or at least a backup Windows partition for situations like these. As 10%-20% of the time I still need Windows. And that is with everything linux working as it should.

But a lot has to do with hardware combinations. As I have Linux Mint 14 Cinnamon & KDE 14 both with backports enabled for latest and both versions are still problem free on my setup and no problems with SD cards. And can switch to either on the fly as have those partitions backed up to external usb drive. So 20 mins and can be running Cinnamon or KDE with my Win7 there if I need it. Bork my Win7 then also 20 mins later back up and running.

Wish I could offer a solution and help you get back up. But still a newbie to linux.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Can't transmit pics from camera with LM 14

Postby businessmik on Thu Apr 25, 2013 1:36 pm

Indeed Orbmiser, I also had a dual boot install. But I also needed Full System Encryption. And I could not use the same open source software for system encryption on both Linux and Windows. So doing a Dual Boot system with Full Encryption using 2 different encryption systems was a mess. It is possible but again, I'm not going to spend the next 6 months to learn how to do it.

A laptop costs 500USD today, it is cheaper than wasting longs (paid) hours solving bugs. so it was a lot more efficient to buy a second one for each OS. Much more easy, stable and clean.

For the camera dowload issue, I've tested the direct transfer: removing the SD card and plugging it into my laptop. It works. So I'm able to get the job done, but it's a workaround. It's like entering your car through the window because the "new version" of the door does not open any more.

So with LM13, I could use the camera cable, now with LM14 I have to unplug the card... Improvement...
businessmik
Level 1
Level 1
 
Posts: 6
Joined: Tue Aug 07, 2012 10:39 am

Re: Can't transmit pics from camera with LM 14

Postby Orbmiser on Thu Apr 25, 2013 8:46 pm

Well I have always preferred not using the cable.

1) Eats up battery power on the camera.
2) Cable laying there is a disaster waiting for someone or something to snag on it and send camera tumbling.
I've Seen it happen. And more then once. Once was a Dog and once was a child.
3) Or increased chance of ripping or bending the camera or system usb ports.

For me prefer using my built-in SD card reader on my system.
As always seen the clunky setups of others trying to make room.
And run the cable and put the camera in a safe place during transfers.

Just makes me feel uneasy when I see it done that way.
But to each their own. I just feel Better with $1000+ worth of gear safely tucked away in the bag.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: ahduncu, jefboyardee and 16 guests