Could not download all repository indexes

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Could not download all repository indexes

Postby lucinos on Sat Jan 12, 2013 10:59 am

Failed to fetch http://packages.linuxmint.com/dists/deb ... tion-en_US Unable to connect to packages.linuxmint.com:http:
Failed to fetch http://packages.linuxmint.com/dists/deb ... slation-en Unable to connect to packages.linuxmint.com:http:
Failed to fetch http://packages.linuxmint.com/dists/deb ... tion-en_US Unable to connect to packages.linuxmint.com:http:
Failed to fetch http://packages.linuxmint.com/dists/deb ... slation-en Unable to connect to packages.linuxmint.com:http:
Failed to fetch http://packages.linuxmint.com/dists/deb ... tion-en_US Unable to connect to packages.linuxmint.com:http:
Failed to fetch http://packages.linuxmint.com/dists/deb ... slation-en Unable to connect to packages.linuxmint.com:http:
Some index files failed to download. They have been ignored, or old ones used instead.

then I still have many packages for update, but...

Some of the packages could not be retrieved from the server(s).
Do you want to continue, ignoring these packages?


I say yes and... An error occurred
Code: Select all
E: Unable to correct missing packages

W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-dialogs/mate-dialogs_1.4.0-2+wheezy_amd64.deb
  Could not connect to packages.linuxmint.com:80 (204.45.82.194). - connect (110: Connection timed out)


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-window-manager/marco_1.4.1-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-window-manager/marco-common_1.4.1-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-window-manager/libmarco_1.4.1-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmate/libmate_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmate/libmate-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatecomponent/libmatecomponent_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatecanvas/libmatecanvas_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatecomponentui/libmatecomponentui_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatekbd/libmatekbd_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-menus/libmatemenu_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-menus/mate-menus_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-panel/libmatepanelapplet_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-panel/mate-panel_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-panel/mate-panel-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmateweather/libmateweather_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmateweather/libmateweather-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatewnck/libmatewnck-common_1.4.0-2+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmatewnck/libmatewnck_1.4.0-2+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-desktop/mate-desktop_1.4.1-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-desktop/mate-desktop-common_1.4.1-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-polkit/libmatepolkit_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-polkit/mate-polkit_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-sensors-applet/libmatesensorsappletplugin_1.2.0-3+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/libm/libmateui/libmateui_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/n/nemo/libnemo-extension1_1.1.2+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-applets/mate-applets_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-applets/mate-applets-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/p/python-corba/python-corba_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/p/python-mate/python-mate_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/p/python-mate-desktop/python-mate-desktop_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-backgrounds/mate-backgrounds_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-calc/mate-calc_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-settings-daemon/mate-settings-daemon-gstreamer_1.4.0-2+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-settings-daemon/mate-settings-daemon-common_1.4.0-2+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-settings-daemon/mate-settings-daemon_1.4.0-2+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-control-center/mate-control-center_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-netspeed/mate-netspeed_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-sensors-applet/mate-sensors-applet_1.2.0-3+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-system-tools/mate-system-tools_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-utils/mate-utils_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-menus/python-mate-menu_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-menu-editor/mozo_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-desktop-environment/mate-desktop-environment_1.4.0+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/f/ffmpegthumbnailer-caja/ffmpegthumbnailer-caja_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-keyring/mate-keyring_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-media/mate-media_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-media/mate-media-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-media/mate-media-gstreamer_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-power-manager/mate-power-manager_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-power-manager/mate-power-manager-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-window-manager/mate-window-manager_1.4.1-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-session-manager/mate-session-manager_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-screensaver/mate-screensaver_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-system-monitor/mate-system-monitor_1.4.0-2+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-terminal/mate-terminal_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-terminal/mate-terminal-common_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-text-editor/mate-text-editor_1.4.0-1+wheezy_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-themes/mate-themes_1.4.0-1+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/m/mate-desktop-environment/mate-core_1.4.0+wheezy_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mdm/mdm_1.0.8+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mint-translations/mint-translations_2012.10.18_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mint-common/mint-common_1.0.9_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mint-mdm-themes/mint-mdm-themes_1.0.7_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mintdesktop/mintdesktop_3.2.9_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mintinstall/mintinstall_7.4.4_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mintinstall-icons/mintinstall-icons_1.0.6_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mintmenu/mintmenu_5.3.8_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/m/mintsystem/mintsystem_7.8.3_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/n/nemo/nemo-data_1.1.2+lmde_all.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/n/nemo/nemo_1.1.2+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/main/n/nemo-fileroller/nemo-fileroller_1.0.0+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/t/thunderbird/thunderbird-l10n-en-us_17.0~linuxmint1+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


W: Failed to fetch http://packages.linuxmint.com/pool/import/t/thunderbird/thunderbird_17.0~linuxmint1+lmde_amd64.deb
  Unable to connect to packages.linuxmint.com:http:


any help? The update is not done.

I will try now from the command line
sudo apt-get update
sudo apt-get upgrade
to see what will happen
lucinos
Level 1
Level 1
 
Posts: 19
Joined: Sun May 13, 2012 6:01 am

Linux Mint is funded by ads and donations.
 

Re: Could not download all repository indexes

Postby zerozero on Sat Jan 12, 2013 12:00 pm

follow this topic here to change packages.linuxmint to a different server viewtopic.php?f=90&t=122213
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: Could not download all repository indexes

Postby lucinos on Sat Jan 12, 2013 12:02 pm

I did
Code: Select all
sudo apt-get upgrade --fix-missing

I think it worked, but I have a problem with grub. It does not see the sda :?

Code: Select all
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-2-amd64
Found initrd image: /boot/initrd.img-3.2.0-2-amd64
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
grub-probe: error: no such disk.
grub-probe: error: no such disk.
Found Windows 7 (loader) on /dev/sda1
Found Ubuntu 10.10 (10.10) on /dev/sda6
done
lucinos
Level 1
Level 1
 
Posts: 19
Joined: Sun May 13, 2012 6:01 am

Re: Could not download all repository indexes

Postby zerozero on Sat Jan 12, 2013 12:06 pm

don't reboot now

share the output of
Code: Select all
inxi -Sr
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: Could not download all repository indexes

Postby lucinos on Sat Jan 12, 2013 1:25 pm

thank you very much

I runned
mint-choose-debian-mirror
and chose a different mirror that finally worked with the rest of the packages
If I understood right it was choosing automatically the fastest but unfortunately the fastest one although was fast to many packages, was failing to some. (I tried many times and always failing)

about the grub problem I have a theory although the prompt was very confusing. In sdb I have a fedora that uses lvm2, previously the ubuntu and mint was not even seeing that at all. Now I think mint saw something but was not able to see that it is a fedora.

In trying to do the update I have done some reboots, so it is too late to advice me to not reboot. It reboots well enough I think
inxi -Sr
gives:
Code: Select all
System:    Host metis Kernel 3.2.0-2-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
lucinos
Level 1
Level 1
 
Posts: 19
Joined: Sun May 13, 2012 6:01 am

Re: Could not download all repository indexes

Postby zerozero on Sat Jan 12, 2013 1:32 pm

glad it is sorted
my concern was if grub failed to install you would end up in grub rescue
anyway i still see there a little problem: the full update should bring you kernel -4 and i see you're using -2
my question: which distro is controlling MBR? you have to boot into that one and perform a sudo update-grub in order to use the new kernel in lmde
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: Could not download all repository indexes

Postby lucinos on Sat Jan 12, 2013 1:46 pm

I have done before that (sudo update-grub) and also os-prober but it looks it did not seen the -4 kernel I do not know why but ...

good news I just did it once more and now it saw the -4 kernel. I rebooted once more and know

Code: Select all
System:    Host metis Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free


computers are mysterious boxes...
update grub still have some fails:
sudo update-grub
Code: Select all
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found linux image: /boot/vmlinuz-3.2.0-2-amd64
Found initrd image: /boot/initrd.img-3.2.0-2-amd64
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove `/var/lib/os-prober/mount': Device or resource busy
grub-probe: error: no such disk.
grub-probe: error: no such disk.
Found Windows 7 (loader) on /dev/sda1
Found Ubuntu 10.10 (10.10) on /dev/sda6
done

they may relate to fedora or they may be something I else, I have no idea

but everything else looks now ok and that is good news.

MBR of sda (that I normally boot) is controlled by linux mint debian (the one I was updating)
MBR of sdb is controlled by fedora
windows 7 and ubuntu 10.10 is on sda
LMDE and fedora is on sdb
lucinos
Level 1
Level 1
 
Posts: 19
Joined: Sun May 13, 2012 6:01 am

Re: Could not download all repository indexes

Postby zerozero on Sat Jan 12, 2013 2:04 pm

that is an unusual boot/grub configuration (more even when it involves fedora's lvm partitions)
probably the error comes from there: i see that update-grub doesn't pick fedora.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests