Mintupdate not working in Linux Mint 13 KDE

Forum rules
Before you post please read how to get help

Mintupdate not working in Linux Mint 13 KDE

Postby Salva on Thu Jan 10, 2013 3:03 pm

I installed Mint 13 KDE in december 17, 2012. The one and only time mintupdate worked on my system was when I first installed it. After the first update, every time I click on the mintupdate icon, ask for the password and then, nothing happens and the icon at the bottom of the screen dissapear.

Searching in the forum, found a post about this issue:, but it didn't worked for me. In synaptics, I uninstalled mintupdate and update manager core, and then reinstalled them, but didn't worked either.

I know that a solution is sudo apt-get update && sudo apt-get upgrade in the console but I would like to fix this problem. If I use mintupdate in the console, after typing the password, it throws this message: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Any idea what can be causing this issue?

Thanks in advance!
Level 1
Level 1
Posts: 19
Joined: Sun Jan 06, 2013 7:31 pm
Location: Guatemala

Linux Mint is funded by ads and donations.

Re: Mintupdate not working in Linux Mint 13 KDE

Postby Salva on Sat Jan 12, 2013 3:11 pm

no one knows or has a hint?
Level 1
Level 1
Posts: 19
Joined: Sun Jan 06, 2013 7:31 pm
Location: Guatemala

Re: Mintupdate not working in Linux Mint 13 KDE

Postby karlchen on Sat Jan 12, 2013 7:31 pm

Hello, Salva.

Personally I have never been hit by the problem which you report.
The only other thread related to the same kind of problem seems to be this one: Mintupdate's windows do not open.

I assume that you have rebooted the machine when the problem occurred. - Sometimes a reboot mysteriously fixes problems. - No mystery involved really, just people never bother to find out was changed by rebooting.

Have you gone through the process list and checked whether more than one instance of was running and more than one set of the numerous child processes that it likes to spawn?
(This is an example where a reboot might fix such a situation, because a reboot will terminate all processes.)

The easiest way of finding all loaded instances of is by using a graphical process manager. On Cinnamon and XFCE desktops we have got "gnome-system-monitor". No idea how the corresponding graphical process manager on KDE is called.
You can configure gnome-system-monitor to display "all processes" and their dependencies. Then gnome-system-monitor will display process names in the form of a process tree.
This is pretty handy if you want to find all instances of mintUpdate and all the child processes mintUpdate may have spawned.

Of course it is feasible to determine their names and their PIDs with the help of "ps axu" as well. But it is definitely less convenient.

Anyway, the idea is to terminate all mintUpdate processes and their children and all synaptic processes and their children as well. - Doing so will require root privileges in most cases.
Next I would launch mintUpdate from the menu. This should make sure that only once instance is running.

Have you tried this?

--- Potential Workaround ---
mintUpdate is only a wrapper around Synaptic. As a consequence you can use Synaptic in order to do whatever you do with mintUpdate as well.
Would be interesting to know whether Synaptic will exhibit similar problems as mintUpdate.
(Again before trying I would make sure that no mintUpdate or Synaptic has already been loaded into memory.)

--- Further Steps ---
If the suggested tests, reboot, make sure no minUpdate is running, launch it from the menu, same procedure for Synaptic, do not help solve the problem, in this case it will be inevitable to try and find out what the root cause is: is it inside mintUpdate or as the posted error message suggests is it inside the X software?

Therefore the output the following command might be a good starting point:
Code: Select all
inxi -Fx

Kind regards,
Still using Linux Mint 14, 15, or 16? Upgrade to 17 asap!
Europeans: sudo apt-get purge ttip ceta
User avatar
Level 15
Level 15
Posts: 5918
Joined: Sat Dec 31, 2011 7:21 am

Re: Mintupdate not working in Linux Mint 13 KDE

Postby Salva on Sun Jan 13, 2013 8:58 pm

Hello karlchen,
First of all, thanks a lot for helping here. I'm a newbie in linux world, last 2 years I was using Mint 10.04 Gnome version, but with gnome desktop out I decided to try the cinammon, mate and kde version. Kde was the one I liked the most.

Several times I rebooted but it didn't fixed the issue. I've been updating the system with synaptycs or with the update-manager-2 icon (/usr/bin/update-manager).

Kde has a system monitor too and you can configure to show as a process tree; it shows that only this process are running:


Now, if I click on the mintupdate icon, nothing happens. If I go to consolole then it shows the same error: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

The output to inxi -Fx is this:

Code: Select all
salva@salva-mint13kde ~ $ inxi -Fx
System:    Host: salva-mint13kde Kernel: 3.2.0-35-generic i686 (32 bit, gcc: 4.6.3)
           Desktop: KDE 4.9.5 (Qt 4.8.2) Distro: Linux Mint 13 Maya
Machine:   Mobo: Intel model: D865GVHZ version: AAC72419-110
           Bios: Intel version: BF86510A.86A.0075.P24.0503071605 date: 03/07/2005
CPU:       Single core Intel Pentium 4 CPU (-UP-) cache: 1024 KB flags: (sse sse2 sse3) bmips: 4788.09 clocked at 2394.048 MHz
Graphics:  Card: Intel 82865G Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x1024@75.0hz
           GLX Renderer: Mesa DRI Intel 865G x86/MMX/SSE2 GLX Version: 1.3 Mesa 8.0.4 Direct Rendering: Yes
Audio:     Card: C-Media CM8738 driver: snd_cmipci port: b400 bus-ID: 01:01.0 Sound: ALSA ver: 1.0.24
Network:   Card: Realtek RTL-8139/8139C/8139C+ driver: 8139too ver: 0.9.28 port: b800 bus-ID: 01:00.0
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: 00:e0:4c:77:15:f4
Drives:    HDD Total Size: 200.1GB (42.0% used) 1: /dev/sdc WDC_WD800JD 80.0GB
           2: /dev/sda WDC_WD400BB 40.0GB 3: /dev/sdb WDC_WD800BD 80.0GB
Partition: ID: / size: 41G used: 5.5G (15%) fs: ext4 ID: /home size: 37G used: 14G (40%) fs: ext4
           ID: swap-1 size: 1.95GB used: 0.00GB (0%) fs: swap
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 128 Uptime: 1:04 Memory: 316.0/984.9MB Runlevel: 2 Gcc sys: 4.6.3 Client: Shell inxi: 1.7.33

Again, thanks a lot for your help and support!
Level 1
Level 1
Posts: 19
Joined: Sun Jan 06, 2013 7:31 pm
Location: Guatemala

[SOLVED] Mintupdate not working in Linux Mint 13 KDE

Postby Salva on Fri Jan 18, 2013 12:45 am

Ok, I give up on this and switch to mint 13 mate.

Thanks for your help karlchen, but mint 13 mate runs better in my machine and with no issues.
Last edited by karlchen on Sun Mar 16, 2014 10:10 am, edited 1 time in total.
Reason: Moved a_hippie's posts into a separate thread, because this one has been dead for a year.
Level 1
Level 1
Posts: 19
Joined: Sun Jan 06, 2013 7:31 pm
Location: Guatemala

Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests