How To: Completely remove PulseAudio & replace it with ALSA

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Thu Apr 14, 2011 5:10 am

sespela wrote:Hey, I just used this tutorial to help a friend of mine which I have converted to LM.
FYI: All worked out perfectly on my LMDE, no problems what so ever!:D

If I understand your post correct, the volume control issue happens only in Linux
Mint and not in LMDE. Then it must be an Ubuntu vs. Debian issue.
By the way, I use LMDE myself, and that is perhaps why I don't have this issue.

And your friend might want to use Gnome Alsa Mixer to adjust her sound volume levels until the issue
is resolved.
sudo apt-get install gnome-alsamixer
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Linux Mint is funded by ads and donations.
 

Re: How To: Completely remove PulseAudio & replace it with A

Postby sespela on Thu Apr 14, 2011 8:38 am

mads wrote:
sespela wrote:And your friend might want to use Gnome Alsa Mixer to adjust her sound volume levels until the issue
is resolved.


Yes, you understood me correctly, it is in fact an Ubuntu VS Debian issue, sorry for my bad English.
Yes, she is using the Gnome Alsa Mixer to adjust the level, but I was hoping someone had a work around so it would be possible to get a volme control. Also the keyboard shortcuts for adjusting the volume doesn't work.

In advance, thanks for any help.
sespela
Level 1
Level 1
 
Posts: 25
Joined: Tue Aug 10, 2010 1:21 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Fri Apr 15, 2011 6:06 am

I've found a workaround to get back the volume applet, but cannot confirm it since I don't have access to a Mint 10 system.

1. Menu > Adminitstation > Software Sources > Third-Party Software > Add > add this into the APT Line: ppa:dtl131/ppa
(or if you prefer terminal: sudo add-apt-repository ppa:dtl131/ppa)

PPA description
The gnome-media/applets/settings-daemon packages are for users running without PulseAudio. They will disable the Pulse-based volume control and use the "classic" gstreamer-based volume control, which includes an option to configure event sounds. Also, GNOME media-keys will once again work without PulseAudio.


2. sudo apt-get update

3. sudo apt-get install gnome-applets gnome-media gnome-settings-daemon libcanberra0

4. Restart your computer

5. Right click on the panel, click Add to Panel choose Volume Control and add it.

PS! I would appreciate if a Linux Mint 10 user can confirm this workaround.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby davy51 on Fri Apr 15, 2011 11:59 am

It worked for me up to a point

It gave me the icon back but it doesn't completely work

it wont change the sound level or mute

To change the sound lever to mute I have to open volume control
Dave

Linux Mint Debian Edition 32 bit
Linux Mint 10 32Bit
User avatar
davy51
Level 2
Level 2
 
Posts: 61
Joined: Mon Aug 02, 2010 7:20 pm
Location: U.S.A

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Fri Apr 15, 2011 12:13 pm

@ davy51 and sespela, thanks. Your posts inspired me to find a permanent solution to this issue. :)

@ update: The issue with volume control applet is resolved now. Mint 10 users: Please refer to this guide.

Note: This issue only affects users who are NOT running LMDE.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby ridoj on Wed Apr 27, 2011 2:37 pm

mads, thank you for the HOWTO. I have now the sound working good :D .

Also I translated your howto to spanish on my blog.
But now I have a problem... There are now an update that tryis to remove esound :S . What I do? :?: :?: I remove it or not? Thank you!
I attach an image that show the mint updater asking me if I want to remove it...
Attachments
Captura.png
Mint updater asking me if I want to remove esound...
Captura.png (79.82 KiB) Viewed 6657 times
Last edited by ridoj on Thu May 05, 2011 3:06 pm, edited 1 time in total.
ridoj
Level 1
Level 1
 
Posts: 8
Joined: Wed Apr 20, 2011 6:21 am

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Thu Apr 28, 2011 5:50 am

Hi ridoj, just go ahead and remove it. I just did the latest updates and removed 'esound'. I can't see any changes. Everything seems to work as before.

When I wrote the guide I read somewhere that 'esound' was needed to play games like "Chaos Strikes Back" and alike, and that was why I included it,
but right after I wrote the HowTo, 'kwevej' asked in this post:
kwevej wrote:is esound really needed?
I purged PA a while ago, running without esound ... doesn't experience any problems.

I replied: "Yes, it is needed to mix several streams for playback by a single device, and to redirect sound to remote servers."

He wrote back: "mix several streams for playback by a single device works with ALSA alone as well (because of dmix)"

I don't see 'dmix' in Synaptic, but I see 'libesd0' (Enlightened Sound Daemon) which is already installed and it does the same job.
Synaptic's description of libesd0: "This program is designed to mix together several digitized audio streams for playback by a single device."

Update: I have rewritten the HowTo and have removed the part about installing 'esound' since it is going to be removed anyway.

Thank you very much ridoj. I guess you need to correct the Spanish HowTo as well. :)
Something else you might write in the translation (if you haven't already) is that this howto is only for LMDE users. Mint 10 users are supposed to use this guide.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby ridoj on Thu Apr 28, 2011 7:59 am

Thank you very much mads! I applied the upgrade and everything is working :) . Also I updated my how-to (and I inform that is for LMDE and I also added a link to the Linux Mint 10 howto).
ridoj
Level 1
Level 1
 
Posts: 8
Joined: Wed Apr 20, 2011 6:21 am

Re: How To: Completely remove PulseAudio & replace it with A

Postby Emerson Prado on Fri Nov 11, 2011 1:44 pm

If you're running pulse, chances are you created file /etc/asound.conf to route requests to alsa thru pulse. If you uninstall pulse, these changes aren't reverted automatically, so you must undo them - otherwise, many apps will be muted and you'll never know why (this happened to me).

So, if you have a /etc/asound.conf which looks like this:
pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

Just delete it. If it has something other than the lines above, just erase the lines. You'll probably have to restart alsa for changes to take effect.
Keep up,
Emerson
Emerson Prado
Level 1
Level 1
 
Posts: 37
Joined: Thu Nov 04, 2010 1:42 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Sun Nov 13, 2011 9:32 am

Emerson Prado wrote:If you're running pulse, chances are you created file /etc/asound.conf to route requests to alsa thru pulse. If you uninstall pulse, these changes aren't reverted automatically, so you must undo them - otherwise, many apps will be muted and you'll never know why (this happened to me).

So, if you have a /etc/asound.conf which looks like this:
pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

Just delete it. If it has something other than the lines above, just erase the lines. You'll probably have to restart alsa for changes to take effect.
Keep up,
Emerson


Hi Emerson,
Your point is already included in the guide:

Code: Select all
C. Remove pulseaudio, related packages and configuration files
    sudo mv /etc/asound.conf /etc/asound.conf-bak

However, thanks a lot for emphasising this point.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby abtygwyn on Fri Nov 18, 2011 11:49 am

mads wrote:The following How To was originally posted on the thread: Is Pulse Audio the worst tragedy in the history of Linux?

Please note:
- There is no reason to remove PulseAudio unless you are having some issues with it.
Suggestions are welcome!


I have been having issues getting the audio to work in skype and also the internal mic of my built in webcam.
So I tried these instructions and it has worked like a dream. No hitches whatsoever.

Many thanks

Andrew
abtygwyn
Level 3
Level 3
 
Posts: 142
Joined: Mon Apr 25, 2011 4:33 am

Re: How To: Completely remove PulseAudio & replace it with A

Postby inflatablemouse on Thu Jan 12, 2012 8:03 am

I followed the guide and it works fine, except that (I think) my default device is wrong, it's either using an analog or hdmi-audio output instead of optical.

When I can set the audio output device for a program to use I get sound, but for programs that use the default device I don't get sound.

How can I change the default audio device? I can't find an ALSA config file and wiki's floating around on the net all refer to a config file. I have no idea how or what to put in such a file from scratch.

Another thing I'd like to do while we're at it is to disable any resampling done on bitrate and frequency.

Thanks a bunch!
inflatablemouse
Level 2
Level 2
 
Posts: 72
Joined: Mon Jan 09, 2012 6:07 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Thu Jan 12, 2012 8:21 am

inflatablemouse wrote:How can I change the default audio device?

I am not sure if this is what you are asking.
The following example is based on my own hardware. Run:
Code: Select all
cat /proc/asound/modules

to see your sound modules. Output (in my case):
0 snd_intel8x0
1 snd_hda_intel

Then, run:
Code: Select all
gksudo gedit /etc/modprobe.d/alsa-base.conf

and add the following lines at the end of the file (change the lines according to your sound modules):
Code: Select all
# Fixes the order of my sound cards and prevents them from switching
options snd_intel8x0 index=0
options snd_hda_intel index=1

Save the file and exit Gedit. Reboot.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby inflatablemouse on Thu Jan 12, 2012 12:14 pm

Thanks mads, I see you expanded your original reply, appreciate it.

I'll have a go at it when I get home, I asume 0 needs to be the one that I want programs to use by default?
inflatablemouse
Level 2
Level 2
 
Posts: 72
Joined: Mon Jan 09, 2012 6:07 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Thu Jan 12, 2012 12:18 pm

inflatablemouse wrote:I'll have a go at it when I get home, I asume 0 needs to be the one that I want programs to use by default?

Yes. :)
But, to be honest, I'm not 100% sure if it gets you where you want. However, it is safe, and you can easily undo changes.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby Brian49 on Thu Jan 12, 2012 1:40 pm

I have never been able to get optical output working since I migrated to Linux; I spent months trying to make it happen, but without success. It used to work fine in Windows.
Brian49
Level 5
Level 5
 
Posts: 601
Joined: Thu Oct 29, 2009 2:27 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby fredbird67 on Sat Jan 28, 2012 4:59 pm

Ahh...now I have sound! :-) Many thanx, this worked like a charm on a fresh installation of LMDE Xfce. :D
User avatar
fredbird67
Level 1
Level 1
 
Posts: 31
Joined: Fri Jan 18, 2008 11:20 am

Re: How To: Completely remove PulseAudio & replace it with A

Postby bmschris on Thu Feb 16, 2012 9:48 pm

Thank you very much for this help. I've been having major problems using USB audio input to covert LP's to digitial music. This did the trick. I've tried off and on for a year to get this to work. Thanks again.

Chris
bmschris
Level 1
Level 1
 
Posts: 1
Joined: Thu Feb 16, 2012 9:45 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby mads on Fri Feb 17, 2012 4:56 am

fredbird67 and Chris,
thank you for your feedbacks and kind words. Much appreciated. :D
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: How To: Completely remove PulseAudio & replace it with A

Postby losst on Sat Jan 12, 2013 8:34 pm

For anyone else who stumbles here after several hours of trying to get audio working with LMDE 201204 on an Alienware M17x R3, this should work:

Code: Select all
sudo pluma /etc/modprobe.d/alsa-base.conf


Add this line to the end of the file:

options snd-hda-intel model=dell-m6-amic

Reboot and make sure audio settings reflect analog output and analog stereo duplex where appropriate.

I actually ended up having to reinstall pulseaudio after breaking my system (even more) to get it working again.
losst
Level 1
Level 1
 
Posts: 8
Joined: Sat Jan 12, 2013 8:23 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 2 guests