Linux Mint 14 MATE - Internet not working [SOLVED]

Questions about cabled networking
Forum rules
Before you post please read this

Linux Mint 14 MATE - Internet not working [SOLVED]

Postby Giridharg82 on Fri Jan 11, 2013 4:40 am

Hi, i am new to Linux. I installed Linux mint 14 MATE last week. 3 days ago i took my laptop to my friend's place & used his WiFi. Ever since that i am unable to use my internet connection (I use ethernet connection). When i attempt to access internet, Firefox waits for a minute & finally says "unable to connect".

I tried searching for a solution in many forums including this one. Either the answers did not work or i didn't understand how to use them.

I seek help to solve my issue. Please be a patient with me as i am completley new to Linux. I like the open source philosophy so i decided to try Linux. I do not want to throw it away because every problem has a solution & so does mine.

I ran ifconfig & got the below output.

radhika@radhika-Inspiron-N5110 ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 18:03:73:9f:ba:8f
inet addr:27.7.129.2 Bcast:27.7.135.255 Mask:255.255.248.0
inet6 addr: fe80::1a03:73ff:fe9f:ba8f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:375 errors:0 dropped:0 overruns:0 frame:0
TX packets:3366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:100308 (100.3 KB) TX bytes:258263 (258.2 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

wlan0 Link encap:Ethernet HWaddr 7c:e9:d3:40:0b:79
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Thank you, Giri
Last edited by Giridharg82 on Tue Jan 29, 2013 10:53 am, edited 1 time in total.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Sun Jan 13, 2013 10:32 am

I tried the following troubleshooting steps:
STEP 1: Checked the network connection settings. Screen shot (a)Network Connections
Network Connections.png
Network Connections.png (122.54 KiB) Viewed 4786 times


STEP 2: Ran nm-tool & sudo ifconfig eth0. Screen shot (a) Screenshot-Terminal-1
Screenshot-Terminal-1.png
Screenshot-Terminal-1.png (59.3 KiB) Viewed 4786 times


STEP 3: added the below "stanza" in /etc/network/interfaces file
auto eth0
iface eth0 inet dhcp

STEP 4: Ran sudo ifconfig eth0 up. Screen shot (a) sudo ifconfig eth0 up
sudo ifconfig eth0 up.png
sudo ifconfig eth0 up.png (23.72 KiB) Viewed 4786 times


Hope the above info gives a better view to troubleshoot. I would really appreciate a quick help. Thanks.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Sun Jan 13, 2013 10:29 pm

STEP 5: ifconfig -a (as root)
ifconfig -a (as root).png
ifconfig -a (as root).png (86.29 KiB) Viewed 4767 times


STEP 6: inxi -SNx
inxi -SNx.png
inxi -SNx.png (37.27 KiB) Viewed 4767 times


STEP 7: lspci
lspci.png
lspci.png (115.98 KiB) Viewed 4767 times
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby spandey on Mon Jan 14, 2013 2:08 am

In home are you trying to connect to wired or wireless?
did you tried to ping?
Linux Mint 17 - Mate 64 Bit
spandey
Level 4
Level 4
 
Posts: 439
Joined: Sat Feb 20, 2010 1:23 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Mon Jan 14, 2013 8:21 am

Thanks spandey for answering my request. At home i connect via ethernet cable. I did try ping. I got a timed out response.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby yonnie on Mon Jan 14, 2013 3:50 pm

Hi Gridharge,
You see that little icon down in the lower right area of your kicker panel that looks kind of like two plugs? Right click on it and select connect to eth0. Anytime I've had this issue in the past, that has been the solution for me. Going from one place to another place seems to bring up this issue at least once. After that 1 time event, the problem doesn't seem to happen again, well, most of the time. Another way would be to turn-off the wifi on the laptop, connect the Ethernet cable and boot-up from complete off condition. Boot should detect the live ethernet cable and settings automatically. I've noticed this problem on several distrobutions, they want to connect the same way again. You go crazy thinking something is broke and troubleshooting for an hour.

Most ethernet ports have a little activity led built-in, check to see if there is activity, if not maybe you have a bad cable?
You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.”
- Friedrich Nietzsche
User avatar
yonnie
Level 2
Level 2
 
Posts: 80
Joined: Mon Jan 03, 2011 12:18 am

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Tue Jan 15, 2013 11:14 am

Thanks Yonnie. The internet now seems to be running fine! I didn't do anything at all. I booted it up in Linux & right away internet started working fine. Not really sure what the cure was. Thank you all for your help.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Wed Jan 16, 2013 11:13 am

I think i spoke too soon. After i restarted my machine, i lost internet again. I see a red 'X' on the 2 plug icons in the kicker tray. How do i switch off Wifi on my machine.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Jerry on Sat Jan 19, 2013 11:16 am

You should be able to just to to Network Connections>Wireless (tab) > and unselect 'connect automatically'
Jerry
Level 1
Level 1
 
Posts: 46
Joined: Fri Dec 28, 2012 11:52 pm
Location: Canada

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Mon Jan 21, 2013 11:45 am

SealLion, I dódn't have anything under wireless.
Screenshot-Network Connections-1.png
Screenshot-Network Connections-1.png (19.95 KiB) Viewed 4593 times


Internet did work yesterday but it lasted about 5 minutes. I dón't think it is physical connection because i didn't disturb anything. When i dual boot into Windows7 internet works fine.

Could WiFi be interfering with ethernet? I tried to
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby snison on Mon Jan 21, 2013 11:52 pm

Actually you put an o between eth and 0.
sudo ifconfig etho0 up


change your /etc/network/interfaces back to default
Code: Select all
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback


Make sure your wireless hardware switch is on. Left click on the two cables icon and connect to your wireless network.
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Wed Jan 23, 2013 12:56 pm

snison, i am right now connected but the connection will cut-off in couple of minutes. I do not have WiFi connection. My router has ethernet only.
Also i don't see the "two-plugs" icon at the bottom. Is it supposed to be there?
Attachments
ifconfig -a (as root).png
ifconfig -a (as root).png (86.29 KiB) Viewed 4534 times
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Fri Jan 25, 2013 2:36 am

I have noticed the following so far:
1. Internet works sometimes. Even if it does it disconencts after about 10~15 mins. I have an ethernet cable plugged into my laptop.
2. I do not see the "two -plugs' icons at the bottom right hand corner.
3. Without disturbing the cables when i reboot into Windows7 internet works fine.

I am not sure whats hindering the connection.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby snison on Fri Jan 25, 2013 5:33 am

The two little cables over on the right side of your taskbar...

Image
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Fri Jan 25, 2013 1:12 pm

snison, right now i am connected to internet using Linux but i don't the two cables icons at the bottom. I see the date & time, battery life, volume & update manager

Surprisingly i am unable to save screenshots as well! When i attempt to save a screenshot, i navigate to the desired folder & notice all the other files greyed out. I continue to save the screenshot. Later when i go to the folder the file isn't there..
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Sat Jan 26, 2013 11:28 am

As i wasn't able to save screenshots, i took a picture using my mobile.
Icon Tray.jpg
Icon Tray.jpg (570.3 KiB) Viewed 4442 times
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Re: Linux Mint 14 MATE - Internet not working

Postby snison on Sat Jan 26, 2013 12:54 pm

I'm going to ensure you didn't miss this step

change your /etc/network/interfaces back to default

Code: Select all
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback


then reinstall the network manager
Code: Select all
sudo aptitude reinstall network-manager
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: Linux Mint 14 MATE - Internet not working

Postby Giridharg82 on Mon Jan 28, 2013 2:08 am

Thank you snison. I think that did the trick. My intenet connection is consistent. No issues encountered so far.
Giridharg82
Level 1
Level 1
 
Posts: 15
Joined: Fri Jan 04, 2013 2:16 pm

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 2 guests