[SOLVED] Local gateway address redirects to localhost

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help

[SOLVED] Local gateway address redirects to localhost

Postby Ghostbird on Tue Jan 15, 2013 3:06 pm

I have got a really annoying problem:
Today I was happily using my computer (Linux Mint 13 with Cinnamon), suddenly I could not reach any websites. My WiFi was connected. I started tracking down the problem.
I tried every conceivable approach, and thought up a few others while doing so, and tried those too.
My conclusion:
My local gateway is 192.168.2.1 all my traffic must go trough it. However any attempt to reach 192.168.2.1 is internally in my system redirected to the loopback. This does not show up in routing tables. I could not find any reason whatsoever in any configuration file that I could find on the system, I disabled dnsmasq, and this did not solve the problem.
In the meantime I'm using the weaker signal from the router upstairs, which has IP 192.168.3.1 on the subnet 192.168.3.1/24. This works perfectly fine for accessing the internet, but I cannot access the resources on the subnet 192.168.2.1/24, including my server.

  • When I'm connected to any network, or even no network at all, 192.168.2.1 is still redirected to the localhost.
  • The redirect does not appear in any routing table. Only by analysis of the behaviour can I conclude that the redirect is there.
  • Pings to 192.168.2.1 always return with ridiculously short RTT.
  • This happens even if the network interfaces are hard-blocked.

Can anyone please help me solve this problem, because it's driving me crazy, and I already am sufficiently crazy.

EDIT:
Finally solved the crazy:
It turns out VMWare Player installs a couple of inane virtual network interfaces (vmnet1 and vmnet8). I have no idea why, but the interfaces are normally down and not shown in ifconfig, yet still they somehow caused 192.168.2.1 (and only that address) to be resolved to 127.0.0.1. This was not shown in any system configuration, nor in any routing tables. The weirdest thing is that the problem did not start immediately after I installed VMWare Player, only after I stopped using it. I guess something went wrong with it. I solved my problems by removing VMWare Player with this command:
Code: Select all
sudo vmware-installer --uninstall-product vmware-player

Note: Attachments removed, since they did not contribute to the solution. The problem was not visible in the output of mintWifi.py, probably because it had nothing to do with the wlan0 interface.
Ghostbird
Level 1
Level 1
 
Posts: 9
Joined: Tue Aug 21, 2012 5:22 pm

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 3 guests