ATI/AMD proprietary FGLRX graphic driver Installation Mint

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

ATI/AMD proprietary FGLRX graphic driver Installation Mint

Postby jasond567 on Tue Jan 15, 2013 4:13 pm

Hello,

I am trying to install the ATI/AMD proprietary FGLRX graphic driver on Mint 14 but am struggling a little, I believe that installing additional drivers should be done through the "software sources" application however when i click on the additional drivers tab it just says "no proprietary drivers are in use" and does not give me the option to install the ATI/AMD proprietary FGLRX graphic driver.

I am quite sure i am doing somthing wrong but am not sure what.

How do i install the ATI/AMD proprietary FGLRX graphic driver?

Jason
Linux Mint 14 / Mate DTE / Acer 5536
User avatar
jasond567
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 14, 2013 4:45 am

Linux Mint is funded by ads and donations.
 

Re: ATI/AMD proprietary FGLRX graphic driver Installation Mi

Postby jungle_boy on Tue Jan 15, 2013 5:45 pm

Do you need really proprietary driver?

Open a terminal and:

Code: Select all
inxi -G


Post here the answer.

You can download the proprietary driver in the link:

http://support.amd.com/br/Pages/AMDSupportHub.aspx
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1215
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: ATI/AMD proprietary FGLRX graphic driver Installation Mi

Postby bedfojo on Tue Jan 15, 2013 5:53 pm

I think your Acer 5536 has an ATI Radeon™ HD 3200 video card.

As stated at http://wiki.cchtml.com/index.php/Ubuntu ... st.2Ffglrx :

ATI RadeonHD 2x00 - 4xx0 cards If you have one of these cards, you do have the option of using the Catalyst Legacy driver, but only if you downgrade your Xserver version (the Catalyst Legacy driver does not support the kernel version (3.5) or the Xserver version (1.13) that Ubuntu Quantal/12.10 uses). This can be done really easily by following the instructions given at [[1]]. This PPA downgrades the Xserver and install a patched version of fglrx that supports kernel version 3.5 of Ubuntu Quantal.

[1] is https://launchpad.net/~makson96/+archive/fglrx
bedfojo
Level 1
Level 1
 
Posts: 2
Joined: Fri May 04, 2012 12:01 pm


Return to Hardware Support

Who is online

Users browsing this forum: gsagostinho and 18 guests