Can't delete printers with LMDE XFCE UP6

Questions about hardware and drivers
Forum rules
Before you post please read this

Can't delete printers with LMDE XFCE UP6

Postby mikecz on Tue Jan 15, 2013 10:15 pm

I'm trying to clean up some old printers in my print manager, and whenever I try to delete a printer defined in the Printing contol panel (System > Printing, system-config-printer 1.3.7), the program hangs and I have to force it to close. When I try to delete it via http://localhost:631, I get asked for a username & password, and it fails with a message "forbidden".

I think this may be a known bug, because when I try to look at any of the printer properties I get an error box that says:

"Option 'printer-resolution' has value '(unknown IPP tag)' and cannot be edited"

I'm using cups, and all the printers happen to be HPs of various types.

And, if its helpful, apparently even printing to PDF is broken.

MikeC
mikecz
Level 2
Level 2
 
Posts: 74
Joined: Sat Jun 11, 2011 5:14 pm

Linux Mint is funded by ads and donations.
 

Re: Can't delete printers with LMDE XFCE UP6

Postby mockturtl on Wed Jan 16, 2013 2:30 am

mikecz wrote:I'm trying to clean up some old printers in my print manager, and whenever I try to delete a printer defined in the Printing contol panel (System > Printing, system-config-printer 1.3.7), the program hangs and I have to force it to close. When I try to delete it via http://localhost:631, I get asked for a username & password, and it fails with a message "forbidden".

I think this may be a known bug, because when I try to look at any of the printer properties I get an error box that says:

"Option 'printer-resolution' has value '(unknown IPP tag)' and cannot be edited"

I'm using cups, and all the printers happen to be HPs of various types.

And, if its helpful, apparently even printing to PDF is broken.

MikeC
May be relevant: viewtopic.php?f=61&t=122592&start=20#p673880
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: Can't delete printers with LMDE XFCE UP6

Postby mikecz on Wed Jan 16, 2013 6:49 am

mockturtl wrote:
mikecz wrote:I'm trying to clean up some old printers in my print manager, and whenever I try to delete a printer defined in the Printing contol panel (System > Printing, system-config-printer 1.3.7), the program hangs and I have to force it to close. When I try to delete it via http://localhost:631, I get asked for a username & password, and it fails with a message "forbidden".

I think this may be a known bug, because when I try to look at any of the printer properties I get an error box that says:

"Option 'printer-resolution' has value '(unknown IPP tag)' and cannot be edited"

I'm using cups, and all the printers happen to be HPs of various types.

And, if its helpful, apparently even printing to PDF is broken.

MikeC
May be relevant: viewtopic.php?f=61&t=122592&start=20#p673880


I did find that thread with a Google search, but it didn't seem to be helpful since that looks to be about people with issues printing from a live CD session. I know printing was working fine as of UP5 (the last time I did any printing with this particular box), so something in UP6 must have broken CUPS.

I will go through the thread again, though, just to see if I missed anything.

MikeC
mikecz
Level 2
Level 2
 
Posts: 74
Joined: Sat Jun 11, 2011 5:14 pm

Re: Can't delete printers with LMDE XFCE UP6

Postby zerozero on Wed Jan 16, 2013 6:56 am

mikecz wrote:And, if its helpful, apparently even printing to PDF is broken.
see Schoelje's last post viewtopic.php?f=61&t=122592&p=674577#p674577
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Can't delete printers with LMDE XFCE UP6

Postby mikecz on Wed Jan 16, 2013 7:24 pm

zerozero wrote:
mikecz wrote:And, if its helpful, apparently even printing to PDF is broken.
see Schoelje's last post http://forums.linuxmint.com/viewtopic.p ... 77#p674577


I did the steps in the post, and I am now able to print PDFs (to ~/PDF, which is different than before when it went right into my home directory), but no change for the other behaviors of not being able to delete existing printers. I haven't tried adding a new printer yet, and may just leave it be since I have access to other computers that will print, and will likely be reinstalling LMDE Cinnamon when they release the updated ISOs. But I'm still mystified about what's happening, especially if this is a known upstream bug.

I'm tempted to try and completely remove then reinstall CUPS, but I'm leery since I don't know which packages I'll need to do that cleanly.

But, at least something is fixed, and I'm grateful for the help.

MikeC
mikecz
Level 2
Level 2
 
Posts: 74
Joined: Sat Jun 11, 2011 5:14 pm

Re: Can't delete printers with LMDE XFCE UP6

Postby mikecz on Wed Jan 16, 2013 8:37 pm

mikecz wrote:
zerozero wrote:
mikecz wrote:And, if its helpful, apparently even printing to PDF is broken.
see Schoelje's last post http://forums.linuxmint.com/viewtopic.p ... 77#p674577


I did the steps in the post, and I am now able to print PDFs (to ~/PDF, which is different than before when it went right into my home directory), but no change for the other behaviors of not being able to delete existing printers. I haven't tried adding a new printer yet, and may just leave it be since I have access to other computers that will print, and will likely be reinstalling LMDE Cinnamon when they release the updated ISOs. But I'm still mystified about what's happening, especially if this is a known upstream bug.

I'm tempted to try and completely remove then reinstall CUPS, but I'm leery since I don't know which packages I'll need to do that cleanly.

But, at least something is fixed, and I'm grateful for the help.

MikeC


EDIT: I deleted the printers the old fashioned way: by stopping CUPs with the /etc/rc2.d/S19cups script, and then manually removing the relevant sections of /etc/cups/printers.conf, then restarting CUPS.

I will see if I can add printers another time, but I am still interested in where the bug lies in this case.

EDIT 2: Since I couldn't let this go, I hooked up a known working printer, and lo and behold CUPS automatically identified it (an HP OfficeJet 6000-E609n, a very nice piece of kit I must say), configured it, and I was able to print without problem, including using the duplexer (which confirmed that it was using the correct driver). And I still could not delete it with the System > Printers program and had to go in manually to remove it.

I'm thinking its a bug in the manager program, and though I have a decent work around, I am still curious about where this came from and how to fix it.
mikecz
Level 2
Level 2
 
Posts: 74
Joined: Sat Jun 11, 2011 5:14 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests