SSD + HDD mounting problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

SSD + HDD mounting problems

Postby Therion87 on Fri Dec 28, 2012 7:35 pm

Anyone know how to remount /var from an SSD to an HDD - /var is mount in as part of / on the SSD and /home is the HDD they were mounted that way by my during installation.

My current fstab:

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=4f8e9ce2-4096-4dba-b7f9-61e91c641b9a /               ext4    errors=remount-ro,noatime,discard 0       1
# /home was on /dev/sda1 during installation
UUID=3ff367de-ba7d-4f46-9aa8-0b69997da624 /home           ext4    defaults        0       2
# swap was on /dev/sdb5 during installation
UUID=b01e9f24-5b6a-4402-b4b5-8fa229aa8ac7 none            swap    sw              0       0
# store tmp files in memory instead of SSD
none /tmp   tmpfs   nodev,nosuid,mode=1777   0   0
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Linux Mint is funded by ads and donations.
 

Re: SSD + HDD mounting problems

Postby Therion87 on Tue Jan 15, 2013 2:31 pm

Any ideas?
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: SSD + HDD mounting problems

Postby passerby on Wed Jan 16, 2013 7:55 pm

-Boot through a live CD/DVD/USB
-Copy the contents of /var onto the new partition (separate from /home. eg. if /home is /dev/sda1, move it to /dev/sda2)
If you're unsure how, follow a tutorial for moving the home partition and just substitute home for var.
eg. http://blogs.pcworld.co.nz/pcworld/tux- ... _home.html
-Edit fstab to reflect the new /var
-reboot

eg.
Since /home was /dev/sda1, if you partitioned that disk so you have space for /var, it would end up as /dev/sda2.
Code: Select all
sudo mount -o rw -t ext4 /dev/sda2 /mnt
sudo cp /var /mnt
sudo pluma /etc/fstab

A simple cp command might not be enough. Refer to a tutorial on moving /home to be safe.
Add to fstab something like:
Code: Select all
/dev/sda2 /var           ext4    defaults        0       2

assuming it's been formatted as ext4. You can also use the UUID if you wish instead of /dev/sda2.
After that, reboot. If everything went well /var will be mounted on your HDD and you can delete /var on your SSD.
If not, boot through the live CD/DVD/USB again and comment out or delete the newly added line in fstab. Definitely refrain from deleting /var from your SSD until you've booted properly with the new config.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: SSD + HDD mounting problems

Postby Therion87 on Thu Jan 17, 2013 8:13 am

Ok, thanks. that's where I was messing up I wasn't creating a second partion on the home drive. I need to resize.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH


Return to Newbie Questions

Who is online

Users browsing this forum: bob3326, Kalyk, kc1di, Mute Ant and 25 guests