Can't get my wireless to stay connected to school wireless

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Can't get my wireless to stay connected to school wireless

Postby locke456 on Thu Jan 17, 2013 4:02 pm

Hi all,
I'm a bit of a Linux newbie, so apologies if I leave out something obvious.

My problem is that I can't get my wireless to stay connected throughout the day when I'm at work. I teach at Washington State University and use the university's "WSU Wireless" network to connect. I started using Mint on my work computer about six months ago, and originally was completely unable to connect to WSU Wireless at all; something about a faulty security certificate. So I went to http://infotech.wsu.edu/help/wireless/ and followed the instructions there. It didn't help (I'll note that I used that site's Windows 7 instructions when I first got my work computer and those got me connected fine through Win7). I checked out the university's student Linux user group as well https://www.lug.wsu.edu/, but they don't answer my emails and don't seem to be having "office hours" anymore. I followed the instructions on their site, but those didn't help either. Finally, I realized that WSU's security certificate is issued by Thawte, so on a whim I navigated to /etc/ssl/certs and tried out the generic Thawte certs available in my Linux installation, and found that changing my connection's settings through Network Manager to use either Thawte_Premium_Server_CA.pem and thawte_Primary_Root_CA.pem allowed me to connect, finally. However, every time the computer has to reconnect (either waking up from sleep or being turned on at the start of the day), whichever of these two certs I have selected doesn't work, and I have to switch to the other one to connect. Because I'm teaching this semester, I carry my computer around from room to room a lot, and thus it goes into sleep mode and loses the connection 5-6 times a day, at least, which means every time I open my computer I have to navigate to Network Manager and toggle between certs until one takes. This isn't a huge hassle, but it seems like there should be an easy solution that I'm just not experienced enough to figure out. I'd have followed up with the university instead of posting here, but they don't seem to have anyone on staff familiar with anything but Mac OS and Windows.

I'm running Mint 13 32-bit on an HP Mini 210 with a Broadcom 4313 wireless card. Thanks for any help! :D
locke456
Level 1
Level 1
 
Posts: 22
Joined: Wed Oct 03, 2012 6:02 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: Bing [Bot] and 8 guests