[SOLVED] Sound choppy after suspend/resume

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[SOLVED] Sound choppy after suspend/resume

Postby oishiiburger on Thu Jan 10, 2013 3:35 am

Hello all,

I'm having an issue with Mint 14 on my Lenovo T530. After suspend/resume, the sound is choppy -- it's as if the mute goes on and off about twice a second, over and over. Using alsa force-unload or alsa force-reload does not work, and the sound remains choopy until reboot.

The sound is using the snd-hda-intel module, and I'm using options snd-hda-intel model=thinkpad in alsa-base.conf (it doesn't make a difference). More details below. Any ideas? Any help would be greatly appreciated. Thank you!

Code: Select all
$ sudo lspci -v | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

Code: Select all
$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC269VC

Code: Select all
$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=thinkpad
oishiiburger
Level 1
Level 1
 
Posts: 2
Joined: Thu Jan 10, 2013 3:25 am

Linux Mint is funded by ads and donations.
 

Re: [SOLVED] Sound choppy after suspend/resume

Postby oishiiburger on Fri Jan 18, 2013 1:49 am

To anyone having a similar problem, after much fuss I was able to fix the problem by adding a script named 11suspend to /etc/pm/sleep.d with the following contents.

Code: Select all
#!/bin/sh
/usr/bin/amixer sset Master mute
/usr/bin/amixer sset Master unmute


It seems muting and unmuting on sleep solves the issue of choppiness after resume.
oishiiburger
Level 1
Level 1
 
Posts: 2
Joined: Thu Jan 10, 2013 3:25 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: olepi and 6 guests