Help installing libcrypto.so.6

Questions about applications and software
Forum rules
Before you post please read how to get help

Help installing libcrypto.so.6

Postby stetson on Sat Jan 19, 2013 3:55 pm

I've loaded jBase application and I am installing on my Linux MINT ver Nadia system.

I am getting the following error message:

CREATE-FILE: error while loading shared libraries: libcrypto.so.6: cannot open shared object file: No such file or directory

I am told I need openssl098e installed using apt-get command. I've run as follows:

'sudo apt-get install openssl098e'

No luck completing command. Do I need to get via ftp?

I'm new to LINUX and need some guidance.

Thanks!
stetson
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 06, 2013 2:27 pm

Linux Mint is funded by ads and donations.
 

Re: Help installing libcrypto.so.6

Postby DrHu on Sat Jan 19, 2013 5:25 pm

http://itsecureadmin.com/2009/06/error- ... directory/
--some research for the error, try idconfig, as shown in the link

The problem, you no doubt recognize has to do with that package installation: jbase
http://www.jbase.com/new/support/eval/downloads.html
--carefully read the requirements and any documentation from the vendor..
    Also that package has other requirements in that it is a java installation , and it seems to require a KORN shell (not bash, which is the default for Linux distributions..)
    Linux
    You must have the korn shell (ksh) installed before you install jBASE for Linux, or the installation will fail. In addition, many of the shell scripts included in jBASE for Linux require ksh.
User avatar
DrHu
Level 17
Level 17
 
Posts: 7007
Joined: Wed Jun 17, 2009 8:20 pm

Re: Help installing libcrypto.so.6

Postby xenopeek on Sat Jan 19, 2013 5:39 pm

libcrypto is already installed, but it is a newer version. You should be able to fool the application by creating a link to this newer version, called 'libcrypto.so.6'. First, check what current file you have:
Code: Select all
locate libssl.so.

On Linux Mint 14 64-bit that responds the following (on 32-bit it will be somewhere else):
Code: Select all
/lib/x86_64-linux-gnu/libssl.so.1.0.0

Then you can create the link by going to the directory that has the file (from the output of above command):
Code: Select all
cd /lib/x86_64-linux-gnu

And then running this command to create the link (first the name of the file as output by above command, then the 'libcrypto.so.6' name):
Code: Select all
ln -s libssl.so.1.0.0 libcrypto.so.6

This may or may not work, depending on whether the application you are trying to run is 64-bit or not. If it is 32-bit, you would first install the package libssl1.0.0:i386 and this will install the library to '/lib/i386-linux-gnu/libcrypto.so.1.0.0'. And then you would run the above commands the same way, except replacing the 'x86_64-linux-gnu' part of the path with 'i386-linux-gnu'.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15259
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 11 guests