[SOLVED] Stop Nemo Displaying Home Directory On Desktop

Chat about Linux in general

[SOLVED] Stop Nemo Displaying Home Directory On Desktop

Postby childe joseph on Sun Jan 20, 2013 9:32 am

I use Crunchbang Linux with Sid sources, and the LMDE repo for the latest Cinnamon. Problem is when I set Nemo to handle the desktop in addition to Computer, Home, Mounted Volumes, Trash, etc, the entire Home directory is displayed as well. These are not shortcuts, if I move any of the icons to trash, it trashs the folder in the home directory. Anyone here know how to stop Nemo from displaying the entire contents of the Home directory onto the desktop?
Last edited by childe joseph on Sun Jan 20, 2013 11:26 am, edited 2 times in total.
childe joseph
Level 1
Level 1
 
Posts: 20
Joined: Wed Apr 27, 2011 8:12 am

Linux Mint is funded by ads and donations.
 

Re: Help! Stop Nemo Displaying Entire Home Directory On Desk

Postby xenopeek on Sun Jan 20, 2013 10:39 am

Make sure your ~/.config/user-dirs.dirs matches the folder names in your home folder, and that you in fact have a desktop folder. Here is copy of the file on Linux MInt installed in US English:
Code: Select all
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

And suggest you disable running xdg-user-dirs-update at login, as this will mess everything up by trying to change folder names back to your locale (as defined in ~/.config/user-dirs.locale).

If you have been manually renaming folders, or the XDG_DESKTOP_DIR entry doesn't exist, then Nemo won't know where to find your desktop and will probably show your home folder instead. That happened for another user that was renaming folders manually, which upon reboot had xdg-user-dirs-update reset all his settings (which he hadn't updated) in ~/.config/user-dirs.dirs to "$HOME".
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14510
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Help! Stop Nemo Displaying Entire Home Directory On Desk

Postby childe joseph on Sun Jan 20, 2013 11:25 am

xenopeek wrote:Make sure your ~/.config/user-dirs.dirs matches the folder names in your home folder, and that you in fact have a desktop folder. Here is copy of the file on Linux MInt installed in US English:
Code: Select all
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

And suggest you disable running xdg-user-dirs-update at login, as this will mess everything up by trying to change folder names back to your locale (as defined in ~/.config/user-dirs.locale).

If you have been manually renaming folders, or the XDG_DESKTOP_DIR entry doesn't exist, then Nemo won't know where to find your desktop and will probably show your home folder instead. That happened for another user that was renaming folders manually, which upon reboot had xdg-user-dirs-update reset all his settings (which he hadn't updated) in ~/.config/user-dirs.dirs to "$HOME".


Thanks I was missing "XDG_DESKTOP_DIR="$HOME/Desktop" from that config file so I just added it, and it was fixed.
childe joseph
Level 1
Level 1
 
Posts: 20
Joined: Wed Apr 27, 2011 8:12 am

Re: [SOLVED] Stop Nemo Displaying Home Directory On Desktop

Postby oldpilsbury on Wed Apr 30, 2014 10:44 pm

I had the same problem. I like to lowercase my home directories for less keystrokes, and I don't like extraneous shortcuts on my desktop. (Why use Linux if you're just going to clutter it up like a dirty old Windows box?) When I deleted the desktop shortcuts it also deleted them from my home folder. Luckily they were empty. At first I tried apt-get remove nemo, which was not a good idea. (Thanks a lot, guy in forum who told me to do that!) Cinnamon crashed and I had to boot from runlevel 1 by editing GRUB and appending the linux line with a 1, at which point I connected to the network and reinstalled nemo. Finally I found this thread and edited ~/.config/user-dirs/dirs. The only reason I can think of that you would want xdg to auto-change your directory names is if you're changing between languages for your menus in Language Support. In that case the mv command seems like a reasonable alternative. Can't I just crush xdg altogether? I don't want a Desktop folder. The capital letters are repulsive, and it seems unnecessary.
oldpilsbury
Level 1
Level 1
 
Posts: 1
Joined: Tue May 28, 2013 1:00 am


Return to Chat about Linux

Who is online

Users browsing this forum: No registered users and 6 guests