pulseaudio no longer working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

pulseaudio no longer working

Postby Dubslow on Sun Jan 20, 2013 2:44 pm

So I recently installed LMDE as a replacement for my now-outdated Ubuntu 11.04 (I dislike Unity and Gnome 3, and Cinnamon does not yet offer some things that Gnome 2/MATE do).

I torrented the .iso over winter break, so late December, but didn't get around to actually installing it until a few days ago.

pulseaudio and sound in general has been working just fine, until 10 minutes ago. I pressed the mute button on my keyboard (PA announcement in the dorm), and when I unmuted it, no sound came through. This was YouTube, so I tried Google Music and Banshee before concluding it was the OS.

I googled around about "mint restart sound" because I don't want to reboot, and found this, which suggested this. So I tried `pulseaudio -k` on its own, nothing happened. Then I did the more robust --check, and nothing happened, so I assume the daemon crashed for some reason. Then I tried `pulseaudio -D`, and that failed, which was the real curveball.
Code: Select all
pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.

What the hell?

I've seen other suggestions on this board to replace pulseaudio with alsa, should I be trying that?

Edit: Some more attempts:
Code: Select all
∰∂ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
∰∂ pulseaudio --check
∰∂ pulseaudio --start
∰∂ pulseaudio --check
∰∂ killall pulseaudio
∰∂ pulseaudio -D
∰∂ # Appears to have started fine, but still no sound


Edit2: Even a reboot didn't work. This is rather bad.


EDIT: The next guy after me to post in this forum has a work around and better diagnosis of the issue! :)
Dubslow
Level 1
Level 1
 
Posts: 8
Joined: Sat Jan 05, 2013 11:59 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 0 guests