Mint 14 keeps asking for wifi passphrase

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Mint 14 keeps asking for wifi passphrase

Postby RemyR on Sun Jan 20, 2013 11:13 am

After following serval guides and posts on the forums I finally got Mint 14 to recognize my dreaded Netgear WNA3100 and it sees all of the wireless networks in the neighborhood fine it just will not let me connect to mine. It keeps asking for the passphrase which I know is correct. It is setup for WPA2. I have tried it with both Network Manager and wicd to no avail.

iwconfig
wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:300 Mb/s Tx-Power:32 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

mintwifi
-------------------------
* I. scanning WIFI PCI devices...
-------------------------
* II. querying ndiswrapper...
bcmwlhigh5 : driver installed
device (0846:9020) present
-------------------------
* III. querying iwconfig...
wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:300 Mb/s Tx-Power:32 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 00:25:22:ea:0c:cf
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::225:22ff:feea:ccf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:209060 errors:0 dropped:0 overruns:0 frame:0
TX packets:108685 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:306574969 (306.5 MB) TX bytes:8030656 (8.0 MB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:275 errors:0 dropped:0 overruns:0 frame:0
TX packets:275 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:24960 (24.9 KB) TX bytes:24960 (24.9 KB)

wlan0 Link encap:Ethernet HWaddr 20:4e:7f:f1:fe:f1
inet6 addr: fe80::224e:7fff:fef1:fef1/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:62 errors:0 dropped:0 overruns:0 frame:0
TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7006 (7.0 KB) TX bytes:12004 (12.0 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: google.com
Address: 173.194.37.71
Name: google.com
Address: 173.194.37.69
Name: google.com
Address: 173.194.37.67
Name: google.com
Address: 173.194.37.72
Name: google.com
Address: 173.194.37.64
Name: google.com
Address: 173.194.37.73
Name: google.com
Address: 173.194.37.70
Name: google.com
Address: 173.194.37.68
Name: google.com
Address: 173.194.37.65
Name: google.com
Address: 173.194.37.78
Name: google.com
Address: 173.194.37.66


Any ideas?
RemyR
Level 1
Level 1
 
Posts: 5
Joined: Sun Jan 20, 2013 10:37 am

Linux Mint is funded by ads and donations.
 

Re: Mint 14 keeps asking for wifi passphrase

Postby viking777 on Sun Jan 20, 2013 12:22 pm

it sees all of the wireless networks in the neighborhood fine it just will not let me connect to mine


Do you have mac filtering enabled in your router, and if so have you added the address of the Netgear device?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Mint 14 keeps asking for wifi passphrase

Postby RemyR on Sun Jan 20, 2013 12:47 pm

It didn't help any either way. I turned on mac filtering and added all of my devices to the list but only the Mint install resfuses to connect, everything else still worked fine either way. It just stays in an endless loop of asking for the passphrase.
RemyR
Level 1
Level 1
 
Posts: 5
Joined: Sun Jan 20, 2013 10:37 am

Re: Mint 14 keeps asking for wifi passphrase

Postby RemyR on Sun Jan 20, 2013 12:52 pm

Also if it helps it isn't just Mint that is doing this, I have tried Ubuntu 12.10, Fedora 16 and 18, openSuSE 12.2, Debian 6 and crunchbang 10 all with the same results. Also I am using the 32-bit version of all of them as I have been reading over the past couple of weeks that it almost takes an act of divine intervention to get this dongle to work on a 64-bit Linux install.
RemyR
Level 1
Level 1
 
Posts: 5
Joined: Sun Jan 20, 2013 10:37 am

Re: Mint 14 keeps asking for wifi passphrase

Postby viking777 on Sun Jan 20, 2013 2:06 pm

That is an impressive list of failures :( . I notice you haven't said "It works with Windows". Does this mean it doesn't or you don't run Windows? My only thought with something as reluctant to work as that is to try Windows Wireless Drivers utility (aka ndiswrapper). There are hundreds of guides as to how to use this utility, this is just the first I saw:

http://www.howtogeek.com/howto/43752/ho ... s-drivers/

Of course if it doesn't work with Windows there is not much point in trying that either.

I had a similar situation to this myself a while back (a built in wireless card in this case). I tried for ages to get it going, newer and older versions of network manager, wicd, all the usual 'solutions' and I never did get it to work (exactly the same problem as you btw, kept asking for password all the time). In my case it didn't matter that much because it was my wife's computer, not mine and she uses windows nearly all the time anyway. The only way it was cured is when she bought herself a new laptop. Sorry I can't be more positive than that, I hope you find a solution somewhere.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Mint 14 keeps asking for wifi passphrase

Postby tjpmack1961 on Sun Jan 20, 2013 2:26 pm

I too am having this issue. What I did to connect was to remove security and I can connect without issue.
I have tried all security types without luck when using security passwords.
It happens with , Mint 14 any desktop, Ubuntu 12.10 any desktop. This has only happened to me on my newer laptops, ( HP Pavilion G6-2278dx) & ( Asus K55A-hi5121).
I don't suffer this issue on my (Toshiba Satellite L505-S6946). An older machine.
Q: Can it have to do with having to enable the (legacy) option in my bios in order to boot? I do this because I daul boot, Win7 & Linux and the newer UEFI boot option doesn't allow me to boot otherwise.
tjpmack1961
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 2:11 pm

Re: Mint 14 keeps asking for wifi passphrase

Postby viking777 on Sun Jan 20, 2013 2:48 pm

I would be quite happy to blame this on Uefi - it has caused so many other disasters since it was introduced, but in this case I feel it is probably stretching it a bit far. Interesting that you can connect by disabling security though. (This is a pretty 'radical' solution, I hope you realise that).

There is an answer here that seems to work for some people:

http://askubuntu.com/questions/64903/ne ... ontinually
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Mint 14 keeps asking for wifi passphrase

Postby tjpmack1961 on Sun Jan 20, 2013 10:38 pm

In reply to Viking777,
I don't use Mint 14 on my newer machines because of this issue. I have gone back to Mint 13. 13 works just fine for me. I do however use mint 14 and ubuntu 12.10 on my older machines with out issue. But yes, it is a radical issue. What could possibly cause a password protected, wireless network to deny connection ?
tjpmack1961
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 2:11 pm

Re: Mint 14 keeps asking for wifi passphrase

Postby viking777 on Mon Jan 21, 2013 7:02 am

I have had issues in the past with wifi and autologin. If either of you are using autologin, try switching it to manual login temporarily to see if it makes any difference.

Another thing to look at. Wifi passwords are kept (unencrypted amazingly :shock: ) at /etc/NetworkManager/system-connections. Check in there that you have an entry for your wireless connection and that it has the correct password listed. Just in case you don't have one here is the format of the file - you can create it yourself easily enough, although I haven't tried this myself, I don't have to, my wireless already works. The name of the file is the name of your wireless network. (sensitive information has been replaced by x's supply your own information here).

Code: Select all
[connection]
id=xxxx
uuid=xxxx
type=802-11-wireless

[802-11-wireless]
ssid=xxxx
mode=infrastructure
mac-address=xxxx
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-psk
auth-alg=open
psk=xxxx

[ipv4]
method=auto

[ipv6]
method=auto


Use the command:
Code: Select all
nmcli con list


to get the UUID of your connection. The mac address is that of your network card or device (not your router).

NB this arrangement is a fairly recent one, on systems earlier than Ubuntu 12.04/MInt 13, passwords were stored in gnome-keyring and that is what used to cause the autologin problem, so maybe that workround isn't valid any more.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Mint 14 keeps asking for wifi passphrase

Postby chiefjim on Mon Jan 21, 2013 8:04 am

Perhaps the solution isn't so complicated. When you edit your connections ensure both the "connect automatically" and the "available to all users" boxes are checked.
Desktop:
Mint-16 64 bit with Mate
Gigabyte GA-MA785GM-US2H
AMD Athlon II X3 425
CORSAIR 4GB DDR2 800
640GB HDD WD Black 7200rpm

Laptop:
Acer Aspire AS5552-5898
Mint-16 64 bit with Mate
AMD Phenom II Triple-Core N830
4GB Memory DDR3
500GB HDD 5400rpm
chiefjim
Level 4
Level 4
 
Posts: 387
Joined: Sun Jun 07, 2009 7:26 am

Re: Mint 14 keeps asking for wifi passphrase

Postby tjpmack1961 on Mon Jan 21, 2013 2:31 pm

chiefjim wrote:Perhaps the solution isn't so complicated. When you edit your connections ensure both the "connect automatically" and the "available to all users" boxes are checked.

I am not using auto-connect. I have set up security with a simple passphrase to test it, (12345678). It does not matter what the passphrase is or the number of charactures. I have tried WEP & WPS. neither work. Again. This is only on newer machines, not older ones. This has to be an issue with The latest kernal release & newer machines. My opion anyway.
tjpmack1961
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 2:11 pm

Re: Mint 14 keeps asking for wifi passphrase

Postby chiefjim on Mon Jan 21, 2013 2:54 pm

OK. I misunderstood the original to be you were always being asked for the pass phrase.

As to the current issue, did you install Mint 14 fresh or as an upgrade?
Desktop:
Mint-16 64 bit with Mate
Gigabyte GA-MA785GM-US2H
AMD Athlon II X3 425
CORSAIR 4GB DDR2 800
640GB HDD WD Black 7200rpm

Laptop:
Acer Aspire AS5552-5898
Mint-16 64 bit with Mate
AMD Phenom II Triple-Core N830
4GB Memory DDR3
500GB HDD 5400rpm
chiefjim
Level 4
Level 4
 
Posts: 387
Joined: Sun Jun 07, 2009 7:26 am

Re: Mint 14 keeps asking for wifi passphrase

Postby RemyR on Mon Jan 21, 2013 6:32 pm

It works fine in Windows XP, 7 and 8. I will connect in Mint too if I disabled the security in my router like the other person did but that isn't really an ideal option lol. I have tried to disable auto connection and the all users box is checked, I even unchecked just to try it that way and nothing...I'm too broke right now to buy a wireless adapted that is known to work with Linux and I have seen other people get this one working but it just doesn't seem to like me :/
RemyR
Level 1
Level 1
 
Posts: 5
Joined: Sun Jan 20, 2013 10:37 am

Re: Mint 14 keeps asking for wifi passphrase

Postby RemyR on Mon Jan 21, 2013 6:36 pm

Oh yeah and I am using ndiswrapper to install the drivers as there are no native drivers for it. I have tried both the bcmwlhigh5 and the bcmn43xx32 ones that often work for others.
RemyR
Level 1
Level 1
 
Posts: 5
Joined: Sun Jan 20, 2013 10:37 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 13 guests