Vgaswitceroo at startup

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Vgaswitceroo at startup

Postby Compiled on Mon Jan 21, 2013 12:52 pm

I've been trying for the past week to get my laptop running perfect in Mint 14 (Mate/Cinnamon), but I've run into an issue.

If i run
Code: Select all
echo OFF >> /sys/kernel/debug/vgaswitcheroo/switch
it disables the DIS gpu fine.
I then run
Code: Select all
sudo gedit /etc/rc.local
and add the above to it.

Apon rebooting I notice that the DIS gpu fan is still running, so i'll :
Code: Select all
sudo cat /sys/kernel/debug/vgaswitcheroo/switch
and notice that the IGD is PWR and the DIS is OFF (even though I know its physically on).
So I'll re-run switcheroo/switch and it turns off for about a minute then turns back on.

I'm at my wits end here.
I have a i7 3610QM + AMD Radeon 7970M.

I have also tried to install the lastest AMD drivers (13.1) and they work until I reboot (I can't find a how-to-install for noobs tutorial for this driver in Mint 14).
Is there anything I can do to disable to DIS automatically (i have a muxless machine here so BIOS switch is out of the question). I've tried using bash scripts but that doesn't work either unless I'm doing something wrong. I have currently uninstalled Mint 14 and I am just running Windows for the time being (I would like to dual boot).

Please help I was up until 4:30am trying to figure this out and I am at the point where I am just going to forget about *nix for a few years (until there is a stable automatic solution with software etc).

Signed 1 beaten user.
Compiled
Level 1
Level 1
 
Posts: 1
Joined: Mon Jan 21, 2013 12:40 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], blueredgreen, Delta44, mint15 and 35 guests