wifi stopped working -LM 14 Nadia Cinnamon 64-bit

Questions about WIFI networks and devices
Forum rules
Before you post please read this

wifi stopped working -LM 14 Nadia Cinnamon 64-bit

Postby squeezethecroc on Mon Jan 21, 2013 6:41 pm

Hello all, greetings from snowy England

I installed Linux Mint 14 Nadia Cinnamon 64-bit on a Dell Inspiron 1545 a few day ago. I connected it via ethernet to my router during installation and also got the wireless working without any problems. My son took the laptop with him to Canada but has been unable to connect to the free wifi that's available at the hostel where he's staying, although the other members of the group had no problems connecting theirs.

I wonder if anyone can shed some light on this? Unfortunately, I can't give any details of the hardware as the laptop is now in Canada and I can only communicate with my son for a few minutes at a time.

Thanks
squeezethecroc
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 21, 2013 5:44 pm

Linux Mint is funded by ads and donations.
 

Re: wifi stopped working -LM 14 Nadia Cinnamon 64-bit

Postby snison on Mon Jan 21, 2013 11:16 pm

It is because your Mint is using dnsmasq as the dns resolver (127.0.0.1) instead of getting a DHCP DNS server. Horrible design! You can't login to their web portal to authenticate without the onsite DNS server.

Code: Select all
sudo pico /etc/NetworkManager/NetworkManager.conf
put a # in front of dns=dnsmasq
sudo restart network-manager


Look in the clock tray and right click the icon that looks like two cables connecting.

Code: Select all
click:
edit connections
wireless
SSID name
edit
IPv4 settings
"Require IPv4 addressing..."
available to all users
save
close


left click on the cables icon and select the SSID
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: wifi stopped working -LM 14 Nadia Cinnamon 64-bit

Postby squeezethecroc on Tue Jan 22, 2013 8:20 am

Thank you snison for your reply.

I'll get my son to do that. I'm still puzzled about why it worked before though....
squeezethecroc
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 21, 2013 5:44 pm


Return to Wireless

Who is online

Users browsing this forum: pdc_2 and 4 guests