ibus anthy anquish

Forums for the KDE Edition
Forum rules
Before you post please read this

ibus anthy anquish

Postby chibi on Fri Jan 18, 2013 1:56 am

I am a relative newby to Linux. I keep on trying it -- and going back to Windows -- because it just takes too much time to get rid of the bugs and problems.
On the other hand, I really like the KDE desktop in general. If only it was usable. My big problem with it is ibus anthy -- which I have always been unable to install. I hoped that Nadia would be an improvement -- but it isn't. I think that this is KDE -- because I installed Ibus Anthy (Japanese support) fine in Cinnamon. (Mint 14).
I have checked out a lot of Internet posts -- but nothing seems to work. Anyway -- last try.....
I installed Ibus Anthy, with Japanese and English in the Locale language settings. If I run Ibus Anthy (or Keyboard Input) I can see Japanese as an option but I can select it -- it is grayed out along with the controls "Up' , "Down" and so on. There is not icon for Anthy. No input window.
I tried switching to the Japanese interface. That works fine. But Ibus Anthy still doesn't work. Everything is grayed out. Suggestions.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Linux Mint is funded by ads and donations.
 

Re: ibus anthy anquish

Postby grepnix on Fri Jan 18, 2013 6:38 am

I installed ibus in order to stop an error message about a missing directory (I was running a Linux tutorial on pyqt) I was getting in the console. But it didn't change anything until I also installed ibus-doc and ran 'man ibus' in konsole which told me I had to run im-config to set it up. This setup a /home/user/.config/ibus directory which stopped the error message after I logged out and back... (maybe reboot?)

This could be what you need to do?? Just a suggestion... Maybe wrong but worth seeing if you have the above directory...

Ibus has to be set up as a service, can't remember if I had to install im-config. If its not there do a search in synaptic...

Cheers,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby chibi on Fri Jan 18, 2013 1:10 pm

I downloaded im-config and ran it and go the following message;
Current configuration for the input method:
* Active configuration: missing (normally missing)
* Automatic configuration: ibus (normally ibus or fcitx or uim)
* Number of valid choices: 2 (normally 1)
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
Available input methods: ibus xim
Unless you really need them all, please make sure to install only one input method tool.
:(
This is all Greek to me! Can you help?
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby chibi on Fri Jan 18, 2013 1:17 pm

I also get the following message:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

I wonder what this means?
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby grepnix on Fri Jan 18, 2013 1:27 pm

Have to say, I didn't get any of that. Just a window where I chose ibus...

Is ibus and ibus-qt4 installed?

Is there now a directory /home/chibi/.config/ibus ?

In Dolphin click show hidden files to see the .config directory

Cheers,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby chibi on Sat Jan 19, 2013 2:04 am

thanks so much for the help. I will check.
Just logging onto these forums now from another computer -- yes, (sadly) using Win 7. :x
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby chibi on Sat Jan 19, 2013 4:54 am

the ibus directory is there in config. Nothing in it though.
ibus-qt4 is installed.
the ibus icon (the little keyboard) is there but greyed out. Input method is off but cannot be activated since all options are grayed out.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby grepnix on Sat Jan 19, 2013 5:55 am

My ibus directory was created after I ran im-config and some config file was put in there. If you run ibus-daemon in a terminal what does it say...

Beginning to run out of ideas here so if anyone can pour more light on the situation that would be good...

Cheers,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby chibi on Sun Jan 20, 2013 2:53 am

If I run ibus-daemon -d in a terminal, it doesn't say anything. Just starts ibus -- but the preferences are greyed out, including the japanese option.

i notice that older documentation refers to "language support". That is not available in KDE 4.9 other than thru Locale.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby chibi on Sun Jan 20, 2013 11:47 pm

I guess I will just try reinstalling Nadia. And then Ibus-Anthy, etc.
if it doesn't work this time. I will have to dump Mint KDE and to Cinnamon, which works fine with Ibus Anthy. I like KDE better -- but it is just too undeveloped.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby grepnix on Mon Jan 21, 2013 4:28 am

Anything useful on this page?

http://code.google.com/p/ibus/wiki/Ubuntu

Cheers,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby chibi on Tue Jan 22, 2013 12:33 am

Thanks so much for the page.
I tried everything there -- but no joy -- the little keyboard icon and all the options are greyed out.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby chibi on Thu Jan 24, 2013 2:52 am

I reinstalled Mint 14 KDE. I noticed that the language localization files for Japanese are not installed -- and I cannot install them. There are language localization files for KDE on synaptic -- but I cannot download them. Very strange.
If this fails, I guess I switch back to Cinnamon.
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby grepnix on Thu Jan 24, 2013 4:46 am

chibi wrote:I reinstalled Mint 14 KDE. I noticed that the language localization files for Japanese are not installed -- and I cannot install them. There are language localization files for KDE on synaptic -- but I cannot download them. Very strange.
If this fails, I guess I switch back to Cinnamon.


I just checked and its working here on Mint 13 KDE. Perhaps its a temporary repository problem?

Regards,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby chibi on Thu Jan 24, 2013 12:44 pm

I think I am getting closer to identifying the problem --or rather the bug. When I try to download the language localization files for Japanese I have to use Synaptic because they are not listed in Software Manager. Why not listed in Software Manager? Because they either don't exist for KDE 4.9.3 or they cannot be accessed from the Ubuntu archive. Using Synaptic I get a 404 error and a message that I cannot access the Ubuntu archive for KDE 4.9.3.
If I were running Mint 13, it might work!
chibi
Level 1
Level 1
 
Posts: 11
Joined: Fri Jan 18, 2013 1:45 am

Re: ibus anthy anquish

Postby grepnix on Thu Jan 24, 2013 1:05 pm

chibi wrote:I think I am getting closer to identifying the problem --or rather the bug. When I try to download the language localization files for Japanese I have to use Synaptic because they are not listed in Software Manager. Why not listed in Software Manager? Because they either don't exist for KDE 4.9.3 or they cannot be accessed from the Ubuntu archive. Using Synaptic I get a 404 error and a message that I cannot access the Ubuntu archive for KDE 4.9.3.
If I were running Mint 13, it might work!


That may be it. I switched back to KDE 13 as I had a few problems with video on my intel graphics cards (Mesa is a different version). Its also supported until April 2017 as its LTS. I'm happy enough with KDE 4.8.5...

Cheers,
Grepnix
grepnix
Level 1
Level 1
 
Posts: 38
Joined: Thu Dec 06, 2012 2:27 pm

Re: ibus anthy anquish

Postby trung.nguyen on Tue Feb 18, 2014 12:05 am

Hi,

I had same problem after installed Linux Mint 16 KDE, but I solved by following these steps:
1. Install (or reinstall) ibus
Code: Select all
sudo apt-get install –reinstall ibus ibus-gtk ibus-qt4 gnome-icon-theme gnome-icon-theme-full

2. Install im-config
Code: Select all
sudo apt-get install im-config

3. Start im-config
Code: Select all
im-config

it will show warning -> OK -> Yes (update all ibus files and config) -> Show input methods list -> cho Ibus and OK
4. Start ibus setup, by command line or ALT-F2 (type ibus-setup)
Code: Select all
ibus-setup

You can setup languages, and hot key to change to that (default is <super>space while before was <Alt>space)
5. Logou and back, keyboard icon will show up at system tray

Hope this is useful for
trung.nguyen
Level 1
Level 1
 
Posts: 2
Joined: Wed Feb 13, 2013 7:31 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests