vlc freezes at first frame

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

vlc freezes at first frame

Postby bmike1 on Mon Jan 21, 2013 4:00 pm

Any video player I try doesn't work. vlc freezes at the first frame while the sound continues normally. gnome movie player plays slow while the audio is normal. totem skips frames and then freezes. I like vlc. any ideas how to fix this?
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Linux Mint is funded by ads and donations.
 

Re: vlc freezes at first frame

Postby bmike1 on Mon Jan 21, 2013 7:33 pm

I forgot to mention that the sound continues as if all was normal.
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby passerby on Mon Jan 21, 2013 7:37 pm

Probably a missing codec, but before speculating: what messages come up when you run vlc from a terminal and try to play a video?
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: vlc freezes at first frame

Postby bmike1 on Mon Jan 21, 2013 8:08 pm

Missing codex? I didn't install <?> any if I'm supposed too.
vlc 00005.MTS
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x8404908] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 0
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 256
"sni-qt/6075" WARN 17:02:39.121 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE ]
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 0
libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) for PID 256
[h264 @ 0xb7365ee0] illegal short term buffer state detected
[0xb730a740] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[h264 @ 0xb7365ee0] reference picture missing during reorder
[h264 @ 0xb7365ee0] Missing reference picture
[h264 @ 0xb7365ee0] reference picture missing during reorder
[h264 @ 0xb7365ee0] Missing reference picture
[h264 @ 0xb7365ee0] reference picture missing during reorder
[h264 @ 0xb7365ee0] Missing reference picture
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby passerby on Mon Jan 21, 2013 9:15 pm

The warning can be fixed by removing qt-at-spi from your system, then logging out and back in. I don't think it's related to the issue though.
One of the good things about mint is that it comes with the codecs you need by default, but even so it looks to me like a problem with libavcodec.
You should wait for someone more knowledgeable in the area. The best advice I can give is to (re?)install libavcodec53 and 54, maybe upgrade vlc (since they're up to 2.0.5)
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: vlc freezes at first frame

Postby bmike1 on Mon Jan 21, 2013 10:42 pm

well, I tried deleting the qt-at-spi package and installing libavcodec53 but neither of those suggestions helped (what a bummer). So I suppose I need to wait for more knowledge.
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby snison on Tue Jan 22, 2013 12:35 am

Are you currently up-to-date? There have been several VLC releases lately.

Code: Select all
sudo apt-get update
sudo apt-get upgrade

?
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: vlc freezes at first frame

Postby bmike1 on Tue Jan 22, 2013 12:52 am

well.... I thought everything was up to date but when I typed in to upgrade vlc- data was scheduled to update.... maybe this will fix it! I'll let you know when it is done.
.
.
.
.
nope, that didn't help any.
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby snison on Tue Jan 22, 2013 1:22 am

Does it show any errors in /var/log/syslog or /var/log/syslog.1 ?
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: vlc freezes at first frame

Postby bmike1 on Tue Jan 22, 2013 11:42 am

I started a video and there was nothing relevant. there wassomething with the proper time stamp but it didn't seem to be relevant. Here it is:
Jan 22 08:40:04 Michaels-Laptop wpa_supplicant[829]: WPA: Group rekeying completed with 00:24:7b:2c:e9:3c [GTK=TKIP]
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby snison on Tue Jan 22, 2013 6:25 pm

Have you tried "Movie Player" that comes built into Linux Mint?
I generally don't use salutation, valedication, or please when answering your questions. I'm not a jerk; you have a question, I have a possible solution.
snison
Level 2
Level 2
 
Posts: 81
Joined: Wed Dec 26, 2012 12:42 am

Re: vlc freezes at first frame

Postby bmike1 on Wed Jan 23, 2013 2:13 pm

Yep... I tried it. 'Movie Player' is 'Totem'. It plays like a quarter second with movement and sound and then freezes and the sound doesn't continue as normal. Then it jumps ahead a little and freezes and then again, then freezes permanently.
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Re: vlc freezes at first frame

Postby bmike1 on Thu Jan 24, 2013 3:25 pm

gnome-mplayer seems to be the best. Everything plays and even sounds but the video is slow and the half way through the audio gets choppy. also, it needs to be deinterlaced.
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

vlc works best after upgrade

Postby bmike1 on Fri Jan 25, 2013 7:56 pm

well, I upgraded from mint 13 to 14 in the hopes that would fix the problem but that didn't help any. I also increased the cache for vlc but that was not a help as well. So I have to choose between vlc, totem, and mplayer; vlc freezes at the first frame while audio continues normally; totem plays slowly and the audio stops after saying, 'Hello Michael' (the first sound on the video) but it doesn't seem to have any interlacing associated with the video; mplayer needs deinterlacing and the video is slow but the audio plays normally. So vlc has the least wrong with it:D
Mint17 Mate- Running on a Dell Dimension C521 with a AMD Athlon(tm) 64 Processor 3200+ CPU, containing 4G of memory, and a GeForce 6150 LE video card
bmike1
Level 4
Level 4
 
Posts: 367
Joined: Mon Nov 28, 2011 1:13 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: aurelius, gibbs1984, Hecubus, nerdtron, sportsfan7700 and 25 guests