Linux Mint 14 Nadia - No audio at times (random)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Linux Mint 14 Nadia - No audio at times (random)

Postby amko on Wed Dec 19, 2012 5:17 am

Just installed Linux Mint 14 Nice Nadia Cinnamon. My audio doesn't seem to work at times, randomly. No .mp3 playback, cannot play sound in YouTube (both Firefox 17.0.1 and Opera 12.11), no DVD audio playback in VLC. Strangely, for this session, the audio is working ok as I request this support since I'm a little mystified as to what's up - to say the least.

I did type the following in terminal -> inxi -Fc 0 - and here is the output:


System: Host: (myname)-desktop Kernel: 3.5.0-17-generic i686 (32 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: Mobo: Intel model: DH55TC version: AAE70932-302
Bios: Intel version: TCIBX10H.86A.0037.2010.0614.1712 date: 06/14/2010
CPU: Dual core Intel Core i3 CPU 530 (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 1197.00 MHz 2: 1197.00 MHz 3: 2926.00 MHz 4: 1197.00 MHz
Graphics: Card: NVIDIA GT218 [GeForce 210]
X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau Resolution: 1600x900@60.0hz
GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 9.0
Audio: Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Card-2: NVIDIA High Definition Audio Controller driver: snd_hda_intel
Network: Card: Intel 82578DC Gigabit Network Connection driver: e1000e
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 70:71:bc:9a:02:2d
Drives: HDD Total Size: 500.1GB (9.0% used) 1: id: /dev/sda model: ST3500418AS size: 500.1GB
Partition: ID: / size: 455G used: 42G (10%) fs: ext4 ID: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 38.0C mobo: N/A gpu: 46.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 141 Uptime: 7 min Memory: 363.9/3897.7MB Client: Shell inxi: 1.8.4


Any ideas as to what to do next would be greatly appreciated, thank you.
amko
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 19, 2012 5:10 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby andy1m on Wed Dec 19, 2012 10:53 am

I also try to enable alert sound and start up sound but no sound at all (Mint 14 Mate).
andy1m
Level 1
Level 1
 
Posts: 13
Joined: Wed Jun 24, 2009 9:30 pm

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby kwatson512 on Sat Dec 22, 2012 11:17 am

I have the same problem. Mint 14 Nadia running Cinnamon, on a Lenovo ThinkPad T430s (Intel 3rd generation i7-3520M CPU @ 2.90GHz with Intel HDA 4000 audio). One boot, sound will work, but the next boot nothing after login sounds.

From my lspci -v:
Code: Select all
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Lenovo Device 21fb
   Flags: bus master, fast devsel, latency 0, IRQ 46
   Memory at d2530000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd-hda-intel


And from head -n 1 /proc/asound/card0/codec*:
Code: Select all
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC269VC

==> /proc/asound/card0/codec#3 <==
Codec: Intel PantherPoint HDMI
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 203
Joined: Sun Apr 20, 2008 7:16 pm

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby kwatson512 on Thu Dec 27, 2012 8:02 pm

I thought I had fixed my problem, but on the next boot (this morning) I have no sound again. I added one line at the bottom of the alsa-base.conf file in /etc/modprobe.d. See this post for more details (thanks to AlbertP).

Here's what I did in a terminal:

Code: Select all
gksu gedit /etc/modprobe.d/alsa-base.conf


Add at the bottom:
Code: Select all
options snd-hda-intel model=auto


This configures the audio driver by reading the BIOS. Depending on your hardware, you may need to try one of the other options listed for "model=", but "auto" works for me. (YMMV)

Still looking for a solution that lasts.
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 203
Joined: Sun Apr 20, 2008 7:16 pm

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby kwatson512 on Mon Dec 31, 2012 12:13 am

Well, my problem is finally fixed! Take a look at this post. For me it was much simpler than I had expected. Here are the steps:

Install gnome-alsa-mixer using synaptic or
Code: Select all
sudo apt-get install gnome-alsa-mixer


Then from the menu (Sound & Video --> GNOME Alsa Mixer), make sure all the IEC958 blocks are checked.

Reboot or logout/login.
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 203
Joined: Sun Apr 20, 2008 7:16 pm

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby viceyo on Mon Dec 31, 2012 3:44 am

Hi,

I'm also having the same problem here. I'm using Linux Mint 14 Cinnamon x86_64.

I tried your solution kwatson512 (Install gnome-alsa-mixer using sudo apt-get install gnome-alsamixer) but after rebooting, one of the checkboxes gets unchecked again.
[Update] I got able to keep all checkboxes checked but the problem remains for me :(

I noticed that eventhough the issue seems to be random, I can "force" the problem to appear every time I open a youtube video.

Output of aplay -l:
Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC665 Digital [ALC665 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Output of lspci -v:
Code: Select all
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
   Subsystem: Dell Device 050e
   Flags: bus master, fast devsel, latency 0, IRQ 51
   Memory at f1c00000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd-hda-intel
viceyo
Level 1
Level 1
 
Posts: 1
Joined: Mon Dec 31, 2012 3:26 am

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby kwatson512 on Mon Dec 31, 2012 7:51 am

@viceyo,

Hmm... I notice the same thing when I reboot (one of the checkboxes gets unchecked). But I hadn't thought to look at that until you said something, since my Youtube and other audio works fine. Maybe someone else in the forum can suggest a more consistent solution for us.
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 203
Joined: Sun Apr 20, 2008 7:16 pm

Re: Linux Mint 14 Nadia - No audio at times (random)

Postby amko on Fri Jan 18, 2013 1:45 am

Please visit this link:

http://www.linuxandlife.com/2012/05/no- ... -maya.html

This may fix the problem permanently. To get the sound to work after login without editing the sound preferences, you just need to restart pulseaudio when booting up. This can be done easily by adding some simple commands to the startup applications.

Go to the Linux Mint menu, search for " Startup Applications". When the Startup Applications Preferences window open, click on the "Add" button then add the following command into the command section:

Code: Select all
rm -r ~/.pulse && killall pulseaudio


Give it a name then click the +Add button then close the Startup Applications Preferences window.
amko
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 19, 2012 5:10 am

[SOLVED] Re: Linux Mint 14 Nadia - No audio at times (random

Postby kwatson512 on Tue Jan 22, 2013 5:04 pm

@amko,

Thanks. It works dependably now. I had it working by installing qjackctl and its dependencies, but this is a "belt and suspenders" approach I don't mind adding. :)
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 203
Joined: Sun Apr 20, 2008 7:16 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest