Intel 5100 Wireless Drivers Location <SOLVED>

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Intel 5100 Wireless Drivers Location <SOLVED>

Postby countryboy456 on Mon Jan 21, 2013 11:49 pm

First off I have searched numerous times on this post about the wireless issue I am having.. I have had no luck on finding what I need.

My issue is that I have the wireless driver downloaded onto my laptop but I do not know where I need to put the files.

The website that I had receive the file from states that if I run the command "# cp iwlwifi-*.ucode /lib/firmware" it is suppose to install the firmware.

Well the result of that command is as follow:

# cp iwlwifi-5000-ucode-5.4.A.11 /lib/firmware
cp: omitting directory `iwlwifi-5000-ucode-5.4.A.11'



As being fairly new to Linux(I have most of the basic commands down). I am not sure what that error means.

Also I am not sure if I can post the link to the location of where I receive the driver and the command it tells me to run... If I am able, I will and let fellow Linux people take a look as to what I am doing wrong.

Thank you for your help.
Last edited by countryboy456 on Mon Jan 28, 2013 2:02 pm, edited 1 time in total.
countryboy456
Level 1
Level 1
 
Posts: 19
Joined: Fri Jan 18, 2013 6:44 pm

Linux Mint is funded by ads and donations.
 

Re: Intel 5100 Wireless Drivers Location

Postby nomko on Tue Jan 22, 2013 3:04 am

countryboy456 wrote:My issue is that I have the wireless driver downloaded onto my laptop but I do not know where I need to put the files.

Before or after downloading the package? Before downloading: best is to download files in your download folder which can be found in you home directory: /home/{username}/Downloads. After downloading: the package itself "knows" where to install all the files.

countryboy456 wrote:The website that I had receive the file from states that if I run the command "# cp iwlwifi-*.ucode /lib/firmware" it is suppose to install the firmware.
Well the result of that command is as follow:
# cp iwlwifi-5000-ucode-5.4.A.11 /lib/firmware
cp: omitting directory `iwlwifi-5000-ucode-5.4.A.11'

As being fairly new to Linux(I have most of the basic commands down). I am not sure what that error means.
Also I am not sure if I can post the link to the location of where I receive the driver and the command it tells me to run... If I am able, I will and let fellow Linux people take a look as to what I am doing wrong.



Did you get the drivers from here:http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17045&lang=eng?
Last edited by nomko on Wed Jan 23, 2013 3:36 am, edited 1 time in total.
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2917
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Intel 5100 Wireless Drivers Location

Postby countryboy456 on Tue Jan 22, 2013 5:44 pm

No.

My laptop model is Asus.

I had gotten the file from

http://wireless.kernel.org/en/users/Drivers/iwlwifi

Not sure how good the site is. But it was the only site I could find the driver on.
countryboy456
Level 1
Level 1
 
Posts: 19
Joined: Fri Jan 18, 2013 6:44 pm

Re: Intel 5100 Wireless Drivers Location

Postby nomko on Wed Jan 23, 2013 3:36 am

Try the link i provided. See if any issues will appear then.
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2917
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Intel 5100 Wireless Drivers Location

Postby countryboy456 on Wed Jan 23, 2013 12:33 pm

Actually the link I posted is a link in the site you posted.. I have to click on yours, and the link for the Intel® Wireless WiFi 5100AGN is in the site I posted.
countryboy456
Level 1
Level 1
 
Posts: 19
Joined: Fri Jan 18, 2013 6:44 pm

Re: Intel 5100 Wireless Drivers Location

Postby countryboy456 on Mon Jan 28, 2013 2:01 pm

I found how to get the issue to work..

I was able to find the topic http://ubuntuforums.org/showpost.php?p= ... stcount=62


I was a bit confused so I had to do some testing.. I was not able to find the line that stated the following:

A file will open. Search for the string CONFIG_IWL4965_HT=y. Directly after that string, on a new line, add this string:

So I added the command "CONFIG_IWL5000=y" under the line that had something with the following "IWL4965" and was able to get the wireless working,
countryboy456
Level 1
Level 1
 
Posts: 19
Joined: Fri Jan 18, 2013 6:44 pm

Re: Intel 5100 Wireless Drivers Location <SOLVED>

Postby ZAJDAN on Sun Aug 11, 2013 6:14 pm

HI,
what is really strange so, that when I run from live CD, the wireless card Intel 5100 works correctly, but from same CD after install not. Linux Mint 15 x64bit KDE
Why it doesn't work after installation and form Live CD yes?
ZAJDAN
Level 1
Level 1
 
Posts: 6
Joined: Tue Jun 04, 2013 3:35 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: cevion and 14 guests