windows boot option loads linux mint

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

windows boot option loads linux mint

Postby choppy1812 on Tue Jan 22, 2013 3:10 pm

Hello all,

I just installed mint cinnamon 32-bit on my sdb drive, and I have windows 7 on the sda drive. During install, the bootloader was put on sda (windows drive).

Now, when I boot, I can choose the first option for Mint (on /dev/sdb1), and that works fine, but when I try the last option in the menu for "Windows 7 (loader) (on /dev/sda1)", the computer simply restarts.

I have a windows 7 disk, and I've read about restoring the MBR with that, but I prefer to do it with Linux / Grub, if possible.

I found /etc/default/grub, but I don't see anything in this file that looks like a list of options (ie, windows), so I assume there is another file somewhere to look at?

What should I do? Many thanks in advance. :)
choppy1812
Level 1
Level 1
 
Posts: 1
Joined: Tue Jan 22, 2013 2:50 pm

Linux Mint is funded by ads and donations.
 

Re: windows boot option loads linux mint

Postby jungle_boy on Tue Jan 22, 2013 10:30 pm

Try in a terminal:

Code: Select all
sudo update-grub


Reboot.
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: windows boot option loads linux mint

Postby thegreatgazoo on Tue Jan 22, 2013 11:39 pm

So from your description of your disks, sda1 and sdb1, It looks like you have 2 drives.
sda=windows and sdb=linux
Now, windows 7 usually has 2 partitions a small 100MB partition in front, then the main partition afterwards.
So windows should really be on SDA2.

Try this, boot up and in grub choose the option to manually edit the windows line. Manually edit sda1 to say sda2 and see if it will boot now. If it does, it's easy to make it permanent.
thegreatgazoo
Level 3
Level 3
 
Posts: 109
Joined: Wed Aug 22, 2012 3:18 pm

Re: windows boot option loads linux mint

Postby perduta on Fri Jan 25, 2013 7:47 am

Do as follows:
Boot your Linux Mint then open a command prompt and enter the following:

sudo os-prober
sudo update-grub

Next time you restart your computer it should giving you the choice which OS you want.

Note: Personally I disconnect the Windows drive when installing Linux because I just use my rom bios boot priority to choose which drive to boot from and I don't like the grubby menu. ;)

p.s. I keep all my own data files on a separate NTFS partition of my Windows drive so that if I need to reinstall either OS, it never affects my work.
perduta
Level 2
Level 2
 
Posts: 69
Joined: Mon Jan 21, 2013 12:55 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 23 guests