How to install the Nvidia proprietary drivers in LinuxMint

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby tany3450 on Tue Dec 25, 2012 2:13 pm

i am writing this post from linux mint with half screen :D everthing done without problem, until "sudo /etc/init.d/mdm stop" which is just before step 7. when i run this command i get nothing but black screen and cursor. when i run this command on the previous steps there were no problems. need to use windows till you help me . thanks

edit : solution for this problem was mentioned on the first page . i look to bios but i couldnt find anything useful :( pls help me i dont wanna format my mint :(

i am using gt 540m with optimus technology. i installed bumblee project a month ago but just before installing nvidia driver today , i've deleted it from package manager. recovering my system is more important for me now than install nvidia driver :cry:

--edit2---

solved by myself :D

If you are installing the Nouveau drivers after uninstalling the Nvidia ones, be sure to delete the /etc/X11/xorg.conf file that the Nvidia driver created (or undo the changes), or else X will fail to properly load the Nouveau driver.
Install the DDX driver with the xf86-video-nouveau package.
Also make sure you have Xorg properly installed.
If you want hardware-accelerated 3D support (to run GNOME Shell or KWin's effects, for instance), install the DRI driver with the nouveau-dri package. For Arch x86_64, install lib32-nouveau-dri from the Multilib repository, as well.


this worked for me finally i get my full screen back ! and i decide to use primus for bumblebee :D
User avatar
tany3450
Level 1
Level 1
 
Posts: 8
Joined: Wed Nov 14, 2012 8:29 am

Linux Mint is funded by ads and donations.
 

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby SanfordandSunRa on Tue Dec 25, 2012 4:07 pm

I am having a problem; as soon as I go into tty1, without my taking any further action I get this repeated error message.

buffer I/O error on dev fd0

I'm not running a floppy drive, and I removed all other USB devices from the computer thinking that might be the problem, to no avail. Any ideas what might be causing this? It prevents me from going further into the process described on the first page.

I'm running 14.1 Cinnamon edition, 64-bit. This is a fresh install on a hard drive that was a duel-booter (Win 7 and Mint 13). Finally cutting the umbilical cord with MSoft. :D The card I'm trying to set up is a GTX 460 as well. Video seemed smooth on 13 but I noticed everything (web browsing, 1080p video on VLC) was glitchy on this install, a sort of "dropped frames" effect. Not horrible but would like it to be smooooth. I have a Phenom X4 with 8G of DDR2. Thanks.

EDIT: I just ignored the error messages and was able to run the driver install up to a point, but then I got a message saying the nouveau driver was still installed. The installer's workaround didn't work, so I rebooted and deleted the file mentioned when you try the workaround. It's telling me to read the read me file at nvidia.com, but I can't find any such doc. Also getting hung up on a *checking battery status* message in tty1. Will try replacing mobo battery next.

EDITED AGAIN: Replaced mobo battery and went through Bios settings again and was able to install the driver. I still had the "checking battery status" message at one point, and what I typed failed to be visible again after that (this was happening before but I didn't mention it). Pressing alt + ctrl +F8 and then going back to tty1 again by pressing alt + ctrl + F1 fixed that. Now I'm gaming and watching videos in freedom-hating eye candy glory. Thanks to the author of this thread for helping out!
SanfordandSunRa
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 25, 2012 4:02 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Cylonbunny on Mon Dec 31, 2012 2:31 am

I have a GTX 670M and have followed these instructions twice now. However, when I restart MDM after updating the drivers the OS goes into fallback graphics mode and I have a 640x480 resolution. Running the NVIDIA X Server Settings program confirms I am not running an NVIDIA driver and asks me to run nvidia-xconfig again – which I have done many times now. Earlier, I tried to add the NVIDIA drivers using a different method, but I ended up in the same situation and had to reinstall the OS (its a fresh install).

I have checked my BIOS but it has no settings I can change except for the boot preference order -__-

Does anybody have any idea of what I am doing wrong / should try? I am pulling what little hair I have left out!
Cylonbunny
Level 1
Level 1
 
Posts: 1
Joined: Mon Dec 31, 2012 2:19 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Mon Dec 31, 2012 7:09 am

Cylonbunny wrote:Does anybody have any idea of what I am doing wrong / should try? I am pulling what little hair I have left out!

what edition of mint are you using?
according to the specs that card has optimus technology http://www.geforce.com/hardware/desktop-gpus/geforce-gtx-670m/features so the only option is going to be bumblebee (but the way you install it is dependent of the mint edition you are using)
start please by sharing the output of
Code: Select all
inxi -SGx
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby josealb77 on Wed Jan 02, 2013 12:30 pm

Hello,
after the first reboot with the nouveau driver blacklisted I get the 2nd case: "be in a low graphics mode, in which case, you will need to hit ctrl+alt+f1 at the same time to get to tty1, and then login there" but when I hit ctrl+alt+f1 I just get a black screen. My monitor does not turn off, it is just that I can't login at any other tty but the graphic one with a low graphics mode. tty1, tty2, tty3... any of the other eleven just show a black screen. It happens in my x64 pc and in my pentium4 x86 pc.
I'm using the 3.8.0rc1 kernel, I've updated to the 3.8.0-999.201212310405_amd64 but this still happens. My graphic card is an NVIDIA GeForce GTX 460.
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby McLovin on Wed Jan 02, 2013 8:44 pm

josealb77 wrote:Hello,
after the first reboot with the nouveau driver blacklisted I get the 2nd case: "be in a low graphics mode, in which case, you will need to hit ctrl+alt+f1 at the same time to get to tty1, and then login there" but when I hit ctrl+alt+f1 I just get a black screen. My monitor does not turn off, it is just that I can't login at any other tty but the graphic one with a low graphics mode. tty1, tty2, tty3... any of the other eleven just show a black screen. It happens in my x64 pc and in my pentium4 x86 pc.
I'm using the 3.8.0rc1 kernel, I've updated to the 3.8.0-999.201212310405_amd64 but this still happens. My graphic card is an NVIDIA GeForce GTX 460.

I have had this issue a couple of times on various distros, the best solution to this is when you boot up the machine, hit "e" in the grub menu on the version of Mint that you are going to install the driver on, this will allow you to edit the boot line, change the section that says
Code: Select all
ro quietboot (quietsplash)
(i don't remember exactly what the quiet part is), and chage it to say
Code: Select all
text
this is will boot into a text only mode, allowing you to install the drivers. However, I'm not sure if Nvidia has updated the drivers to work with the new 3.8 kernels yet, so it may end up failing, but I cannot say for sure, as I haven't tried using the 3.8 kernel yet.
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby josealb77 on Thu Jan 03, 2013 5:58 am

I already had tried remove "ro quiet splash $vt_handoff" but no writting "text", nevertheless this neither worked. What really worked was removing
Code: Select all
ro   quiet splash $vt_handoff
and
Code: Select all
gfxmode $linux_gfx_mode
I think removing this last line was actually the key.
But sadly, as you said I think this driver isn't ready for the 3.8.0 kernel as I got two errors:a dkms and a gcc error. Lookint at make.log it says that Ihave to run 'make oldconfig && make prepare' on kernel src to fix it but I don't feel comfortable doing this with a new kernel, so I tried to install the nvidia drivers without dkms but then I got this other error message
Code: Select all
The compiler used to compile the kernel (gcc 4.6) does not exactly match the current compiler (gcc 4.7). The Linux 2.6 kernel module loader rejects kernel modules built with a version of gcc that does not exactly match that of the compiler used to build the running kernel.


As I do not NEED the nvidia privative drivers by the moment I will wait to the final 3.8.0 kernel be released and the nvida installer to be ready for that kernel. So I still continue working with the nouveau driver.
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby RodneyLee on Fri Jan 11, 2013 12:53 pm

is there an easy way to return to nouveau nvidia driver module, I keep getting window artifacts (a window that won't close) when printing, copining files to XP/Vmware
and google earth..., seems to me some kinda notice window but is just grey and cannot be closed
RodneyLee
Level 1
Level 1
 
Posts: 21
Joined: Sun Nov 25, 2012 11:58 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby bobble on Wed Jan 16, 2013 8:11 pm

I've tried your installation instructions, but every time I get to a point where I have to reboot, I end up with a black screen after selecting the first line of the grub menu unless I elect to "e" edit it and add "nomodeset xforcevesa". That of course wipes out anything I've done to xorg.conf to use the Nvidia drivers.
bobble
Level 1
Level 1
 
Posts: 9
Joined: Wed Nov 28, 2012 7:04 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby McLovin on Tue Jan 22, 2013 9:40 pm

@bobbie
When grub loads, hit e to edit the entry, and find the part that says "quiet splash" and just delete those 2 words, that will give you a verbose boot up, and will show you any errors that are happening, try that, and post any errors that you find here so we can try to solve this issue.
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby bobble on Wed Jan 23, 2013 4:08 pm

@McLovin

Thanks for the offer to help. I've kind of given up on getting the Nvidia drivers to load for a while. I did finally find that I could edit grub with the "nomodeset" entry and get Mint to load that way.

I did a clean install of Mint 14 Nadia Mate with the "nomodeset" line added to grub and having been using it without the Nvidia drivers, but it would be nice if I could get the Nvidia drivers to work.

Over a period of several weeks, I did several clean installs of Mint 13 and tried to get Nvidia to work. I could activate the drivers, but they were never used and there were long lists of error in the Xorg.0.logs and other logs indicating that the Intel chip and Nvidia card weren't cooperating with each other and that there appeared to be some conflicts in memory address area. See my topic "Nvidia Issues"
viewtopic.php?f=59&t=122969 for more information.

I'll try again another time, but right now my attention has been diverted to solving some issues on my wife's W7 Laptop.

Thanks
Last edited by bobble on Fri Feb 01, 2013 2:35 pm, edited 1 time in total.
bobble
Level 1
Level 1
 
Posts: 9
Joined: Wed Nov 28, 2012 7:04 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby yoramdavid on Fri Jan 25, 2013 3:13 pm

Hello and thank you for the tutorial, unfortunately it did not work for me.

In my case I need to install the Nvidia-173 driver.
I am on LinuxMint 14, installed yesterday, first time using it.

I downloaded the driver and made it executable as shown here.
I hit Ctrl+alt+F1 and went to console.
The command
Code: Select all
sudo /etc/init.d/mdm stop

gave a command not found error, so I assumed I had to use
Code: Select all
sudo /etc/init.d/kdm stop
instead and it did something, but like others I ended up with a black screen and no place to type.
Hitting Ctrl+alt+F1 did nothing so I had to press the reset button to reboot.
I went again in command line mode and continued to type the commands of the tutorial, but it did not work without shutting down the kdm.
So I ran the command
Code: Select all
sudo chmod +x nvidia-173.run

Then the command
Code: Select all
sudo ./nvidia-173.run

and it returned the error:
Code: Select all
Error: You seem to be running an X server; please exit X before installing.


So I tried again from the beginning:
I hit Ctrl+alt+F1 and went to console, then I ran:
Code: Select all
sudo /etc/init.d/kdm stop

and this time I got the console working.
Then:
Code: Select all
sudo ./nvidia-173.run

and the installation process started, but there was an error:
Code: Select all
The distribution-provided pre-install script failed! Continue anyway?
Yes             No

I hit
Code: Select all
yes
and got the ERROR:
Code: Select all
The nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding.

I hit OK but Installation has failed.

After running
Code: Select all
sudo /etc/init.d/mdm start

I went back to the desktop, things seem fine.
What am I doing wrong?
We must be the change we want for the world (Ghandi)
User avatar
yoramdavid
Level 2
Level 2
 
Posts: 57
Joined: Fri Jan 25, 2013 2:41 pm
Location: Almodôvar, Baixo Alentejo, Portugal

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby spynoodle on Fri Jan 25, 2013 5:56 pm

When I installed the Nvidia proprietary drivers for my GT 545, I'm pretty sure that I just installed the package(s) from the Software Manager, and everything has worked fine for me. Is that bad? I'm a little new to Linux graphics drivers. :?
My caseless OC rig: Asus P5K Pro, Pentium E5200 @ 4GHz 1.4v, 4gb Crucial + Nanya DDR2 @ 853MHz, WD1200BB 120GB HDD, OEM Nvidia Geforce GT 545, Modded Kingwin RVT-12025D heatsink, AcBel R8 II 500w PSU, Linux Mint 14 Cinnamon
spynoodle
Level 1
Level 1
 
Posts: 9
Joined: Fri Jan 04, 2013 11:45 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby yoramdavid on Sun Jan 27, 2013 4:53 pm

I uninstalled the nouveau driver but that did nothing, it is still in use!
I followed this threat http://forums.linuxmint.com/viewtopic.php?f=191&t=82424 to disable it but I get the error of access denied even using sudo or gksudo.
We must be the change we want for the world (Ghandi)
User avatar
yoramdavid
Level 2
Level 2
 
Posts: 57
Joined: Fri Jan 25, 2013 2:41 pm
Location: Almodôvar, Baixo Alentejo, Portugal

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Otyugh on Thu Jan 31, 2013 2:17 pm

I've a terrible doubt.
I'm gone in synpatic I think, saw there was a list of 4-5 choices of "use nouveau, proprietary or last-release but unstable driver NVIDIA, etc.", I just made a choice, and then my processor stopped working like hell to display cinammon and I was able tu launch 3D things without any lagg, so i guessed I had installed everything right.

But as I see here, maybe i haven't installed a driver that could use my card at his best... Isn't it ?
Otyugh
Level 3
Level 3
 
Posts: 125
Joined: Wed Jan 02, 2013 9:52 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby ashfallen0 on Mon Feb 04, 2013 7:44 pm

I'm having the same problems as Jon who posted on page 1. I have a Sony Vaio SVS1511CFXB, which has the onboard intel 4000 and the Nvidia 640M LE gpu as discreet. The "bios" is from Insyde, which means it's basically useless. I have boot order only... the output of inxi:

$ inxi -SGx
System: Host: janette Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2) Desktop: Gnome Distro: Linux Mint 14 Nadia
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
Card-2: NVIDIA Device 0fd3 bus-ID: 01:00.0
X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@59.9hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.0 Direct Rendering: Yes
I reinstalled about 5 times this weekend as removing all noveau drivers and installing the official nvidia 310 drivers. Same as a few on here, I'm in gnome fallback in 640x480 with nvidia settings telling me that there are no nvidia drivers installed. I'm trying to run Eve online through Wine, which works, but it reports the "Intel Ivybridge" as my graphics, which is telling me that it's not trying my nvidia even with the pre-installed version.

Please, please help, since searching this forum with "Sony Vaio" tells me that "my search terms are too common." :evil: :evil:
ashfallen0
Level 1
Level 1
 
Posts: 3
Joined: Mon Feb 04, 2013 7:26 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Mon Feb 04, 2013 7:55 pm

ashfallen0
you have 2 gpu's so the only option is bumblebee
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Otyugh on Mon Feb 04, 2013 8:47 pm

I've now the proprietary driver (shame on me).
Nothing to say on the 3D. However.
Playing a video I just noticied a problem. On 2d video actually, on VLC or wathever video viewer I use, I have some "grid as in chess withe&grey" that appear sometimes at the edge of "movement" on the videos.
Is that something known as problem ?
Otyugh
Level 3
Level 3
 
Posts: 125
Joined: Wed Jan 02, 2013 9:52 pm

NVidia 313.18 drivers and kernel 3.7.6

Postby matthewls on Fri Feb 08, 2013 9:27 am

It took a while, but I finally learned how to get the latest NV drivers installed working with the latest kernel. So, in case anyone else wants to do this, here's the trick. (the same driver installed well and works fine on k3.7.5). With the 3.7.6 kernel the nvidia installer fails.
The reason it fails is one line in the conftest.sh file. So, the solution:

download the 313.18 driver file
sudo su
extract the files: ./NVIDIA-Linux-x86_64-313.18.run -x
cd NVIDIA-Linux-x86_64-313.18.run/kernel
gedit conftest.sh
go to line 1703. It should read: -a -n "$SUBLEVEL" -a $SUBLEVEL -le 5
change the 5 to a 6
save the file
exit gedit
cd ..
./nvidia-installer

And voila, the latest driver and kernel play well together again.
matthewls
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 08, 2013 9:11 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Napi2003 on Fri Feb 08, 2013 9:30 pm

Hello and thanks for the instructions.

One point that keeps popping everywhere and I assume has the failure rate at installing the NVIDIA propietary drivers is the following:

There are no clear / working instructions on how to get rid or even disable the odious "Nouveau" drivers that are deeply rooted on Nadia's (Mint 14.1) distro. Period.

If you can't disable said drivers, all the following steps are totally moot.

1. You can attempt at STOPping the service, and everytime you reboot the system, it will load the GUI, waiting to be "disabled" again and again.
Code: Select all
sudo service mdm stop
sudo /etc/init.d/gdm stop
sudo /etc/init.d/mdm stop

2. Not even an apt-get -remove --PURGE command will do the trick. It will always reinstall and reload each time you reboot the OS.
Code: Select all
sudo apt-get remove --purge nouveau*

3. the NVIDIA installer won't acknowledge your override command that stops checking for nouveau drivers (--no-nouveau-check, --disable-nouveau)
Code: Select all
sudo sh NVIDIA-Linux-x86_64-310.32.run --disable-nouveau
sudo sh NVIDIA-Linux-x86_64-310.32.run --no-nouveau-check

4. The NVIDIA driver installer adds the "nvidia-installer-disable-nouveau.conf" in /etc/modprobe.d with these lines:
Code: Select all
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

Guess what? That doesn't work either. Something as stubborn as this driver should legally be called a virus: It does no good and also refuses to move out.

What is needed is definitive instructions on how oliberate the oudious Nouevau drivers.

The NVIDIA installer acknowledges that it previously added some "trick file" to unload the drivers, but at this point it directs you to read some non-existent (or very well hidden) "README" file or consult your "distro manual" so you can wrestle it yourself at some machine code level.

This thing is starting to feel as hopeless and a total waste of time as ATI equally half-baked propietary drivers. The message is clear: Go back to Windows and forget this nightmare.

Anybody, please help. Thank you.
ECS Black Series dual PCIe board / AMD Phenom II 64-bit
SATA RAID-0 + 2 x IDE / ATI HD-3300 video inegrated video/ 8GB DDR3 / BFG NVIDIA 8800 Ultra 768 MB PCIe card
User avatar
Napi2003
Level 1
Level 1
 
Posts: 4
Joined: Thu May 03, 2012 8:59 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 2 guests