dialup without minicom

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

dialup without minicom

Postby Manuel Calavera on Sat Jan 26, 2013 10:37 am

Dear friends,

I try to find the way to connect to the Internet via dial-up (since in the area I want to try it this is almost the only way how to get an access to the Internet).
I have Linux Mint 14 MATE installed in my machine (the other one I want to try has Linux Mint 12 MATE). I bought TrendNet TFM-561U USB modem. And its package says that it is compatible with Linux.

I pluged in my modem. I discovered that its directory is /dev/ttyACM0 (strange directory, isn't it?). Then I configured minicom (as the modem's user's guide says) and I tried to establish a connection to the dialup ISP. Unfortunately the modem's speaker does not make a sound (for some reason), so I rely on what minicom terminal says to me. And after some moment the terminal asks for login and password. When I type them the communication is established. So I can conclude that it is possible to make an Internet connection with my modem on a Linux machine.

The bad part of the story is that I do this experiment for my parents who live in a remote village, not covered with 3G and the local landline phone company does not provide an xDSL option. So dialup is the only way to get an internet access for them. But since they are quite old people I can hardly make them use minicom and type some commands for it. So I wanted to make my modem work with Gnome PPP. But Gnome PPP does not see my modem. I. e. when I launch Gnome PPP, go to "Setup", then type "/dev/ttyACM0" in "Device", select "USB modem" in "Type" and press "Detect" I have the message "No modem found".

So how to make my modem work with Gnome PPP?

Thx.

UPD.

Suddenly I discovered that my modem can work only in sudo mode. I. e. if I run ether minicom or gnome-ppp in sudo mode my modem is always detected and I can make calls.
So now I want to make my modem work also in a normal user mode.

UPD-2.

Solved by myself.

I have created the file "70-trendnet-modem.rules" in the directory "/etc/udev/rules.d" with the following contents:

Code: Select all
# USB TrentNet TFM-561U modem
KERNEL=="ttyACM0", MODE="0777"


I restarted the system and now I can use my modem as a normal user!
Manuel Calavera
Level 1
Level 1
 
Posts: 1
Joined: Sun Oct 28, 2012 2:36 pm

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 2 guests