Why is LMDE still using Skype v2.1?

Questions about applications and software
Forum rules

Why is LMDE still using Skype v2.1?

Postby simplex on Sat Jan 26, 2013 11:40 am

This software is 4 years old! I cannot even send an SMS with this version of Skype!

Greetings,
S.
simplex
Level 3
Level 3
 
Posts: 135
Joined: Sat Oct 06, 2012 2:32 pm

Linux Mint is funded by ads and donations.
 

Re: Why is LMDE still using Skype v2.1?

Postby xenopeek on Sat Jan 26, 2013 11:43 am

I think because Debian testing repository is in feature freeze due to preparation for Debian 7 release. Debian PTS seems to confirm that: http://packages.qa.debian.org/p/pidgin-skype.html. Hence no newer version is available in LMDE yet, I think.

Edit: doh! I looked at the wrong package :o Ignore my post... zerozero has the info on this one...
Image
User avatar
xenopeek
Level 23
Level 23
 
Posts: 18182
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Why is LMDE still using Skype v2.1?

Postby zerozero on Sat Jan 26, 2013 2:53 pm

but ... there's no skype packaged in debian and lmde stop supplying the mint version of skype some time ago
Code: Select all
zerozero@deb-kde ~/Documents $ apt policy skype
skype:i386:
  Installed: 4.1.0.20-1
  Candidate: 4.1.0.20-1
  Version table:
*** 4.1.0.20-1 0
        100 /var/lib/dpkg/status

the question is: why you have skype 2.x in your installation?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

Re: Why is LMDE still using Skype v2.1?

Postby simplex on Sat Jan 26, 2013 3:42 pm

Because somewhere in the jungle of this forum, when asking for "skype on Linux Mint", I found a posting that said: Include the following line in your sources list:
Code: Select all
deb http://download.skype.com/linux/repos/debian/ stable non-free


Now I have

Code: Select all
ziegler@nc10:~$ LANG=C apt policy skype
skype:
  Installed: 2.1.0.81-1
  Candidate: 2.1.0.81-1
  Version table:
*** 2.1.0.81-1 0
        500 http://download.skype.com/linux/repos/debian/ stable/non-free i386 Packages
        100 /var/lib/dpkg/status
ziegler@nc10:~$ cat /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://lmde-mirror-fr-1.wedrop.it/latest testing main contrib non-free
deb http://lmde-mirror-fr-1.wedrop.it/latest/security testing/updates main contrib non-free
deb http://lmde-mirror-fr-1.wedrop.it/latest/multimedia testing main non-free
deb http://download.skype.com/linux/repos/debian/ stable non-free
simplex
Level 3
Level 3
 
Posts: 135
Joined: Sat Oct 06, 2012 2:32 pm

Re: Why is LMDE still using Skype v2.1?

Postby zerozero on Sat Jan 26, 2013 3:59 pm

well, that was either an old or outdated post;
skype moved to multiarch, so you must first go through this viewtopic.php?f=190&t=122296 and then download skype from here
http://beta.skype.com/en/download-skype/skype-for-linux/downloading/?type=debian32 (debian32bit)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

Re: Why is LMDE still using Skype v2.1?

Postby mockturtl on Sat Jan 26, 2013 6:14 pm

I needed libqtwebkit4:i386 to upgrade from 2.x.

Code: Select all
$ apt-cache depends skype
skype:i386
  Depends: libasound2:i386
  Depends: libc6:i386
  Depends: libc6:i386
  Depends: libgcc1:i386
  Depends: libqt4-dbus:i386
  Depends: libqt4-network:i386
  Depends: libqt4-xml:i386
  Depends: libqtcore4:i386
  Depends: libqtgui4:i386
  Depends: libqtwebkit4:i386
  Depends: libstdc++6:i386
  Depends: libx11-6:i386
  Depends: libxext6:i386
  Depends: libxss1:i386
  Depends: libxv1:i386
  Depends: libssl1.0.0:i386
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 447
Joined: Sat Oct 09, 2010 8:51 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 6 guests