Default browser for UP4 ?

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Default browser for UP4 ?

Postby jan_goyvaerts on Tue May 15, 2012 3:45 am

Since UP4 it looks like the default browser can not be set. Chrome keeps on asking me whether I want to set it as default. And when applications open a url I get a popup dialog to select the default browser.

Anybody else has/had this problem ?

TIA !

Jan
jan_goyvaerts
Level 2
Level 2
 
Posts: 57
Joined: Tue Nov 29, 2011 4:53 am

Linux Mint is funded by ads and donations.
 

Re: Default browser for UP4 ?

Postby äxl on Sun May 20, 2012 7:15 pm

I also have some problems with defaults. Have you tried Preferred Applications in the menu? (Options are greyed out for me.)
I tried to set it with following but it wouldn't change anything:
Code: Select all
sudo update-alternatives --config x-www-browser
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Default browser for UP4 ?

Postby jan_goyvaerts on Mon May 21, 2012 4:35 am

It's not greyed-out for me. But setting it has no effect. Chrome still asks whether it can be the default browser. Even when the preferred application is Chrome.
jan_goyvaerts
Level 2
Level 2
 
Posts: 57
Joined: Tue Nov 29, 2011 4:53 am

Re: Default browser for UP4 ?

Postby David Brown on Sun May 27, 2012 8:17 am

Preferred applications is greyed out for me too (in Maya with Mate). Is there a config file somewhere I can edit to change the preferred apps?
David Brown
Level 2
Level 2
 
Posts: 56
Joined: Sat Jun 28, 2008 5:55 pm

Re: Default browser for UP4 ?

Postby craigevil on Sun May 27, 2012 12:49 pm

sudo update-alternatives --config x-www-browser
sudo update-alternatives --config gnome-www-browser

Then check Preferred Applications and make sure the same browser is checked.

Linux Mint Forums • View topic - Opera as default browser <SOLVED> - http://forums.linuxmint.com/viewtopic.php?f=190&t=84566
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Default browser for UP4 ?

Postby jan_goyvaerts on Tue May 29, 2012 4:59 am

Nope. Still the same problem. The selection was identical anyway. Same after changing both the Chrome in item 2.

Maybe the problem is because Chrome is mentioned twice ?

Code: Select all
sudo update-alternatives --config x-www-browser
There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                    Priority   Status
------------------------------------------------------------
* 0            /usr/bin/google-chrome   200       auto mode
  1            /opt/firefox/firefox     70        manual mode
  2            /usr/bin/google-chrome   200       manual mode
  3            /usr/bin/opera           200       manual mode

Press enter to keep the current choice[*], or type selection number:

Code: Select all
sudo update-alternatives --config gnome-www-browser
There are 3 choices for the alternative gnome-www-browser (providing /usr/bin/gnome-www-browser).

  Selection    Path                    Priority   Status
------------------------------------------------------------
* 0            /usr/bin/google-chrome   200       auto mode
  1            /opt/firefox/firefox     70        manual mode
  2            /usr/bin/google-chrome   200       manual mode
  3            /usr/bin/opera           200       manual mode

Press enter to keep the current choice[*], or type selection number:
jan_goyvaerts
Level 2
Level 2
 
Posts: 57
Joined: Tue Nov 29, 2011 4:53 am

Re: Default browser for UP4 ?

Postby äxl on Tue May 29, 2012 4:07 pm

Alternatives are pretty much respected. If you want to try it out you could remove the Chrome alternative:
Code: Select all
sudo update-alternatives --remove x-www-browser /usr/bin/google-chrome
sudo update-alternatives --remove gnome-www-browser /usr/bin/google-chrome

http://wiki.debian.org/DebianAlternatives

Also look here for a similar problem:
viewtopic.php?f=199&t=99768#p585563
But a restart didn't help ...
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Default browser for UP4 ?

Postby craigevil on Tue May 29, 2012 5:59 pm

[SOLVED] Wrong web browser launched (i.e. not the default web browser) (Page 1) - Help & Support (Stable) - CrunchBang Linux Forums - http://crunchbanglinux.org/forums/topic ... b-browser/ see the third post, and #18.

$ xdg-settings get default-web-browser
Firefox.desktop

Which is correct for me.

Set the default web browser to google-chrome.desktop
Code: Select all
xdg-settings set default-web-browser google-chrome.desktop


There was also a gconf setting that can be set.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Default browser for UP4 ?

Postby jan_goyvaerts on Wed May 30, 2012 5:01 am

AHA ! There's something fishy about the dialog to select the default browser.

Before starting Chrome:
Code: Select all
xdg-settings get default-web-browser
custom-WebBrowser.desktop


When Chrome starts to sees it isn't the default browser and thus asks whether it can set it as such. So after doing that:
Code: Select all
xdg-settings get default-web-browser
google-chrome.desktop


After that my IDE (IntelliJ) wants to open a url. As a result a small popup dialog comes up asking me to select the default browser. Strange but okay. When Chrome is selected:
Code: Select all
xdg-settings get default-web-browser
custom-WebBrowser.desktop


Which brings us back to the situation before the very first start of Chrome. Etc... :-)

It looks to me there's a little bug in the popup window. And I won't be surprised if this is due to the fact I'm running the XFCE version of LMDE - but it's full of Gnome stuff in there too.
jan_goyvaerts
Level 2
Level 2
 
Posts: 57
Joined: Tue Nov 29, 2011 4:53 am

Re: Default browser for UP4 ?

Postby äxl on Wed May 30, 2012 10:44 am

Didn't work for me. Propably because I have no XFCE.

What worked was simply putting this in the $HOME/.local/share/applications/mimeapps.list
Code: Select all
text/html=firefox.desktop;
text/xml=firefox.desktop
application/xhtml_xml=firefox.desktop
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
x-scheme-handler/ftp=firefox.desktop
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Default browser for UP4 ?

Postby craigevil on Wed May 30, 2012 12:30 pm

my mimeapps.list
Code: Select all
[Added KDE Service Associations]
application/xhtml+xml=kwebkitpart.desktop;
application/xml=kwebkitpart.desktop;
text/html=kwebkitpart.desktop;
[Added Associations]
text/html=Firefox.desktop

[Default Applications]
text/html=Firefox.desktop


Firefox is my default browser.

11.10 - How to set Google Chrome as the default browser? - Ask Ubuntu - http://askubuntu.com/questions/96080/ho ... lt-browser
You should have in the ~/.local/share/applications/mimeapps.list file the following lines:

text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop

Make sure these lines are under either the [Default Applications] or [Added Associations] section.

And of course, you need google-chrome installed such that google-chrome.desktop is either located at /usr/share/applications/, /usr/local/share/applications/ or ~/.local/share/applications/.


Change the google-chrome.desktop to whichever browser you are wanting to use.

Unset Chromium as default browser on Ubuntu - http://playingwithsid.blogspot.com/2012 ... er-on.html
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Default browser for UP4 ?

Postby jroddius on Sat Jan 26, 2013 1:51 pm

I know this is an older thread but I ran into this problem today on Linux Mint 13 XFCE. I got Chrome working using this post so here is what I did different. I set the the update-alternatives to option zero auto google chrome. I ran the xdg command and found that google-chrome.desktop was already set. Then I went into Preferred Applications and set my Web Browser to google chrome.
Then here is the key to my success. I clicked on my menu button on the panel and then I clicked Web Browser. Google Chrome should come up and it will display a message "google chrome not set as default browser". DO NOT CLICK THE BUTTON THAT SETS GOOGLE CHROME AS THE DEFAULT WEB BROWSER INSTEAD CLICK THE BUTTON THAT SAYS DO NOT SHOW THIS MESSAGE AGAIN. ok thats it now google chrome loads for me everytime as the default. Thank you guys so much for all the earlier posts without those posts I'd be stuck. Thanks ;)
jroddius
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 26, 2013 1:15 pm

Re: Default browser for UP4 ?

Postby jroddius on Sat Jan 26, 2013 2:03 pm

One more thing after performing my above post I checked my preferred applications and my preferred web browser is now set to chromium and no I am not running chromium I am running the official chrome. So you may just need to set that to chromium and then when you launch chrome with the web browser click Do Not Show Message Again. I have not tried this but thought is was worth the mention.
jroddius
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 26, 2013 1:15 pm

Re: Default browser for UP4 ?

Postby zerozero on Sat Jan 26, 2013 3:07 pm

please don't bump old topics (see the forum rules), also this topic is about lmde and not mint main edition.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 1 guest