Shutting down one network controller

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Shutting down one network controller

Postby xmanmonk on Wed Jan 30, 2013 3:23 pm

My mother has Mint 13 on her Toshiba laptop. Her laptop has a consistent problem with the built-in wifi network controller (apparently a known issue, judging from various blogs). I bought a USB wifi adapter for about $10, and it works great. Unfortunately, the built-in wifi occasionally comes to life at seemingly random moments.

I thought I could just put in a startup script like this:

Code: Select all
kdesudo ifconfig wlan0 down


I threw it in a shell script and plopped it in the ~/.kde/Autostart directory, and it ran and shut down the controller. Unfortunately, it also shut down the other controller (wlan1).

So my assumption is that I am doing something wrong (usually a safe assumption). Can someone suggest the proper way to do this? Unfortunately, the built-in controller is not on a separate board, so there's no way to unplug it. If this doesn't work, we may just have to buy another machine, but I'd rather fix this, even if it's a kludgy fix. Thanks!
-The X-Man
User avatar
xmanmonk
Level 1
Level 1
 
Posts: 33
Joined: Sun Mar 11, 2012 8:42 pm
Location: Santa Rosa, California, USA

Linux Mint is funded by ads and donations.
 

Re: Shutting down one network controller

Postby xenopeek on Wed Jan 30, 2013 3:26 pm

I know laptop BIOSes are usually hopeless, but have you checked if you can disable the onboard Wi-Fi in the BIOS?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14847
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Shutting down one network controller

Postby AlbertP on Wed Jan 30, 2013 3:43 pm

Could you run these commands in terminal:
Code: Select all
inxi -N
rfkill list


Maybe there is a way to get that adapter disabled in software, if BIOS does not offer an option for that.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Shutting down one network controller

Postby xmanmonk on Wed Jan 30, 2013 8:45 pm

Nothing in the BIOS. It's a pretty old machine, and although Toshiba apparently provided a BIOS upgrade, all the reports I saw online said the upgrade did not fix the problem (nor did it offer a way to disable the adapter).

I'll try the commands right now and reply with the results. Thanks!
-The X-Man
User avatar
xmanmonk
Level 1
Level 1
 
Posts: 33
Joined: Sun Mar 11, 2012 8:42 pm
Location: Santa Rosa, California, USA

Re: Shutting down one network controller

Postby xmanmonk on Wed Jan 30, 2013 9:59 pm

Well, here's what happened. I did the following:
Code: Select all
Script started on Wed 30 Jan 2013 05:47:48 PM PST
lorraine@BigBertha ~ $ inxi -Nx
Network:   Card-1: Atheros AR5212/AR5213 Wireless Network Adapter driver: ath5k bus-ID: 02:02.0
           Card-2: Realtek RTL-8139/8139C/8139C+ driver: 8139too ver: 0.9.28 port: 3000 bus-ID: 02:01.0
           Card-3: Ralink RT5370 Wireless Adapter usb-ID: 148f:5370
lorraine@BigBertha ~ $ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: phy1: Wireless LAN
        Soft blocked: no
        Hard blocked: no
lorraine@BigBertha ~ $ exit

Script done on Wed 30 Jan 2013 05:48:11 PM PST


I then issued an rfkill block 0 command. A subsequent rfkill list showed that wlan0 was soft blocked. A moment later, it changed to being hard blocked. Furthermore, I couldn't connect to anything through wlan1. My network controller would not allow me to select "enable wireless" on the network controller dialog.

I am beginning to suspect that it's time to melt this poor machine into slag and purchase a new one. I'd rather not, so if there's any perceivable way to save this, any help will be appreciated. Thanks.
-The X-Man
User avatar
xmanmonk
Level 1
Level 1
 
Posts: 33
Joined: Sun Mar 11, 2012 8:42 pm
Location: Santa Rosa, California, USA

Re: Shutting down one network controller

Postby AlbertP on Thu Jan 31, 2013 4:48 am

It is indeed true that wifi might get disabled completely if you disable one adapter.

Please run:
Code: Select all
sudo sh -c 'echo "options ath5k nohwcrypt" > /etc/modprobe.d/ath5k.conf'
That may fix the built-in wifi, then you may not need the USB adapter anymore.

If it doesn't help, edit the file again:
Code: Select all
gksudo gedit /etc/modprobe.d/ath5k.conf
And replace the text by:
Code: Select all
blacklist ath5k

Then the driver is not loaded anymore, and you won't be bothered by internal wifi.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands


Return to Wireless

Who is online

Users browsing this forum: No registered users and 9 guests