USB Drive automounts after login

USB Drive automounts after login

Postby gmakka on Thu Jan 31, 2013 6:23 am

Hi Guys,

Installed linux mint 14 with mate the other day. Every time that i login, the connected USB drives automatically mount and a file browser pops up.

Whilist this is convient sometimes, 99% of the time, it's REALLY annoying :) Oh, and then when i logout and back in again, it then tells me that it can't mount the drive, because it's previously mounted else where

Is there a way to turn this off?

Thanks
Grant
gmakka
Level 1
Level 1
 
Posts: 1
Joined: Thu Jan 31, 2013 6:17 am

Linux Mint is funded by ads and donations.
 

Re: USB Drive automounts after login

Postby jungle_boy on Thu Jan 31, 2013 6:16 pm

Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: USB Drive automounts after login

Postby Trapper on Sun Feb 03, 2013 9:05 am

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot


I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.
Trapper
Level 3
Level 3
 
Posts: 183
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: USB Drive automounts after login

Postby jungle_boy on Sun Feb 03, 2013 11:15 am

Trapper wrote:I think the OP may be more interested in preventing the auto mount of USB connected drives at login rather than the prevention of the file browser opening when the drive's mounted.


I tested and it works fine...
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1216
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: USB Drive automounts after login

Postby mikkelbreiler on Thu Mar 28, 2013 1:48 pm

jungle_boy wrote:Try:

Menu>Control Center>File Management>Media tab

Uncheck "Browse media when inserted"

Close

Reboot


I want to turn this feature off too My USB hard drive tower is reactivated from power off rather often, without anything doe by me and every time this happens a window appears on top of what I am oing so I can click it away.

I have Linux Mint Cinnamon installed and if I select "Menu", at the bottom left I do not see anything labelled "Control Center". Where do I find "Control Center", "File Mangement" and the "Media" tab ?

-Mikkel
mikkelbreiler
Level 1
Level 1
 
Posts: 1
Joined: Thu Mar 28, 2013 1:30 pm

Re: USB Drive automounts after login

Postby DrHu on Thu Mar 28, 2013 2:29 pm

Apart that it (a line entry ref: usb device) may be in /etc/fstab, the static mounts for devices: the usual location for inserted media is /media, hence you are allowed to alter its operation per device in that location
The media TAB mentioned, or you can use a file manager, whichever one you have, Cairo, nautilus, thunar (should be in menu(s) or as an ICON on your desktop)), and then a right-click-->properties will get data you can manage/change..
http://www.linuxlinks.com/article/20081 ... agers.html
http://www.maketecheasier.com/linux-fil ... 2010/04/29
User avatar
DrHu
Level 16
Level 16
 
Posts: 6882
Joined: Wed Jun 17, 2009 8:20 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests