Speaker works, headphones don't (misconfigurations?)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Speaker works, headphones don't (misconfigurations?)

Postby ffriend on Fri Feb 01, 2013 12:19 pm

Ok, this is one hundred thousandth question about sound in Linux, but after days of experiments I've got too tired to test different options at random.

When I only installed Linux Mint, it worked great. Sound from both - internal speaker and headphones - was completely ok. After some time (and probably my incorrect actions) sound in headphones disappeared. I found out that it was a problem with automatic switching between speaker and headphones - manual switching in Sound Settings fixed that problem.

Of course, it was temporary solution, so a week later I came back to this problem and tried to fix the problem myself... how naive I was. After my "fixes" not only automatic switching stayed broken, but also sound in headphones disappeared completely.

My latest attempts (that actually could break sound settings) are:

1. In file "/usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf" changing [Speaker Element]

[Element Speaker]
switch = on
volume = ignore

(solution found on StackExchange, doesn't work, reverted to "off" for both params)

2. In file "/etc/modprobe.d/alsa-base.conf" adding line:
options snd-hda-intel model=<config-option>

with <config-option> set to "basic", "generic", "hp-laptop", "m51va position_fix=0", "3stack-dig position_fix=0". Nothing changed - neither headphones started to work, nor speaker stopped.

3. Playing around with alsamixer. Right now:

Master: active
Headphones: active
Speaker: muted
PCM (don't know what it is): max volume
Mic: muted
Mic boos: zero volume
S/PDF: active
Auto-mute: enabled
Internal: muted
Internal (another bar): 20%

Headphones plugged-in, but no sound.

Some system info is below, if you need something else, just let me know.

------------------------------------

Laptop: ASUS K55V
OS: Linux Mint 14 Cinnamon

Code: Select all
sudo lshw -c sound
  *-multimedia           
       description: Audio device
       product: Panther Point High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:46 memory:f7a10000-f7a13fff


Any help will be appreciated.
ffriend
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 01, 2013 8:49 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests