[solved] locale settings .dmrc causing desktop load problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[solved] locale settings .dmrc causing desktop load problems

Postby mintbadger on Fri Feb 01, 2013 5:24 pm

Hi

I've had problems with my locale ever since I installed Mint14, with MATE desktop. I have been getting the error "Language en_GB does not exist; using system default" following boot. I want rid of this message and don't mind using en_US.

I've been trying various fixes and thought I'd try and set everything to en_US.
So I changed my etc/default/locale file to contain:

Code: Select all
LANG="en_US.UTF-8"
LANGUAGE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_ALL="en_US.UTF-8"


When I reboot however, this file is unchanged but looking at locale from the command line I get :
~ $ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8


It would appear that something is changing the LANG and LANGUAGE lines to GB. And my feeling is that the format of the second of these should be LANGUAGE=en_US.UTF-8 or at the least LANGUAGE=en_GB.UTF-8

What is changing locale LANG and LANGUAGE besides the etc/default/locale file?

Thanks
Mintbadger
Last edited by mintbadger on Fri Feb 01, 2013 7:34 pm, edited 2 times in total.
mintbadger
Level 1
Level 1
 
Posts: 14
Joined: Wed Sep 21, 2011 7:54 pm

Linux Mint is funded by ads and donations.
 

Re: locale settings

Postby bb333 on Fri Feb 01, 2013 5:36 pm

Make sure installed:
Code: Select all
$ locale -a


edit file back again, then:

Code: Select all
$ sudo dpkg-reconfigure locales
bb333
Level 2
Level 2
 
Posts: 60
Joined: Wed Jan 23, 2013 3:50 pm

Re: locale settings

Postby mintbadger on Fri Feb 01, 2013 6:36 pm

Hi

I have tried this already:

~ $ locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX
zh_CN.utf8
zh_SG.utf8

$ sudo dpkg-reconfigure locales
[sudo] password for :
Generating locales...
en_AG.UTF-8... up-to-date
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NG.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZM.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
Generation complete.


So the US locale is available and up to date.
However, I still get the same error that en_GB isn't available when I reboot and it would appear that something is overriding the en_US settings from the etc/default/locale file and replacing these with LANG=en_GB:en which is causing the error.

Have you any idea what could be doing this? MATE perhaps, or some other config file Mint is loading before boot?
mintbadger
Level 1
Level 1
 
Posts: 14
Joined: Wed Sep 21, 2011 7:54 pm

Re: locale settings

Postby mintbadger on Fri Feb 01, 2013 7:06 pm

Okay, I used grep and found the following files in my home directory which contained en_GB
.dmrc
.pam_environment

They both have rogue looking LANGUAGE=en_GB:en and other lines in.

I guess it is one of these which is changing the locale settings from /etc/default/locale on boot

I'll try and change them and hopefully that will work...
mintbadger
Level 1
Level 1
 
Posts: 14
Joined: Wed Sep 21, 2011 7:54 pm

Re: locale settings

Postby xenopeek on Fri Feb 01, 2013 7:20 pm

This may be relevant: viewtopic.php?f=42&t=111527. I also believe for similar sounding errors users have fixed it by setting their preferred language as the default on the login screen. I'd try that first.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14860
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: locale settings

Postby mintbadger on Fri Feb 01, 2013 7:31 pm

I got it!

$HOME/.dmrc has a line
Language=en_US:UTF-8


I found whatever I put instead of "en_US:UTF-8" was shown on the error before loading the desktop after boot.

I just commented out this line and the error has gone away. This file must have copied been copied when I upgraded from the last version of Mint.

I then switched back to en_GB and am good to go.

Thanks for your help.
mintbadger
Level 1
Level 1
 
Posts: 14
Joined: Wed Sep 21, 2011 7:54 pm


Return to Newbie Questions

Who is online

Users browsing this forum: dasWindmill, Google [Bot], Google Adsense [Bot], Reorx and 37 guests