Wine doesn't work for me

Questions about applications and software
Forum rules
Before you post please read this

Wine doesn't work for me

Postby AirbusA<380 on Sun Feb 03, 2013 2:23 am

Hi
The reason i'm posting is because when i try to run a program in wine it doesn't work. if i try launching from terminal it says: wine: cannot find L"C:\\windows\\system32\\fgfs.exe" Assuming the program is fgfs (flightgear). Could anyone help me?
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Linux Mint is funded by ads and donations.
 

Re: Wine doesn't work for me

Postby passerby on Sun Feb 03, 2013 4:02 am

It sounds like the problem is with the path to the file you're trying to execute rather than wine itself.
Are you trying to run programs from a windows partition?
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby Pierre on Sun Feb 03, 2013 5:44 am

Have you tried using the commercial version of Wine:-
https://www.codeweavers.com/products/windowsmac/

see if your program is in the supported list ....
Image
User avatar
Pierre
Level 6
Level 6
 
Posts: 1215
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Wine doesn't work for me

Postby AirbusA<380 on Sun Feb 03, 2013 5:46 am

No i only have mint on my computer, and the fgfs.exe file is in the correct .wine c_drive file.
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Sun Feb 03, 2013 5:56 am

What is the exact command you're trying to run?
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Sun Feb 03, 2013 5:17 pm

$ wine fgfs. Or just clicking on the flightgear icon in the wine programs folder in "start menu" , then just nothing happens. By the way iv'e tried other programs too, and nothing works, i'm just using flightgear for an example
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Sun Feb 03, 2013 7:01 pm

$ wine fgfs
should work if the terminal is in the directory where the program is installed. Have you tried using the absolute path to the .exe?
$ wine "~/.wine/whatever/fgfs.exe"
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Sun Feb 03, 2013 8:25 pm

I get this: error of failed request: BadAlloc (insuficient resources for operation
Major OPT code of failed request: 153 (GLX)
Minor OPT code of failed request: 3 (GLX ceatecontent)
Serial number of failed request : 217
current serial number in output stream: 221

does this mean my computer ins't up to par? it is Pentium 4, 489 Mb ram
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Sun Feb 03, 2013 11:43 pm

It's usually caused by insufficient memory on your video card (or bugs with the display manager).
I don't know how resource-heavy/light the program you're trying to run is, but it does appear to be an older system.
Somewhat useful discussion on the error here: http://forums.debian.net/viewtopic.php?t=32259
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Mon Feb 04, 2013 3:37 am

Well the Program worked when i still had windoze installed... but lots of other things didnt and Mint is a million times better than that even if i can´t fly with it...
BTW could it be i haven't got the correct video/graphics driver installed?
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Mon Feb 04, 2013 4:02 am

Definitely possible.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Tue Feb 05, 2013 4:27 am

can a person get Video-graphic driver updates for Linux?
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Tue Feb 05, 2013 4:55 am

Yes. The options depend on your graphics card though.
eg. modern nvidia cards can use nvidia-current, older ones use nvidia legacy drivers, etc.
If in doubt, google your video card + ubuntu.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Thu Feb 07, 2013 4:54 pm

Ok this sounds horribly dumb, but how do i know what model my video card is? (i never was much of a geek)
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby passerby on Thu Feb 07, 2013 5:14 pm

Open a terminal and enter:
Code: Select all
inxi -G
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Wine doesn't work for me

Postby AirbusA<380 on Wed Feb 13, 2013 3:22 am

Hey Thanks for all your time, passerby, its really cool that you guys do all this for free. It´s just that my ¨mint¨ is 32 bit and my computer is 64....
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby AirbusA<380 on Wed Feb 13, 2013 3:22 am

Hey Thanks for all your time, passerby, its really cool that you guys do all this for free. It´s just that my ¨mint¨ is 32 bit and my computer is 64....
AirbusA<380
Level 1
Level 1
 
Posts: 9
Joined: Sun Feb 03, 2013 2:16 am

Re: Wine doesn't work for me

Postby raymerjacque on Wed Feb 13, 2013 4:34 am

open your Home folder and "CTRL+H" to show hidden filesa and folders. then go to .wine-->Drive_C and find the EXE of the program and run it manualy and see if it open. If it does then the shortcut in the menu is broken ( it is not uncommon for that to happen ).

To create a shortcut to Wine apps just right click desktop and choose create launcher, under type set it to "Location", then browse to app via home/.wine/Drive_c/ to where EXE is, give it a name and icon and shortcut created :)
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com
User avatar
raymerjacque
Level 4
Level 4
 
Posts: 227
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Yahoo [Bot] and 24 guests