Cannot mount removeable devices

Forum rules
Before you post please read this

Cannot mount removeable devices

Postby bazzaman on Mon Feb 04, 2013 3:18 am

I'm running Mint 13 KDE on a Lenovo S100 netbook.
I have been using this setup for some time now, without any difficulty, i.e. device notifier recognised removeable drives, and they could be opened in file manager.
But today I had some difficulty booting, and had to mess about with boot priorities in BIOS (no UEFI).
Afterwards, I could not mount removeable devices.
In system setting>removeable devices I checked all the boxes above "Device Over-rides", (this setup works on another machine I have with the same Mint 13 KDE), but no device notifier appears in the kicker panel. "show hidden icons" only contains "printer applet".
I had also been trying to get KGpg and Truecrypt working. I had files of each on separate pendrives, and could only manage to mount the drives by going into the managers for KGpg and Truecrypt.
Is there some way to mount removeable devices using command line?
Or any other suggestions would be appreciated.
thanks
bazzaman
Level 1
Level 1
 
Posts: 19
Joined: Wed Jun 24, 2009 6:05 am

Linux Mint is funded by ads and donations.
 

Re: Cannot mount removeable devices

Postby owend on Mon Feb 04, 2013 5:49 am

i don't have KDE Mint (yet), so this may not be totally relevant, but I had a similar problem with Mint 13 Gnome; I got access by rightclicking and opening as administrator. An error message sometimes says "Cannot access...", but ignore it, it lies, you can!
owend
Level 2
Level 2
 
Posts: 57
Joined: Fri Jul 10, 2009 11:51 am

Re: Cannot mount removeable devices

Postby bazzaman on Mon Feb 04, 2013 8:45 am

Sorry, not sure what you 'right click' on... If on desktop, then pop-up in KDE does not offer that "open as administrator" option.
bazzaman
Level 1
Level 1
 
Posts: 19
Joined: Wed Jun 24, 2009 6:05 am

Re: Cannot mount removeable devices

Postby owend on Mon Feb 04, 2013 1:25 pm

As I said, I'm not a KDExpert :? ! In Gnome, when it opens with the Desktop: go to Computer > Places and on the right there's a panel where there's a list of places including USB, CD, etc - external devices and other partitions. Highlight the one you want and rightclick; one of the pop-up menu choices is Open as Administrator. I use this mainly to open other partitions and access their files, but it also allows me to open external devices.

I've used Gnome for years but I'm going to install Mint KDE, to start getting familiar with the KDE environment, so I'll soon find out if this works in KDE!
owend
Level 2
Level 2
 
Posts: 57
Joined: Fri Jul 10, 2009 11:51 am

Re: Cannot mount removeable devices

Postby owend on Mon Feb 04, 2013 2:52 pm

OK, confession. I've looked at Kubuntu, which is set up on a partition on my computer but I haven't used for some time. I don't need the "Administrator" access option with it, and I can't see how to force the OS to open a device as Administrator/Superuser in Kub - possibly by CLI with experimenting?

I've probably been wasting your time, sorry. :oops:
owend
Level 2
Level 2
 
Posts: 57
Joined: Fri Jul 10, 2009 11:51 am


Return to KDE

Who is online

Users browsing this forum: DeMus and 7 guests