Another EFI boot problem

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Another EFI boot problem

Postby Roel Zuidema on Fri Feb 01, 2013 5:04 am

Hello,
unaware of the existence of EFI I installed Linux Mint 14 on my new Asus Zenbook UX31A. I installed it from DVD: iso. I installed it alongside Windows 7 and it went without problems. New partitions were made automatically.
Wenn I restartet the computer, however, I couldn't reach the LInux OS. The only options are to boot eather Windows or CD-player.
In the EFI menu I can add another Boot-entry, but I can't find out how to reach the installed Linux OS.
Has anyone ideas how to manage this problem?
Thanks
Roel Zuidema
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 16, 2013 10:48 am

Linux Mint is funded by ads and donations.
 

Re: Another EFI boot problem

Postby wayne128 on Fri Feb 01, 2013 5:16 am

Get EasyBCD from Neosmart, run in Windows OS, add an entry of grub2..
reboot and select the grub2 entry .
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Another EFI boot problem

Postby srs5694 on Fri Feb 01, 2013 11:03 am

I have yet to see a report of EasyBCD doing anything helpful for a Linux/Windows EFI-mode installation, although its Web page does claim to now support EFI. Maybe it'll work, but I wouldn't get my hopes up for that.

Ubuntu's "Boot Repair" tool is more likely to help in this sort of situation, although it tends to set things up in a way that can complicate matters in the future. I'm also not 100% certain that it will work with GRUB.

Another option is to use my rEFInd boot manager. Download the Debian package and either the CD or USB flash drive image. Prepare a CD or USB flash drive and boot from it. You can then boot to Mint by selecting one of the penguin icons, although you'll probably need to hit F2 or Insert twice and add a reference to your root device, as in "ro root=/dev/sda7" (or whatever it is). Once you've booted Mint, install the Debian package and it should work more smoothly.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Another EFI boot problem

Postby Roel Zuidema on Mon Feb 04, 2013 11:43 am

Hi srs5694

You wrote:
Another option is to use my rEFInd boot manager. Download the Debian package and either the CD or USB flash drive image. Prepare a CD or USB flash drive and boot from it. You can then boot to Mint by selecting one of the penguin icons, although you'll probably need to hit F2 or Insert twice and add a reference to your root device, as in "ro root=/dev/sda7" (or whatever it is). Once you've booted Mint, install the Debian package and it should work more smoothly.

Thanks a lot, I installed it from Windows and its the first step. I still can't start my installed Linux. When I choose Linux in the rEFInd menu, it looks like starting LInux, but in the logs written on the screen it says things like
Mount /root/.... failed: no such file or directory.
And after a few lines it stops running.

I have no idea how to solve this problem.
Roel Zuidema
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 16, 2013 10:48 am

Re: Another EFI boot problem

Postby srs5694 on Mon Feb 04, 2013 2:28 pm

Roel Zuidema wrote:You wrote:
Another option is to use my rEFInd boot manager. Download the Debian package and either the CD or USB flash drive image. Prepare a CD or USB flash drive and boot from it. You can then boot to Mint by selecting one of the penguin icons, although you'll probably need to hit F2 or Insert twice and add a reference to your root device, as in "ro root=/dev/sda7" (or whatever it is). Once you've booted Mint, install the Debian package and it should work more smoothly.

Thanks a lot, I installed it from Windows and its the first step. I still can't start my installed Linux. When I choose Linux in the rEFInd menu, it looks like starting LInux, but in the logs written on the screen it says things like
Mount /root/.... failed: no such file or directory.
And after a few lines it stops running.


That's because it doesn't know what its root device is. That's the purpose of adding the "ro root=/dev/sda7" boot option I described in my post that you quoted (and that I've quoted again, for quick reference). You'll need to change "/dev/sda7" to whatever your root partition is. If you're not sure what that is, you'll have to figure it out with the help of a partitioning program. It's probably your biggest ext4fs partition.

Given where you are, I recommend you not install the Debian package once you've booted Mint. Instead, run the "mkrlconf.sh" script that comes with rEFInd. That will create the configuration file (/boot/refind_linux.conf) that contains the root device information. Thereafter, you won't need to manually enter this information when booting Mint from rEFInd. You only need to do this once, so that you can get into Linux to run mkrlconf.sh.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Another EFI boot problem

Postby Roel Zuidema on Tue Feb 05, 2013 6:46 am

That's because it doesn't know what its root device is. That's the purpose of adding the "ro root=/dev/sda7" boot option I described in my post that you quoted (and that I've quoted again, for quick reference). You'll need to change "/dev/sda7" to whatever your root partition is. If you're not sure what that is, you'll have to figure it out with the help of a partitioning program. It's probably your biggest ext4fs partition.


The thing is: I really don't know how. When I presse F2 at start up, I'm opening the Aptio Setup Utility Version 2.15.1226 - 2012 American Megatrends.
In it's bootmenu I can Add New Boot Option - 4 steps:
1) Add boot option: (enter a name) Linux Mint
2) Select Filesystem: (I've no choice) PCI(.........
3) Path for boot option: (format fsx:\path\filename.efi) Here I've tried to enter the /dev/sda6, but it's obviously not the place
4) Create

I will need to point to a certain .efi file?

It might be simple, but I don't no where to find the solution.
Roel Zuidema
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 16, 2013 10:48 am

Re: Another EFI boot problem

Postby srs5694 on Tue Feb 05, 2013 1:19 pm

Try this:

  1. Boot from your Mint installation disk, but don't launch the installer program.
  2. Launch a Terminal window. (On my Mint 14 disc, that's the small icon of a computer screen with ">_" inside it.)
  3. Type "sudo gparted". A GParted window will open.
  4. In the GParted window, identify your Mint partition. It will probably be the largest ext4 partition. In fact, it's probably the only ext4 partition. It should have an associated device filename, like /dev/sda3 or /dev/sda8.
  5. Reboot into rEFInd and follow the instructions I presented earlier, substituting the device filename you identified for the "/dev/sda7" that I used in my example.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Another EFI boot problem

Postby Roel Zuidema on Wed Feb 06, 2013 12:11 pm

Thanks,

Now I've found out I had to press F2 in the rEFInd Menu, it all went pretty fast.
Only thing I've to figure out is how to select Linux as first choice in rEFInd.
Thanks a lot. You really helped me.
Roel Zuidema
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 16, 2013 10:48 am

Re: Another EFI boot problem

Postby srs5694 on Wed Feb 06, 2013 1:16 pm

Roel Zuidema wrote:Now I've found out I had to press F2 in the rEFInd Menu, it all went pretty fast.
Only thing I've to figure out is how to select Linux as first choice in rEFInd.
Thanks a lot. You really helped me.


I'm glad to have helped. You can set the default loader by uncommenting and editing the "default_selection" option in refind.conf.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Bing [Bot], Neoto and 7 guests