Mint doesn't boot after Radeon driver install, GRUB broken

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint doesn't boot after Radeon driver install, GRUB broken

Postby BadgerPriest on Mon Feb 04, 2013 12:11 am

Hi all,

I've been a happy user of Linux Mint Debian Edition for about six months now.

Today, while trying to get some games working, I decided to install the official AMD Radeon HD 6xxx series driver, from the AMD website. The driver installation went smoothly, but afterwards all applications requiring OpenGL stopped working, complaining about a missing libgl.so.1 file.

I tried restarting Linux Mint, but it wouldn't boot correctly, simply launching into a black screen. I assume that there is some issue in the AMD driver that I installed that breaks graphics completely.

I tried booting from my Linux Mint Debian install CD, but it wouldn't boot - there's only a blank prompt when I try to use it.

Finally, I saw the instructions on viewtopic.php?f=46&t=122257 and tried following them. It did not fix the issue, and furthermore GRUB stopped working immediately afterward (I'm not sure if it's connected to these instructions or not, but it's a weird coincidence). Now I can't do anything - when I turn on my computer, there's just a blank prompt instead of GRUB, I can't dual-boot into Windows, and I still can't use my install CD.

What can I do?
BadgerPriest
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 04, 2013 12:00 am

Linux Mint is funded by ads and donations.
 

Re: Mint doesn't boot after Radeon driver install, GRUB brok

Postby jungle_boy on Mon Feb 04, 2013 8:17 pm

Try to start in text mode:

http://rolling-ubuntu.blogspot.com.br/2012/06/ubuntu-1204-tip-booting-to-text-mode.html

After, install linux non-proprietary graphic card driver;

Code: Select all
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install xserver-xorg-video-radeon


Reboot, check all and change boot option, from text mode to quiet splash
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1215
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Mint doesn't boot after Radeon driver install, GRUB brok

Postby BadgerPriest on Tue Feb 05, 2013 1:03 am

Hi jungle_boy,

Thanks for the tip, but unfortunately booting to text mode doesn't work: I'm still getting the black screen on startup, even after changing the mode from "quiet" to "text" in GRUB. For about 15 seconds, I can see the loading commands running, but then everything goes black. If text mode doesn't work either, does that mean that the error isn't with X?

(As far as GRUB itself goes, it started working again about a half hour after my first post. I have no idea what happened.)

jungle_boy wrote:Try to start in text mode:

http://rolling-ubuntu.blogspot.com.br/2012/06/ubuntu-1204-tip-booting-to-text-mode.html

After, install linux non-proprietary graphic card driver;

Code: Select all
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install xserver-xorg-video-radeon


Reboot, check all and change boot option, from text mode to quiet splash
BadgerPriest
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 04, 2013 12:00 am

Re: Mint doesn't boot after Radeon driver install, GRUB brok

Postby jungle_boy on Tue Feb 05, 2013 12:25 pm

Reinstall; it is faster...
LM17 Cinnamon (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1215
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 16 guests