Speaker Popping sound on Windows 8 after using LinuxMint 14

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Speaker Popping sound on Windows 8 after using LinuxMint 14

Postby acdindia on Sun Dec 23, 2012 8:44 am

Hi!

I am using Linux Mint 14 MATE x64 on my DELL Inspiron 17R SE 7720.
This laptop has two speakers and a Sub-woofer from Skullcandy.
The audio is IDT.
My problem is that my audio worked fine on Windows 8 x64 prior to installation of LinuxMint 14 MATE on dual boot.
After I used LinuxMint and booted back to Windows 8, my speakers started giving random popping sound.
First I thought it was not related.
The audio works without popping sounds on LinuxMint, but when I boot into Windows 8, it starts popping!!!. :evil:
To confirm this, I formatted Windows 8 and the popping sound was gone.
To verify, I booted into LinuxMint and booted back to Windows 8 and the speaker popping sound was back!!!!! :evil:
I uninstalled the IDT driver, rebooted and reinstalled the driver, the popping sound was gone!!!!
Again, I booted into LinuxMint and back to Windows, guess what, popping was backk!!!! :evil:

So, now I have re-installed IDT driver on Windows 8 and have no popping sounds....
I am reluctant in running LinuxMint cuz it will bring back the popping sound n may spoil my hardware... !!!!

PLEASE HELPPPPPPP!! I am a bioinformatics person and can't live without linux! :( :|

Thanks in advance!!!
acdindia
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 23, 2012 8:26 am

Linux Mint is funded by ads and donations.
 

Re: Speaker Popping sound on Windows 8 after using LinuxMint

Postby CodeBr4k3R on Mon Feb 04, 2013 8:40 pm

i have exactly the same hardware, and *exactly* the same problem !!
It also goes away when you uninstall Mint 14, and comes back after the installation again. It's really annoying.
This will damage my hardware, please do something, i don't want to uninstall Mint 14 :/
CodeBr4k3R
Level 1
Level 1
 
Posts: 1
Joined: Mon Feb 04, 2013 8:35 pm

Re: Speaker Popping sound on Windows 8 after using LinuxMint

Postby nomko on Tue Feb 05, 2013 3:44 am

There was a trick for it to get rid of that popping sound. I have to look it up. I know this is an old bug or issue or thing. I remember it was already there since Ubuntu 9.04/9.10.

*edit*
That was easy to find!
Solution:
- open a terminal
- type:
Code: Select all
sudo gedit /etc/modprobe.d/alsa-base.conf

or
Code: Select all
sudo pluma /etc/modprobe.d/alsa-base.conf

(echange gedit and pluma with the notepad application you're using)
- search for the following line:
options snd-hda-intel power_save=10 power_save_controller=N
- edit this line like this:
options snd-hda-intel power_save=0 power_save_controller=N

This should solve the problem. But i'm not able to check if this is valid for the latest Mint versions... As i said, this solution worked for Ubuntu 9.04/9.10/10.04....
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
nomko
Level 9
Level 9
 
Posts: 2795
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands


Return to Hardware Support

Who is online

Users browsing this forum: papa33 and 12 guests