Broadcom BCM wireless problem

Questions about applications and software
Forum rules
Before you post please read this

Broadcom BCM wireless problem

Postby thestef on Sun Feb 03, 2013 10:49 am

I'm posting this to help any one else with issues with the Broadcom Wiress install on Linux Mint.(in my case Linux Mint 14)

This is in specific for the Broadcom BCM 4311 wireless card, however my understanding is that other Broadcom BMC models might work with the bellow fix as well. Keep reading bellow if you have issues with your Wireless card... even if your not sure on you model type.

The solution ended up being a lot simper then I expected,

I ended up finding a post on
http://askubuntu.com/questions/38387/broadcom-wireless-not-working-worked-on-live-session
Post #2 to be more specific....

Solution bellow:
*********************************************************************************************************************************************************************
I have the same wireless network card; i.e. "Broadcom Corporation BCM4311" (possibly your model may be different, which can be determined by "lspci -vvnn | grep 14e4" command in the terminal), and the same problem (no wireless connection, even I cannot see the list of wireless networks) after the 11.04 upgrade.

My problem is solved after removing "bcmwl-kernel-source" by using Synaptic Package Manager, then installing "firmware-b43-installer" and "b43-fwcutter" again by Synaptic Package Manager. I hope it solves your problem, too
**********************************************************************************************************************************************************************
The next step would be to setup your network settings to connect to your Wireless network...... SSID, password, etc, same stuff as usual to setup a regular wifi


I found that Linux Mint gets confused somehow when auto detecting the drivers during the initial install, it set's up the Broadcom STA Drivers by default, which usually do not work these Broadcom BCM cards. I believe by uninstalling the bcmwl-kernel-source packing, this actually removes all available drivers\files on the system for the STA drivers. Then by re-installing or simply installing the "firmware-b43-installer" and the "b43-fwcutter", this installs the proper b43 drivers and Linux Mint is then forced to use this driver.

I hope someone finds this during their Google search or directly on the linuxmint.com web site.

Good luck!

PS: One more thing in case the above does not work, go to the following location, go to the root directory/etc/modprobe.d, then edit blacklist.conf as root\admin user. Remove ANY references to b43 from the files, save your changes. Also make sure you do not see any other files in the modprobe.d folder location referencing b43.conf or broadcom.conf. if you see a file with any mention of b43 or broadcom, DELETE the file. This folder exist for the sole perpose of preventing Linux from running\installing\accessing files or drivers on the system to avoid driver conflics. The b43 drive for some reason somehow sometimes get added to the list.... since we need the drivers for our Broadcom Wireless we need to make sure its no long blacked listed.
thestef
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 03, 2013 10:18 am

Linux Mint is funded by ads and donations.
 

Re: Broadcom BCM wireless problem

Postby batsdude on Tue Feb 05, 2013 3:29 pm

Theres a VERY easy way to install the Broadcom BCM43XX driver! Install the Ubuntu Software manager, and you'll find a Broadcom driver and installation that does it all for you with one click! Ubuntu has native support fot BCM43xx, and its available there. It's truly incredible that Mint does NOT have built in support for it in installation, but has about every printer bloating it under the sun, with the exception of a Dell printer! Funny that you can run Braille, type in Mongolian, but cannot natively run one of the top two wireless cards in the entire world, nor run any Dell printers! Don't get me started on the PAE issue in Mint 14! Leaving PAE as a sys requirement was a HUGE error, and has discouraged literally tens of thousands of potential users!
batsdude
Level 1
Level 1
 
Posts: 7
Joined: Wed Oct 31, 2012 2:08 am


Return to Software & Applications

Who is online

Users browsing this forum: Ronshere and 20 guests