How to REQUIRE a user to Login at boot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How to REQUIRE a user to Login at boot

Postby Trainingwheels on Thu Jul 05, 2012 10:41 am

Hi.

I have noticed that Linux Mint boots immediately to the desktop. How can I set it up to boot to a Log In screen which demands a user name and password?

Thanks
Trainingwheels
Level 1
Level 1
 
Posts: 11
Joined: Thu Jul 05, 2012 10:31 am

Linux Mint is funded by ads and donations.
 

Re: How to REQUIRE a user to Login at boot

Postby remoulder on Thu Jul 05, 2012 1:41 pm

Are you referring to a live cd/dvd? If so then this is how it is meant to work, you cannot change the login. If you mean an installed system then you have to disable automatic login for the user in system settings.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: How to REQUIRE a user to Login at boot

Postby klick on Sat Feb 02, 2013 5:16 pm

I'm seeing the same thing on my Mint 14 Cinammon HD install. I have two accounts; an admin account and a limited account. I checked the "users" in System Tools and both display "Off" for automatic login. But, when I boot the system, it automatically sends me to the admin account. I can get into the user account from the admin account, but that's not the best or most expedient way to do it.

For safety's sake, I would rather log into and work from a limited account. Ideas?
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to REQUIRE a user to Login at boot

Postby DrHu on Sat Feb 02, 2013 5:25 pm

The first created account isn't a normal user, it is part of an admin group now part of the sudo group (a groups change for the desktop (OS)..))

So try creating another new user and seeing that it should require a logon as part of the desktop load sequence..
--and let us know if that works
    If it doesn't, show us the settings for that user..
    --then we'll see what might be your problem!
    limited account is a windows term
    --if terminology matters much
User avatar
DrHu
Level 16
Level 16
 
Posts: 6287
Joined: Wed Jun 17, 2009 8:20 pm

Re: How to REQUIRE a user to Login at boot

Postby klick on Sat Feb 02, 2013 5:51 pm

OK, I added another standard account with a password, auto login says "off" for this account and the others, too. I restarted the computer and it went directly to the admin account.

I recall during installation, there was an option for logging in automatically; I selected that. I wonder if thay selection might be the cause of the problem?

What settings would you need to know for the user account?
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to REQUIRE a user to Login at boot

Postby TheDynamicHamza21 on Sun Feb 03, 2013 1:56 pm

On MATE using MDM (I'm unsure what Cinnnamon uses) but in usr/share/mdm/defaults.conf file it reads:


[daemon]
# Automatic login, if true the first attached screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=


Check to see if your file says "true" instead of "false". changing it to false should work.
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: How to REQUIRE a user to Login at boot

Postby klick on Sun Feb 03, 2013 2:04 pm

TheDynamicHamza21 wrote:On MATE using MDM (I'm unsure what Cinnnamon uses) but in usr/share/mdm/defaults.conf file it reads:


[daemon]
# Automatic login, if true the first attached screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=


Check to see if your file says "true" instead of "false". changing it to false should work.



Thanks for the reply; here's what I found:

# Automatic login, if true the first attached screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=

It would appear that since the AutoLoginEnable = false, it shouldn't be logging in automatically. Hmmm.......
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to REQUIRE a user to Login at boot

Postby klick on Tue Feb 05, 2013 11:13 am

This thread has gotten a bit quiet, so I'll bump it to see if anyone has any ideas. If not, I guess I'll reinstall.

Anyone?
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to REQUIRE a user to Login at boot

Postby eanfrid on Tue Feb 05, 2013 12:48 pm

You should not modify anything in /usr/share. It is a very wrong way to set system parameters.

Current system parameters are all under /etc. Then you only have to modify "/etc/mdm/mdm.conf" by adding "AutomaticLoginEnable=false" in the "[daemon]" section. And there is even a graphical way to do this in the MDM Login manager.

Why would you reinstall your OS because a single line of text is missing ? :shock: ... an old-time Windows troubleshooting method :D ?
No, Linux is not a Windows clone for free - Before asking any question here...
"Never attribute to malice that which is adequately explained by stupidity." (Hanlon's razor)

Debian GNU/Linux Wheezy 64bit w/custom 3.12 kernel - MATE 1.8
User avatar
eanfrid
Level 6
Level 6
 
Posts: 1195
Joined: Mon Apr 30, 2012 2:49 am
Location: France

Re: How to REQUIRE a user to Login at boot

Postby klick on Tue Feb 05, 2013 3:45 pm

eanfrid wrote:You should not modify anything in /usr/share. It is a very wrong way to set system parameters.

Current system parameters are all under /etc. Then you only have to modify "/etc/mdm/mdm.conf" by adding "AutomaticLoginEnable=false" in the "[daemon]" section. And there is even a graphical way to do this in the MDM Login manager.

Why would you reinstall your OS because a single line of text is missing ? :shock: ... an old-time Windows troubleshooting method :D ?


OK, I found the /etc/mdm/mdm.conf, but it is labeled "read only" and it won't allow me to make changes. I didn't fully undestand the verbiage at the top of the file; could someone give me some info on what to do next?

Thanks!
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to REQUIRE a user to Login at boot

Postby DrHu on Tue Feb 05, 2013 4:35 pm

OK, so /etc/.. is a system area file and needs sudo (in a terminal) or gksudo prefix before selection command for the GUI settings in oreder to write changes to a file (edit..)
https://en.wikipedia.org/wiki/Filesyste ... y_Standard
http://www.ibm.com/developerworks/linux ... ml?ca=dat-
--Linux file system and contents
    There are plenty of information about Linux, its files and various users commands (bash: terminal) and usually the distribution guides/tutorials/forums or help documents to enable most users to find their way around the system and its OS operations..
    --and it is not so different from either the Windows OS or Apple OSX desktops as to be unfathomable..(at least as I see it)

http://www.linuxmint.com/rel_nadia_whatsnew.php
    I am sure you will be able to find the system settings, I think it is control but it doesn't really matter since flipping around the menus just like any other windows OS user will locate the appropriate program or file location for you, then it is a matter of finding the part of the control panel or settings to use to change user login process etc..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6287
Joined: Wed Jun 17, 2009 8:20 pm

Re: How to REQUIRE a user to Login at boot

Postby klick on Tue Feb 05, 2013 8:01 pm

I got it figured out. Thanks for all the help.

Edited to add: Here's how it got fixed: Menu> System Tools> Administration> Login Window> Security Tab.

The User Accounts section had login controls that, apparently, didn't work.
klick
Level 1
Level 1
 
Posts: 14
Joined: Fri Feb 01, 2013 8:56 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: excollier and 28 guests