Setting the screen resolution

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Setting the screen resolution

Postby Udi on Thu Feb 07, 2013 1:00 am

Hi.

My Mint system (Maya with the MATE desktop) doesn't always detect the screen resolution properly. About 50% of the times, I can only get a resolution of 1024*768 while my screen is 1600*1050...

Whenever the system boots in low resolution, I try this:
1) I open the control center and go to "Monitors". Typically, as soon as the monitors app comes up, the screen resolution adjusts itself automatically and I don't need to reboot the system.
2) If the "Monitors" app didn't help, I reboot. Typically, after the second reboot the problem solves itself.
3) Sometimes the reboot also doesn't help, and I don't know what to do anymore.

It's a desktop PC with an Intel I3-2120 processor. Not sure what the motherboard is (how can I detect it?). This is the outout of lspci, if it helps anyone:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

How can I troubleshoot this, please?

Thanks a lot in advance for any help.
Udi.
Udi
Level 1
Level 1
 
Posts: 45
Joined: Sat Dec 27, 2008 3:33 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 17 guests