[RESOLVED] Clicking a PDF file launches Audacity!

Questions about applications and software
Forum rules
Before you post please read this

[RESOLVED] Clicking a PDF file launches Audacity!

Postby RonN on Fri Feb 08, 2013 7:32 pm

I am running LMDE with MATE on a 64-bit system, fully up to date.

As far as I know, all other file types launch the correct app.
I tried uninstalling (ie. purging) audacity, but MATE now launches Libre-Office!
After re-installing Audacity, PDFs launch Audacity again!
I also tried purging and re-installing evince, but same behaviour.
I cannot find a way to configure which app is launched when a file is selected. It seems that this would be the proper way to fix this.

The only other possibly relevant fact I can point identify, is a problem during the last system upgrade. Prior to the upgrade I was happily running LMDE with Cinnamon, but after the upgrade completed, Cinnamon always fails to start. So I simply switched to MATE and it has been working fine - that is, until now.
Last edited by RonN on Mon Feb 11, 2013 3:09 pm, edited 1 time in total.
RonN
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 08, 2013 7:16 pm

Linux Mint is funded by ads and donations.
 

Re: Clicking a PDF file launches Audacity!

Postby rop75 on Sun Feb 10, 2013 3:03 pm

I use Gnome shell and to edit the default apps, you need to edit /etc/gnome(default.lists.

I am not sure whether that file exists in MATE (you can always install Gnome-shell just to edit that file, after that keep using MATE and not use GS if you don't want to). You can also try editting /home/YOURNAME/.local/share/applications/mimeapps.list AND ADD SOMETHING LIKE THIS:

application/pdf=atril.desktop
application/x-bzpdf=atril.desktop
application/x-gzpdf=atril.desktop
User avatar
rop75
Level 2
Level 2
 
Posts: 97
Joined: Sat May 05, 2012 6:08 pm

Re: Clicking a PDF file launches Audacity!

Postby RonN on Mon Feb 11, 2013 3:08 pm

Thank You rop75!
The file /home/YOURNAME/.local/share/applications/mimeapps.list somehow had audacity assigned for PDF for both Added Associations and Default Applications !
A quick edit fixed the problem!
RonN
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 08, 2013 7:16 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 8 guests