[SOLVED!!] Pygame Runs in Geany IDE But Not in IDLE 3.2

Questions about applications and software
Forum rules
Before you post please read how to get help

[SOLVED!!] Pygame Runs in Geany IDE But Not in IDLE 3.2

Postby nanometer294 on Sat Feb 09, 2013 5:16 pm

After changing the shebang line in my Python file to:

#!/usr/bin/env python3

I was able to get the graphical application I'd been working on to run, but only from within my Geany IDE, and not in IDLE, which is what I normally use to run my Python projects.

I'm just grateful the application runs in Geany, but why do I get the error shown below when I try to run it in IDLE?

Code: Select all
Traceback (most recent call last):
  File "/home/carl/Desktop/pygame1.py", line 10, in <module>
    import pygame, sys
ImportError: No module named pygame


If it helps, I'm running:

    Python 3.2.3
    IDLE for Python (version 3.2) using Tkinter
    Mint 13 "Maya" / MATE
    Kernel: 3.2.0-36 generic (X86-64)

    Acer Aspire 5742-6814
    Intel Core i3-380M (@ 2.53 GHz)
    4 GB RAM
    120 GB SSD

Thanks in advance to everyone for their assistance and thank you as well to the Mint development team. I really enjoy using Mint!

Regards,

nanometer294

******************************************************************************************************************************************
(PROBLEM APPARENTLY) SOLVED!

For the time being, at least, I got my graphical application (that uses the Pygame module) to run in IDLE (version 3.2)!

Thanks to dj188us (Post #6) for his solution!

http://forums.oreilly.com/topic/20635-confusion-with-installing-pygame-and-python-3/
nanometer294
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 09, 2013 4:43 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 22 guests