Custom Cursors?

Forum rules
Before you post please read how to get help

Custom Cursors?

Postby AKSoapy29 on Sat Feb 09, 2013 4:57 pm

Hello everyone. I have searched around a bit on how to customize cursors (Download cursor files and use them) but everything I have seen and tried hasn't worked. I have found two cursor files that I would like to use, one or the other:
http://cruxye.deviantart.com/art/Bluecu ... e-96955416
http://gnome-look.org/content/show.php/ ... ent=155025

I am using Linux Mint 14 Cinnamon 32 bit installed on a flash drive.
AKSoapy29
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 09, 2013 4:50 pm

Linux Mint is funded by ads and donations.
 

Re: Custom Cursors?

Postby cwsnyder on Sat Feb 09, 2013 7:16 pm

Did you put the cursor theme folder in /usr/share/themes or ~/.themes? Or did you try both? Did you have your permissions set to access the theme folder properly?
LMDE Mate 64-bit, LM17 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 14.10 64-bit, Xubuntu 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1042
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Custom Cursors?

Postby AKSoapy29 on Sat Feb 09, 2013 7:46 pm

What I tried before was exactly that, but it said I didn't have permissions. Where would I go to set permissions?
AKSoapy29
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 09, 2013 4:50 pm

Re: Custom Cursors?

Postby cwsnyder on Sat Feb 09, 2013 8:16 pm

To move the folder to /usr/share/themes, you would have to do it as an administrator, using sudo or gksudo from the command line, depending on how you wish to move the folder. You would have full permission to make a folder called .themes in your home folder without any resort to the command line.

You can then set the permissions on the folder by right clicking on the folder within your file manager, selecting Properties and then selecting the Permissions tab to make sure you have read, write & execute rights in the folder.
LMDE Mate 64-bit, LM17 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 14.10 64-bit, Xubuntu 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1042
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Custom Cursors?

Postby AKSoapy29 on Sat Feb 09, 2013 9:35 pm

Alright, I copied the folder over to the /usr/share/themes folder and restarted. Looking in the Cinnamon settings under themes, I don't see it. Did I do something wrong?
AKSoapy29
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 09, 2013 4:50 pm

Re: Custom Cursors?

Postby cwsnyder on Sat Feb 09, 2013 9:43 pm

Did you check your permissions for that new folder and /usr/share/themes/ ?
LMDE Mate 64-bit, LM17 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 14.10 64-bit, Xubuntu 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1042
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Custom Cursors?

Postby AKSoapy29 on Sat Feb 09, 2013 10:05 pm

Yeah. What are they supposed to look like? I can't edit them.
AKSoapy29
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 09, 2013 4:50 pm

Re: Custom Cursors?

Postby cwsnyder on Sat Feb 09, 2013 10:21 pm

Looks like you are going to have to get your hands dirty with the CLI.

Open a terminal and paste in the following:
Code: Select all
sudo chmod 777 /usr/share/themes/*
You will have to enter your password to execute the code, but you should be able to use your cursors now, if they are placed in the file structure properly.
LMDE Mate 64-bit, LM17 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 14.10 64-bit, Xubuntu 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1042
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Custom Cursors?

Postby AKSoapy29 on Sat Feb 09, 2013 10:24 pm

Alright, tried that. Will I have to restart to make it show up in the settings? If no, I must have done something wrong.

*Restarted my computer, and nothing shows up in the settings.
AKSoapy29
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 09, 2013 4:50 pm

Re: Custom Cursors?

Postby cwsnyder on Sat Feb 09, 2013 10:43 pm

I have reached the limits of my ignorance. I will have to do some investigation and get back.
LMDE Mate 64-bit, LM17 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 14.10 64-bit, Xubuntu 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1042
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Custom Cursors?

Postby SvenRieke on Wed Feb 20, 2013 5:14 am

The themes folder is not the right place.

It's the icons folder where your cursor file should go.

You have one in your home folder ~/.icons or the system wide one /usr/share/icons

I normally decompress the cursor files into ~/.icons/name_of_cursor theme, for example, mine looks like this:
$ ls ~/.icons
default Eclipse microzoa README Relic_Gold

Each of these folders contains:
$ ls ~/.icons/Eclipse/
cursors index.theme

The cursors folder contains the picture files.
You should make sure you have read permissions to these folders, f.ex.:
$ sudo chmod -R a+r ~/.icons

If you copy the files here you should have permission anyway.

Then I use Ubuntu Tweak for changing the cursor theme in the Tweaks section. You should see your cursor themes in the Popup List control.
SvenRieke
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 17, 2012 4:55 am

Linux Mint is funded by ads and donations.
 

Return to Themes, Icons, & Wallpaper

Who is online

Users browsing this forum: No registered users and 0 guests