How to add Multiarch to LMDE(SOLVED!!)

deb http://debian.linuxmint.com
Forum rules
Before you post please read how to get help

How to add Multiarch to LMDE(SOLVED!!)

Postby lmx on Fri Feb 08, 2013 7:35 pm

Hi guys...

I need(I think) to enable Multiarch to use pack6 right??

any way...i need multiarch to , to run i386 packages...so need do add a foreign arch to my amd 64 arch...

the problem is that when i do sudo dpkg --add-architecture i386 e get this error:
dpkg --add-architecture i386
dpkg: error: unknown option --add-architecture

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !

what is this???

i have dpkg installed???whats the problem...i have downloaded LMDE today, and made a fresh install...Help please.

thanks in advance..

regards
Last edited by lmx on Sat Feb 09, 2013 8:56 pm, edited 1 time in total.
Regards
lmx
lmx
Level 1
Level 1
 
Posts: 43
Joined: Thu Jul 14, 2011 4:11 pm

Linux Mint is funded by ads and donations.
 

Re: How to add Multiarch to LMDE

Postby zerozero on Fri Feb 08, 2013 7:39 pm

hi,
first update and dist-upgrade your install as if multiarch never existed :lol: then when that task is finished you can follow this >> http://forums.linuxmint.com/viewtopic.php?f=190&t=122296
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to add Multiarch to LMDE

Postby lmx on Sat Feb 09, 2013 1:00 pm

Thanks i have done it...

But i have a problem...

I need to install Cisco Packet tracer 5.3.3 i386 package...

This package have Qt dependencies....

I install it but i can't figure out what dependencies it need...its a static package...it don't download all the packages needed automatically...

the libraries that came with it are broken i think, because i launch it but nothing happed...

I have tried to install an amount of libraries but without success...i m lost :(

How can i install i386 libraries in a amd64 system?

I use apt-cache search to found packages...but they are amd64 and not i386?
I can t install libraries for it ...it doesn't start.

Help please...

Thanks in advance

Regards
Regards
lmx
lmx
Level 1
Level 1
 
Posts: 43
Joined: Thu Jul 14, 2011 4:11 pm

Re: How to add Multiarch to LMDE

Postby zerozero on Sat Feb 09, 2013 7:38 pm

ok, i'm not familiar with that pkg but a google search takes me here >> http://crunchbang.org/forums/viewtopic.php?id=19917 (apparently very similar problem) and from there here >> http://kaslnetwork.com/articles/installing-cisco-packettracer-5-3-2-on-64-bit-ubuntu-or-debian/
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to add Multiarch to LMDE

Postby lmx on Sat Feb 09, 2013 8:55 pm

Hi,
thanks for the help...

Some times google is our friend ...sometimes don't...

I have solved it with :
adding a foreign i386 arch.
installing the Cisco Packet tracer 5.3.3...
After that i have installed a tone of packages without know what packages i need in fact...
apt-get install libqt4-webkit:i386 libqt4-core:i386 libqt4-assistant:i386 libqt4-dbus:i386 libqt4-dev:i386 libqt4-gui:i386 libqt4-help:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386 libqt4-svg:i386 libqt4-xml:i386

well a lot of space more than 100 MB was stolen from me in my system, but when you need something and you don get it , you will do almost everything(not bad things a think lol) to achieve the goal...

Hell yaahhh :evil: I have PACKET TRACER 5.3.3 Running ;)

thanks

Ps:I think that sometimes the LMDE team are trying to burn the entire project...be careful with what are your wishes...(Maybe you don't realized yet, but this is the most important project that Mint have...).
Last edited by lmx on Sat Feb 09, 2013 11:18 pm, edited 1 time in total.
Regards
lmx
lmx
Level 1
Level 1
 
Posts: 43
Joined: Thu Jul 14, 2011 4:11 pm

Re: How to add Multiarch to LMDE(SOLVED!!)

Postby zerozero on Sat Feb 09, 2013 8:59 pm

lmx wrote:(Maybe you don't realized yet, but this is the most important project that Mint have...).
well, it is for me anyway :wink:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm


Return to Update Packs Repositories

Who is online

Users browsing this forum: No registered users and 2 guests