mint boots into gnome, not cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

mint boots into gnome, not cinnamon

Postby arnodf on Fri Feb 08, 2013 4:07 pm

Hi,


When using the Nvidia drivers my system always boots into Gnome rather than Cinnamon after I log in. I always have to log out and, without explicitly selecting the cinnamon DE, log back in and I get Cinnamon. I tried using the nouveau drivers again to see if the problem remained but here I didn't have this problem. In this post it's mentioned that there's no hardware acceleration and therefore the system can't boot into cinnamon and boots to gnome instead.
I need the nvidia drivers for steam and other games so using nouveau is not an option. How can I make sure the nvidia drivers are properly loaded before I log in?

Thanks in advance!

Here is my sys info:

Code: Select all
$ inxi -Fc0
System:    Host: arno-laptop Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine:   System: - product: N/A
           Mobo: - model: IFL90 version: IFT00 Bios: COMPAL version: 1.12 date: 08/29/2007
CPU:       Dual core Intel Core2 Duo CPU T8300 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx)
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics:  Card: NVIDIA G84 [GeForce 8600M GT]
           X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa,nouveau) FAILED: nvidia Resolution: 1440x900@59.9hz
           GLX Renderer: GeForce 8600M GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.43
Audio:     Card: Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Network:   Card-1: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express driver: tg3
           IF: eth0 state: down mac: xxxxxxxxx
           Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection driver: iwl4965
           IF: wlan0 state: up mac: xxxxxxxxx
Drives:    HDD Total Size: 162.0GB (45.7% used) 1: id: /dev/sda model: ST9160823AS size: 160.0GB
           2: USB id: /dev/sdb model: USB_Flash_Disk size: 2.0GB
Partition: ID: / size: 92G used: 69G (80%) fs: ext4 ID: swap-1 size: 6.54GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 28.0C mobo: N/A gpu: 62C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 148 Uptime: 8 min Memory: 559.4/3953.5MB Client: Shell inxi: 1.8.4
arnodf
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 08, 2013 2:53 pm

Linux Mint is funded by ads and donations.
 

Re: mint boots into gnome, not cinnamon

Postby karlchen on Sun Feb 10, 2013 4:57 pm

Hello, arnodf.

Actually the screen output of
Code: Select all
inxi -Fx
would be more useful than the screen output created by
Code: Select all
inxi -Fc0

There is on particular detail which is missing, a detail about direct rendering.
Could you, please, run
Code: Select all
inxi -Gx
and post the output.
Thanks.

Karl
--
P.S.:
Have ever tried this?
The logon dialogue appears. It has got three icons at the bottom. The middle icon will allow you to select the session type which you want to use, Cinnamon, Cinnmon 2D, Gnome 3, Gnome 3 Fallback. Select "Cinnamon" explicitly and log in.
Do you get Cinnamon now?
User avatar
karlchen
Level 11
Level 11
 
Posts: 3984
Joined: Sat Dec 31, 2011 7:21 am

Re: mint boots into gnome, not cinnamon

Postby arnodf on Tue Feb 12, 2013 5:26 pm

Hi and thanks for taking the time.
here it is:
Code: Select all
Graphics:  Card: NVIDIA G84 [GeForce 8600M GT] bus-ID: 01:00.0 X.Org: 1.13.0 driver: nvidia Resolution: 1440x900@59.9hz
           GLX Renderer: GeForce 8600M GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.43 Direct Rendering: Yes
arnodf
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 08, 2013 2:53 pm

Re: mint boots into gnome, not cinnamon

Postby karlchen on Sat Feb 16, 2013 9:12 am

Hello, arnodf.

Sorry for not having replied for a few days. :oops:
Have you tried to select "Cinnamon" explicitly in the logon screen once? (middle icon out of 3)

Your inxi output does not give a hint why Cinnamon should not come up after you logon.
My NVidia Geforce 8500 GT does not cause any such problem (Mint 13, NVidia driver 295.40). Neither does the NVIDIA ION VGA (Mint 14, NVidia driver 304.64).
Got and installed the NVidia driver 304.64 from the Ubuntu NVidia Swat PPA.

Kind regards,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3984
Joined: Sat Dec 31, 2011 7:21 am

Re: mint boots into gnome, not cinnamon

Postby arnodf on Sun Feb 17, 2013 9:53 am

Well, I'm glad your trying to help. :)

I've tried selecting it explicitly many times, hoping this time it would work but to no avail.

I tried using the drivers you use and than the proprietary nvidia drivers version 310 but neither changed a thing.

I've been looking at /var/log but don't really know where to look. This is what I've been able to find so far:
Code: Select all
$ cat /var/log/kern.log | grep nvidia
Feb 17 14:04:22 arno-laptop kernel: [  227.484570] nvidia: module license 'NVIDIA' taints kernel.
Feb 17 14:04:22 arno-laptop kernel: [  227.508315] nvidia 0000:01:00.0: >power state changed by ACPI to D0
Feb 17 14:04:22 arno-laptop kernel: [  227.508324] nvidia 0000:01:00.0: >power state changed by ACPI to D0
Feb 17 14:14:50 arno-laptop kernel: [  197.064324] nvidia: module license 'NVIDIA' taints kernel.
Feb 17 14:14:50 arno-laptop kernel: [  197.085865] nvidia 0000:01:00.0: >power state changed by ACPI to D0
Feb 17 14:14:50 arno-laptop kernel: [  197.085875] nvidia 0000:01:00.0: >power state changed by ACPI to D0
Feb 17 14:30:13 arno-laptop kernel: [  218.220173] nvidia: module license 'NVIDIA' taints kernel.
Feb 17 14:30:13 arno-laptop kernel: [  218.237910] nvidia 0000:01:00.0: >power state changed by ACPI to D0
Feb 17 14:30:13 arno-laptop kernel: [  218.237920] nvidia 0000:01:00.0: >power state changed by ACPI to D0


This is interesting, a few lines from /var/log/boot.log:
Code: Select all
 * Starting load fallback graphics devices                               [ OK ] <==
 * Starting configure network device security                            [ OK ]
 * Starting configure virtual network devices                            [ OK ]
 * Starting load fallback graphics devices                               [fail] <==
 * Starting set console font                                             [ OK ]


Here are some snippets from var/log/Xorg.0.log but nothing interesting I guess:
Code: Select all
[   237.804] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   237.804] (==) NVIDIA(0): RGB weight 888
[   237.804] (==) NVIDIA(0): Default visual is TrueColor
[   237.804] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   237.852] (**) NVIDIA(0): Enabling 2D acceleration
[   239.037] (II) NVIDIA(GPU-0): Display (cPATH (DFP-0)) does not support NVIDIA 3D Vision
[   239.037] (II) NVIDIA(GPU-0):     stereo.
[   239.039] (II) NVIDIA(0): NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)
[   239.039] (--) NVIDIA(0): Memory: 524288 kBytes
[   239.039] (--) NVIDIA(0): VideoBIOS: 60.84.42.00.23
[   239.039] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   239.043] (--) NVIDIA(0): Valid display device(s) on GeForce 8600M GT at PCI:1:0:0
[   239.043] (--) NVIDIA(0):     CRT-0
[   239.043] (--) NVIDIA(0):     TV-0
[   239.043] (--) NVIDIA(0):     cPATH (DFP-0) (connected)
[   239.043] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[   239.043] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[   239.043] (--) NVIDIA(0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   239.043] (--) NVIDIA(0): cPATH (DFP-0): Internal Dual Link LVDS
[   239.043] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   239.043] (**) NVIDIA(0):     device cPATH (DFP-0) (Using EDID frequencies has been
[   239.043] (**) NVIDIA(0):     enabled on all display devices.)
[   239.044] (==) NVIDIA(0):
[   239.044] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   239.044] (==) NVIDIA(0):     will be used as the requested mode.
[   239.044] (==) NVIDIA(0):
[   239.044] (II) NVIDIA(0): Validated MetaModes:
[   239.044] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   239.044] (II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
[   240.076] (--) NVIDIA(0): DPI set to (110, 108); computed from "UseEdidDpi" X config
[   240.076] (--) NVIDIA(0):     option
[   240.076] (--) Depth 24 pixmap format is 32 bpp
[   240.076] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[   240.110] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   240.462] Loading extension NV-GLX
[   240.605] (==) NVIDIA(0): Disabling shared memory pixmaps
[   240.605] (==) NVIDIA(0): Backing store disabled
[   240.605] (==) NVIDIA(0): Silken mouse enabled
[   240.606] (**) NVIDIA(0): DPMS enabled
[   240.606] Loading extension NV-CONTROL
[   240.606] Loading extension XINERAMA
[   240.606] (II) Loading sub module "dri2"
[   240.606] (II) LoadModule: "dri2"
[   240.606] (II) Module "dri2" already built-in
[   240.606] (II) NVIDIA(0): [DRI2] Setup complete
[   240.606] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   240.606] (--) RandR disabled
[   240.611] (II) Initializing extension GLX

[   285.618] (II) NVIDIA(GPU-0): Display (cPATH (DFP-0)) does not support NVIDIA 3D Vision
[   285.618] (II) NVIDIA(GPU-0):     stereo.
[   285.618] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   285.618] (**) NVIDIA(0):     device cPATH (DFP-0) (Using EDID frequencies has been
[   285.618] (**) NVIDIA(0):     enabled on all display devices.)
[   296.331] (II) XKB: reuse xkmfile /var/lib/xkb/server-ED74282979563E81BD66F5EFFC067FDB289EACCF.xkm
[   303.229] (II) NVIDIA(GPU-0): Display (cPATH (DFP-0)) does not support NVIDIA 3D Vision
[   303.229] (II) NVIDIA(GPU-0):     stereo.
[   303.229] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   303.229] (**) NVIDIA(0):     device cPATH (DFP-0) (Using EDID frequencies has been
[   303.229] (**) NVIDIA(0):     enabled on all display devices.)


thanks for your help so far!
arnodf
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 08, 2013 2:53 pm

Re: mint boots into gnome, not cinnamon

Postby arnodf on Mon Feb 18, 2013 9:25 pm

what I've done so far is change /usr/share/gnome-session/sessions/cinnamon.session
Here I changed the line FallbackSession=gnome-fallback to FallbackSession=cinnamon2d so at least I have cinnamon in 2d if I don't feel like loggin in twice.
note that on github for cinnamon this is in fact a pull request so the default should be cinnamon2d in future releases.
arnodf
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 08, 2013 2:53 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 13 guests