Samba share password not saved.

Samba share password not saved.

Postby paradox on Tue Dec 18, 2012 5:53 am

Hi all, i have my small smb server setup like this: http://pastebin.com/1XTUXgxi on debian stable amd64.
I've always been able to "Remember Forever" my smb password so that i could instantly access my shares without having to login every time.
If i recall correctly though, a package update i made months ago ruined it all. Now i have to type username and password every goddamn time.
Is this a problem concerning Caja, the keyring or my server configuration?
Using Mint 13 MATE x86.
paradox
Level 1
Level 1
 
Posts: 9
Joined: Mon Dec 17, 2012 10:42 am

Linux Mint is funded by ads and donations.
 

Re: Samba share password not saved.

Postby n1b5 on Fri Jan 18, 2013 10:44 am

Hi paradox

Still not had any replies for this issue? I'm hunting around atm on the forums and search engines, but to no avail. Have you managed to sort it? Of interest in Peppermint2 I get a similar issue but always quit the log in and still access my NAS (which is the object of the samba use); however does not work in Mint (maya). Sadly my memory is rubbish and I cannot remember how it used to work in Ubuntu - but fair to say I often had issues with networking in Ub.
n1b5
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 18, 2013 10:39 am

Re: Samba share password not saved.

Postby paradox on Fri Jan 18, 2013 11:54 am

Nope, no answers.
In ubuntu i remember i used to simply access my SMB server by inserting username\password, selecting "remember forever" and that was it.
paradox
Level 1
Level 1
 
Posts: 9
Joined: Mon Dec 17, 2012 10:42 am

Re: Samba share password not saved.

Postby Troken on Mon Feb 04, 2013 3:39 pm

I have the same problem and it is very annoying. Have a Synology NAS that needs password every time, never remembered.

On linux Mint 14 mate
User avatar
Troken
Level 3
Level 3
 
Posts: 110
Joined: Mon Nov 16, 2009 3:56 am

Re: Samba share password not saved.

Postby Somnus on Sun Feb 10, 2013 6:23 pm

Same problem here (connecting to Synology NAS using smb) - does not store passwords in Mint 14 (64bit), but did in Ubuntu 12.04
Somnus
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 10, 2013 5:34 pm

Re: Samba share password not saved.

Postby Troken on Sun Feb 10, 2013 6:32 pm

Did it work in Ubuntu? Hm... might try it on that computer. It's pretty much impossible to work and to constantly type in passwords.
User avatar
Troken
Level 3
Level 3
 
Posts: 110
Joined: Mon Nov 16, 2009 3:56 am

Re: Samba share password not saved.

Postby altair4 on Sun Feb 10, 2013 6:55 pm

The command that actually connects to and mounts the share can be passed parameters:

Code: Select all
gvfs-mount smb://server/share < /home/altair/creds


/home/altair/creds must have the user name, workgroup, and password - one per line - for the NAS device like this:
Code: Select all
altair
workgroup
altair-nas-password


You can automate this by creating a file at say ... /home/altair/NAS_Mounter with this content:
Code: Select all
#! /bin/bash
gvfs-mount smb://server/share < /home/altair/creds
caja /run/user/altair/gvfs

Make it executable then create a launcher on your desktop with a command that points to the /home/altair/NAS-mounter script. Double click the launcher and it will authenticate, mount, and launch caja to the mount point.

Is this a butt-ugly workaround? You betcha but it's the best I can do at the moment.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6131
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba share password not saved.

Postby Troken on Sun Feb 10, 2013 7:11 pm

Thank you, I bet it works but it seems complicated for a simple user like me. :-)
User avatar
Troken
Level 3
Level 3
 
Posts: 110
Joined: Mon Nov 16, 2009 3:56 am

Re: Samba share password not saved.

Postby altair4 on Sun Feb 10, 2013 7:20 pm

I understand. Seahorse is the thing that saves and remembers the password and it appears there either is no seahorse or it doesn't work in MATE. Sorry, I'm an XFCE user and only have MATE as a VBox guest so I'm not an expert of it's inner workings.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6131
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba share password not saved.

Postby Somnus on Sun Feb 10, 2013 7:32 pm

Yes this script works (thanks altair4). Just realised I am posting in the Mate forum; I am in Mint 14 Cinnamon (so changed the caja line to nemo).
I think you would have to create a new line for each shared folder on the NAS... haven't tried this (but couldn't access other shared folders not mentioned in the script).

I am not keen on keeping the password in the clear as a text file. And as you say, the actual mechanism for keeping the password seems broken (so I guess this is not properly solved?)
Somnus
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 10, 2013 5:34 pm

Re: Samba share password not saved.

Postby myrkat on Sun Feb 09, 2014 6:53 pm

altair4 wrote:The command that actually connects to and mounts the share can be passed parameters:
Code: Select all
gvfs-mount smb://server/share < /home/altair/creds

/home/altair/creds must have the user name, workgroup, and password - one per line - for the NAS device like this:
Code: Select all
altair
workgroup
altair-nas-password

You can automate this by creating a file at say ... /home/altair/NAS_Mounter with this content:
Code: Select all
#! /bin/bash
gvfs-mount smb://server/share < /home/altair/creds
caja /run/user/altair/gvfs

Make it executable then create a launcher on your desktop with a command that points to the /home/altair/NAS-mounter script. Double click the launcher and it will authenticate, mount, and launch caja to the mount point.

Is this a butt-ugly workaround? You betcha but it's the best I can do at the moment.


Sorry to resurrect a year-old post, but I was wondering if this was still the best "butt-ugly" workaround, or if something better/gui'd had been found. Searching for the problem still pulls this page up, so it must be still pertinent for many users.

I get the "forgotten password" thing on my smb shares under Mint 16 Xfce (x64) for both thunar and nautilus. I don't mind hitting the cli to set up altair4's workaround, but was hoping there would be something built in by now, or a setting to tweak.
Main Comp: i7-4770K @ 3.5GHz + nVidia 760GTX + 16GB RAM + SSD + HDD
Linux Mint 17 - KDE
SteamOS Beta
Windows 8.1 Pro x64 (only for Xara)
User avatar
myrkat
Level 1
Level 1
 
Posts: 35
Joined: Sun Feb 02, 2014 7:10 pm

Re: Samba share password not saved.

Postby altair4 on Sun Feb 09, 2014 7:06 pm

Actually, the kids found their way into dad's toolbox and managed to make a mess of gvfs so I've moved back to AutoFS to have these share "automount".

No way to set this up with a GUI - as far as I know - but if you're interested here's a HowTo: HowTo: Auto Mounting Samba Shares Using AutoFS

No more gvfs - no more seahorse - no more lions or tigers or bears ..........
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6131
Joined: Tue Feb 03, 2009 10:27 am

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: No registered users and 8 guests